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Welcome to XMetaL Author

XMetaL Author is a graphical editor for creating and editing structured documents. It provides a highly
configurable user interface and a powerful array of authoring tools.You can use XMetaL to create XML
documents in any language, regardless of your XML knowledge.

The user interface features multiple document views, customizable toolbars, and tear-off menus.The Resource
Manager provides drag-and-drop management of text blocks, images, and other assets.

You can tailor XMetaL Author to fit your organization’s workflow and graphical standards through
customizations. A sample customization, Journalist, is provided as an example. Customizations determine
how your information is presented and much of the authoring functionality.

Other XMetaL publications

APIs and other programming features such as scripts, forms, controls, and macros are described in the
XMetaL Programmer’s Guide. The XMetaL Customization Guide describes how to create and deploy
customizations. These publications are distributed with XMetaL Developer and are available for download
from the JustSystems website at http://na.justsystems.com.

Feedback

Send your comments or questions about XMetaL documentation to XMetaL Support.

Copyright

© 2025 JustSystems Canada, Inc. All rights reserved.
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Quick tour

The user interface provides access to all editing operations and allows you to create a custom environment
that is tailored to your preferences.You can select a preferred view and choose panes and toolbars to
frequently used tasks.

Getting help

Context-sensitive Help is provided in all XMetaL Author dialogs.You can also access online Help and search
for information through the Help menu.

Sample files

Sample files are provided to demonstrate various aspects of XMetaL Author functionality. When a document
is open, you can view sample files through Help > Samples.

Your working copies of the sample files are saved to the following location:
%APPDATA%\SoftQuad\XMetaL\<version>\Samples.You can restore the sample files by deleting this
folder and re-opening the sample files.

Document views
You can choose a view for your document through the View menu or from the view buttons in the document
status bar. The view you select depends on how you want to work with your document.You can set view
options, including a default view through Tools > Options.

Normal view

In Normal view, your documents appear similar to how they would appear in a word processor. Only the
content of your document is visible; the underlying markup is not displayed. Formatting is determined by a
Cascading Style Sheet. Structured authoring commands are available from the menus, and rules checking
is active.

9© 2025 JustSystems Canada, Inc.



Tags On view

In Tags On view, both the content and markup (for example, element start and end tags) of your document
are visible. This view is useful for navigating the element hierarchy and positioning the insertion point.
Formatting is determined by a Cascading Style Sheet. Structured authoring commands are available from
the menus, and rules checking is active.

Here are some of the features available in Tags On view:

• You can select an entire element by clicking its start or end tag.

• You can collapse or expand tags through the right-click menu.

• You can view all set attributes by resting the pointer over a tag.

Plain Text view

In Plain Text view, the markup and content of your document are displayed as text only. Rules checking is
not active in Plain Text view, and you are not prevented from entering invalid markup. However, you can still
validate your document.

Note:  Not all commands are available in Plain Text view.

Plain Text view is color-coded so that you can easily identify elements, attributes, and text.You can set plain
text view options, including line numbering, colors, and wrapping.

XMetaL Author Help10
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If you enter markup characters (for example, ‘<’, ‘>’, and ‘&’) in Plain Text view, they are interpreted as markup
when you switch to another view. If you want to prevent the characters from being interpreted as markup,
you need to enclose them in a CDATA section.

Page Preview

Page Preview allows you to view your document using a Web browser. This view is read-only; you cannot
edit your document in Page Preview. Formatting is determined by a Cascading Style Sheet.

Note: The default browser is Microsoft Internet Explorer.

Follow these stepsTo do this

Click View > Page PreviewView a document using the default browser

Click File > Preview in Browser and select a browserView a document using a browser

Click File > Preview in Browser, click Add and select a
browser

Add a browser to the list of available browsers

Click File > Preview in Browser, select a browser and click
Delete

Remove a browser from the list of available browsers

Tip: You can also use the Preview toolbar to view a document using a selected browser. Click a blank
Preview toolbar button to associate it with a Web browser.

Related Links
Options on page 55

You can set options through the Tools menu.

Inserting CDATA sections on page 124
You can insert CDATA sections using the Insert menu.

Authoring structured content on page 103
When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL
Author ensures that your content is valid by guiding you through the authoring process.You do not
need to have a complete understanding of XML to begin authoring structured content.

Specify tag and tag text colors

1. Click Tools > Options and click the View tab.

2. Click one of the following:

• Foreground (for tag text)
• Background (for tag background)

11© 2025 JustSystems Canada, Inc.
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3. Choose a color.

Tip: You can specify custom tag and text colors by creating a custom palette.

Structure View
Structure View displays the overall structure or information hierarchy of the document.You can select Structure
View from the View menu.

Structure View inherits the styles of the main document. It also has its own style sheet for each DTD or
Schema that you use.

In Structure View, you can insert, cut, paste, copy, and drag-and-drop elements.

Related Links
Customizing the user interface on page 23

You can customize the user interface to give you quick access to tasks and assets.You can make
your changes available to all users or reserve them for your use only. Likewise, your changes can
apply only to documents that use a specific DTD or Schema, or to all documents.

Options on page 55
You can set options through the Tools menu.

XMetaL Author Help12
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Panes
Panes provide access to the markup in your document and let you organize resources.You can have one
or more panes open in your work area at any time.You can dock a pane so that it is attached to the work
area border, or the pane can float.You can pin a pane to keep it open, or un-pin a pane to hide it.

Follow these stepsTo do this

Show/hide a pane
• Click the View menu and select a pane to show or hide it, or
• Right-click on the pane header (or click the Window Position icon), and select Hide

from the menu to hide a menu.

Dock a pane
• Double-click the title bar, or
• Click and hold the title bar, and then drag the pane to its docked position, or
• Right-click on the pane header (or click the Window Position icon), and select Docking

from the menu.

When you are docking a pane, docking hotspot indicators appear.While dragging
a pane, you may move your mouse cursor over one of the indicators. When you
release the mouse, the pane you are docking will snap to the indicated docking
position.

Un-dock a pane (make it
float) • Double-click the title bar, or

• Click the title bar and drag the pane from its docked position, or
• Right-click on the pane header (or click the Window Position icon), and select Floating

from the menu.

Click the sideways pin (pins are displayed sideways when a pane is un-pinned)Pin a pane

Un-pin (auto hide) a pane
• Click the upright pin (pins are displayed upright when a pane is pinned), or
• Right-click on the pane header (or click the Window Position icon), and select Auto

hide from the menu.

When a pane is un-pinned, placing the cursor on the pane's tab slides open the
pane.

The following panes are available:

13© 2025 JustSystems Canada, Inc.
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• Attribute Inspector. Displays the attributes for the current element and lets you set attribute values.

Follow these stepsTo do this

Sort attributes alphabetically
1. Hover the mouse over the Attribute Inspector pane.

2. Right-click to display the action menu.

3. Select Sort Attributes.

Sort attributes by displaying required attributes at the top

of the list

NOTE: Secondary sorting is alphabetically

1. Hover the mouse over the Attribute Inspector pane.

2. Right-click to display the action menu.

3. Select Sort Attributes (Required First).

Sort attributes by displaying those that include a value, at

the top of the list

NOTE: Secondary sorting is alphabetically

1. Hover the mouse over the Attribute Inspector pane.

2. Right-click to display the action menu.

3. Select Sort Attributes (Value First).

• Element List. Lets you insert or change elements in your document. In Normal and Tags On views, displays
the list of elements that are valid at the insertion point (All tab), or the list of elements that are valid at the
insertion point and are currently used in your document (Used tab). Elements that are required in the current
context are displayed in bold. In Plain Text view, all elements are displayed.

XMetaL Author Help14
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• Resource Manager. Provides access to assets including images, cascading style sheets, and scripts. The
Resource Manager pane also includes the Map Editor.

• Results. Displays the results for cross-file operations, Validation, XInclude, Reference Checking, Topic
References, and Key References.

Related Links
Working with elements on page 107

Elements are the building-blocks of your documents. They are defined in your DTD or Schema.
Authoring in Normal view is similar to applying styles, whereas Tags On view lets you work with
elements as structural objects.You can insert elements using the Element List, the Insert menu, or
the In-place, look-ahead element list.

Setting attribute values on page 110
You can set attribute values through the Attribute Inspector.

15© 2025 JustSystems Canada, Inc.
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Results pane on page 97
The Results pane displays the results of cross-file operations, such as the Find in Files feature, and
error-reporting features, such as the Validation Log.

Assets (unsupported) on page 50
You can organize frequently used objects as assets through the Resource Manager. Assets can be
single files, such as images, text, or markup blocks.You can drag and drop assets into your document.

Map EditorThe Map Editor lets you perform map-specific functions and edit element and map editor properties. The
Map Editor is included in the Resource Manager.

Toolbars
You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.

Table 1: Standard toolbar

DescriptionNameButton

Opens the New dialog or opens a new
document based on the default
template

New Page

Opens the Open dialogOpen

Saves the active documentSave

Saves all open documentsSave All

Opens the Find and Replace dialogFind and Replace

Finds the next occurrence of the text
string in the Find field of the Find and
Replace dialog

Find Next

Opens the Spell CheckerCheck Spelling

Removes the selected text or
element(s) to the clipboard

Cut

Copies the selected text or element(s)
to the clipboard

Copy

Pastes the contents of the clipboardPaste

Reverses the last actionUndo

Redoes the last reversed actionRedo

Inserts an image elementInsert Image

Inserts a table element and all required
child elements

Insert Table

Opens the Element ListInsert Element

Opens (or closes) the Resource
Manager

Resource Manager

Makes the previous document in the
list of open documents the active
document

Previous Document

XMetaL Author Help16
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DescriptionNameButton

Makes the next document in the list of
open documents the active document

Next Document

Validates the active documentValidate Document

Opens the online HelpHelp Contents

Table 2: Formatting toolbar

DescriptionNameButton

Lists the elements that can be inserted
at the cursor location

Style Element

Applies or inserts an element
designated as bold

Bold

Applies or inserts an element
designated as italic

Italics

Applies or inserts an element
designated as underscore

Underscore

Applies or inserts an element
designated as overline

Overline

Applies or inserts an element
designated as strikethrough (or line-
through)

Strikethrough

Inserts an element designated as an
ordered (numbered) list

Numbered List

Inserts an element designated as an
unordered (bulleted) list

Bulleted List

Decreases the indent of a list itemDecrease Indent

Increases the indent of a list itemIncrease Indent

Opens the Insert Cross-Reference
window

Cross-Reference

Table 3:Table toolbar

DescriptionNameButton

Opens the Insert Table dialogInsert Table

Opens the Table Properties dialogEdit Table Properties

Adds an empty row above the current
row

Insert Row Above

Adds an empty row below the current
row

Insert Row Below

Deletes the current rowDelete Row

Adds an empty column to the left of the
current column

Insert Column Left

17© 2025 JustSystems Canada, Inc.
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DescriptionNameButton

Adds an empty column to the right of
the current column

Insert Column Right

Deletes the current columnDelete Column

Moves the current row up one rowMove Row Up

Moves the current row down one rowMove Row Down

Moves the current column to the left by
one column

Move Column Left

Moves the current column to the right
by one column

Move Column Right

Merges the current cell with the cell to
the right

Merge Cell Right

Merges the current cell with the cell to
the left

Merge Cell Left

Merges the current cell with the cell
above

Merge Cell Up

Merges the current cell with the cell
below

Merge Cell Down

Splits the current cell into two cells
horizontally

Split Cell into Rows

Splits the current cell into two cells
vertically

Split Cell into Columns

Table 4:Table Advanced toolbar

DescriptionNameButton

Inserts an empty cell to the left of the
active cell

Contract Cell from Left

Inserts an empty cell to the right of the
active cell

Contract Cell from Right

Inserts an empty cell below the active
cell

Contract Cell from Bottom

Inserts an empty cell above the active
cell

Contract Cell from Top

Table 5: Macros toolbar

DescriptionNameButton

Runs the selected macroRun Current Macro

Shows the selected macroSelect Current Macro

Records all keystrokes as a new macroRecord Macro

Stops recording keystrokes to the new
macro

Stop Recording

Opens the Macros dialogMacros

XMetaL Author Help18
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Table 6: Reviewing toolbar

DescriptionNameButton

Turns change tracking on (off)Track Changes

Goes to and selects the previous
tracked change

Previous Change

Goes to and selects the next tracked
change

Next Change

Accepts the current changeAccept Change

Rejects the current changeReject Change

Opens the Accept or Reject Changes
dialog

Accept or Reject Changes

Shows the Revision Mark Options tabRevision Mark Options

Table 7: Views toolbar

DescriptionNameButton

Displays the active document in Plain
Text view

Plain Text

Displays the active document in Tags
On view

Tags On

Displays the active document in Normal
view

Normal

Displays the active document in a
browser

Browse

Opens (closes) the Attribute InspectorAttribute Inspector

Opens (closes) the Element ListInsert Element Window

Opens (closes) the Resource ManagerResource Manager

Opens (closes) full-screen modeFull screen

Table 8: Whiteboard toolbar

DescriptionNameButton

Displays a selection of favorite
whiteboard commands

Show favorites

This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 25 dialog

Customizable

This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 25 dialog

Customizable

This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 25 dialog

Customizable
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DescriptionNameButton

This button can be customized in the
Set customizable buttons in
Whiteboard toolbar on page 25 dialog

Customizable

Displays the Add to Favorites dialogAdd to favorites...

Displays the Run Macro dialogApplication utilities

Displays the Open Document dialogOpen document Ex

Displays a list of all available
commands in XMetaL

Find and execute XMetaL command

Preview toolbar

You use the buttons on the Preview toolbar to display your document in a browser. The default browser is
Microsoft Internet Explorer. The Preview toolbar also has blank buttons that you can associate with other
browsers.

Special Characters and Symbols toolbars

The Special Characters toolbar contains accented letters and other characters that are used in European
languages but that do not have corresponding keys on US English keyboards. The Symbols toolbar contains
special punctuation characters, currency symbols, math symbols, and other symbols. Click a button to insert
a special character or symbol in your document.

Related Links
Character encoding on page 65

XMetaL Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetaL Author use UTF-8 encoding.

Special characters and symbols on page 123
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Custom toolbars and menus on page 23
You can create new toolbars and menus and customize existing ones.You can assign buttons and
menus to built-in commands or user-defined macros.

Display mode
You can choose how much space to allocate for displaying your documents.You can also choose to display
your documents in a tabbed interface so that you can easily switch between open documents.

Follow these stepsTo do this

Click View > Full ScreenView a document in full-screen mode

In full-screen mode, the document display area expands to fill the screen, with only the menu bar visible.You
can display other panes and views in full-screen mode.

XMetaL Author Help20
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Licensing

The licensing feature allows you to register and manage your XMetaL license.

You can view/edit your licensing information by clicking Help > Licensing.The following fields will be displayed:

• License Type - Displays the type of license; either Per-Seat, Concurrent, or Leased Concurrent.

• Licensee - Displays the name of the licensee.

• License Count - Displays the number of seats that apply to this license.

• Maintenance End - Displays the date when the maintenance contract for this license expires.

Activating XMetaL Author
Activating XMetaL Author is required in order for the software to be fully licensed. The license information
required for activation is provided by a license file, or by a licensing server at your company.

When XMetaL is started without a full license, you will be prompted to activate the software or continue your

trial:

• Activate - Allows you to insert a license file. Choose this option if you have been supplied with a license
file. Possible names for the license file include XMEE.lic, XMES.lic and XMLS.lic. When the license
is verified, you are ready to use the software.

Note:  If you have a license for a version of XMetaL earlier than 9.0, you will need to contact your
system administrator or http://xmetal.com/support for an updated XMetaL Author license file.

• Continue Trial - Allows you to continue with the trial version of XMetaL. The trial lasts 30 days from the
time of installation.

• Exit - closes XMetaL.

21© 2025 JustSystems Canada, Inc.
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Removing XMetaL Author License
Removing XMetaL Author from a certain machine and will allow you to use the license on another machine.
Concurrent licenses are automatically returned upon exit of XMetaL Author, leaving the local copy of XMetaL
Author deactivated.

1. Click Help > Licensing

2. Click Remove License.

3. Click Ok when the confirmation window pops up.
A dialog will appear asking you to activate the software; you may choose to activate or to exit the program.

Note:  XMetaL Author will prompt you to save your work upon exit.

Access Key
An access key, if required by your system administrator, allows you to use XMetaL Author in Concurrent or
Leased Concurrent mode.

An access key may be required to receive a concurrent license. If you do not know the access key, contact
your system administrator.

XMetaL Author Help22
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Customizing the user interface

You can customize the user interface to give you quick access to tasks and assets.You can make your
changes available to all users or reserve them for your use only. Likewise, your changes can apply only to
documents that use a specific DTD or Schema, or to all documents.

Related Links
Specify tag and tag text colors on page 11
Spell checker options on page 80

You can specify Spell Checker options through Tools > Spell Checker.Your settings are applied
the next time you open the spell checker.

Language settings on page 88
You can choose a language for the current file or set it as the default language for the spell checker
and thesaurus.You can also add and remove languages.

Thesaurus options  on page 90
You can specify thesaurus options through Tools > Thesaurus.Your settings are applied the next
time you open the thesaurus.

XMetaL customizations on page 106
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Custom toolbars and menus
You can create new toolbars and menus and customize existing ones.You can assign buttons and menus
to built-in commands or user-defined macros.

Follow these stepsTo do this

Perform the customization steps when no document is openCreate toolbars and menus for all DTDs and Schemas

Perform the customization steps when a document that
uses that DTD or Schema is the active document

Create toolbars and menus for a specific DTD or Schema

Toolbars are stored in the following files:

• Global toolbars for the current user only. %APPDATA%\SoftQuad\XMetaL\<version>\default.tbr
contains toolbars available to the current user for all documents being edited. Toolbars in this file take
precedence over any toolbars of the same name in the above file.

• DTD-specific toolbars for all users. Toolbars available to all users for any document based on the DTD
or Schema are contained beside the file location of the .dtd/.xsd OR in a fallback location under
..\Author\Rules\<dtdname>.tbr.

• DTD-specific toolbars for current user only..
%APPDATA%\SoftQuad\XMetaL\<version>\<dtdname>.tbr and a and per-user "gen" folder area
contain toolbars available to the current user for any document based on the DTD or Schema. Toolbars in
this file take precedence over any toolbars of the same name in the above file.

Related Links
XMetaL customizations on page 106

23© 2025 JustSystems Canada, Inc.



Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Create a toolbar

1. Click View > Toolbars from the main menu.
The Customize dialog opens.

2. Select the Toolbars tab.

3. Click New.
The Toolbar Name dialog opens.

4. Enter a name, and then click OK.

A floating window appears. This is your custom toolbar.

5. Select the Commands tab, and then drag and drop buttons from the Commands tab to the new toolbar.

Tip: To create a separator line between buttons, click and drag the button to the right.

6. When have completed your new toolbar, close the Customize dialog.

Create a button or menu

1. Click View > Toolbars from the main menu.
The Customize dialog opens.

2. Select the Commands tab if it is not already selected.

3. Under Categories, select New Menu.
The new menu appears in the Commands column.

4. Drag and drop the new menu to the XMetaL's main menu bar.

5. With the Customize dialog open, right-click on the New Menu button.
A customization menu appears.

6. Customize the menu button as follows:

• Click Button Appearance.

The Button Appearance dialog opens.

1. Select whether the menu button is Text Only, Image Only, or Image and Text.
2. Click New to add a new image or click Edit to edit an existing image in the Edit Button Image

dialog.
3. In the Button Text field, enter the name of the menu button if the menu button has text in the label.

• Click Image to change the text-labeled button into an image-labeled button, or both.

Note:  If you click Image and you have not set an image to use, the Button Appearance dialog
opens.

• Click Delete to remove the menu button.

7. Add menu items to the menu as follows:

• Click Start Group.
• In the Customize dialog's Commands tab, select one of the categories other than New Menu.
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• From the list of all available commands in the right-side menu, drag and drop the commands you want
to include in the new menu.

8. When you are finished customizing your menu or button, close the Customize dialog.

Set customizable buttons in Whiteboard toolbar

The three customizable buttons ( , , , and ) in the Whiteboard toolbar can be customized for
your favorite macros, third-party applications, and documents. The default XMetaL installation contains
examples of using third party applications such as finding selected text on Google or WiKi, opening an image
in MS Paint and using free web services for translating selected text to and from different languages.

1. Press Shift and click one of the customizable buttons.
The Customize favorites dialog opens.

2. Select the item you want to relate to one of the buttons.
The selected function is displayed in the Title field.

3. Click the button to which you want to relate the function.
The function is now set for the selected button.

4. Click Run Application to test the function in the Title field.

XMetaL Styling Assistant

The XMetaL Styling Assistant and the Active Document WYSIWYG environment provide a means to establish
appropriate document view styles within XMetaL. This process is efficient and straightforward, requiring only
fundamental CSS knowledge. Proficient users can create a preliminary version of comprehensive customization,
while regular users can adeptly fine-tune styles to align with their ongoing tasks.

In XMetaL Author, the presentation of XML and SGML documents can be managed through the application
of cascading style sheets (CSS). The CSS file contains selectors and style properties for each element in
your DTD or schema. Conveniently, the XMetaL Styling Assistant facilitates effortless modification of these
style rules. These modifications encompass various attributes such as text font family, size, style, weight,
color, decoration, background, alignment, display style, whitespace handling, and more. This functionality
empowers users to add or replace new CSS styles within the context of existing active document customization,
or to create fresh default CSS styles.

XMetaL Styling Assistant includes:

• Create a new CSS selector.
• Add a new style or edit existing styles for the selected CSS selector.
• Find a CSS selector matching to the selected element in active document if it is possible.
• Create a CSS selector matching to the selected element in active document.
• Add and traverse @import selector by:

• selecting CSS file.
• using XMetaL default style.

• Copy, Past, Delete, or Change orders of CSS selectors.
• Edit existing styles in text mode.
• Import styles from customization default CSS or user defined CSS file.
• Apply and Save CSS style changes to any opened documents with the corresponding customization.
• Reload active document CSS styles.
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• Open the selected CSS file with the system default application or the customer's preferred CSS editor.
• Show the location of the selected CSS file in Windows Explorer.
• Generate default CSS styles for active document based on existing CTM rules.

XMetaL Styling Assistant Editor

Opening XMetaL Styling Assistant Editor

To open the XMetaL Styling Assistant Editor, you can utilize the XMetaL quick navigation tool for invoking
the "CSS styling assistant: open" macro:

1. Ctrl+?
2. Ctrl+G
3. Select "CSS styling assistant" command group, and press Enter key
4. Select "CSS styling assistant: open" macro, and press Enter key

The active document CSS is loaded into the editor.

XMetaL Styling Assistant Editor functionality

The XMetaL Styling Assistant Editor consists of the following areas:

• Selectors area: Enables you to create, delete, copy, past, sort, choose selectors, and more.

• Style Rule area: Display the style rule for the current selector and allow you to modify it.

• Sample Text area:  Apply formatting to the text according to the style rule.

• Properties area: Enables you to create or edit the style rules in text mode.
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Toolbar of Selectors area

Description# on image

Create new CSS selector using "Create Empty Rules" dialog.1

Create new CSS selector with properties of selected Selector using "Create Rules with current Properties"
dialog.

2

Delete a selector from the list.

Clicking the delete button by holding the Shift key deletes the selector silently, When the focus
is on the selectors list, the keyboard keys Del and Shift enable the silent deletion of selectors.

3

Find CSS Selector matching to Active Document Selection.

How to use:

4

1. Locate a cursor to the Active Document element whose style you want to change.

2. Click on ">" button to result in the highlighting of the corresponding CSS selector within the list of
selectors.

This function finds the selector in editing CSS style and the explicit selector definition only. For
changes to the complex selectors, such as involving inheritance from nested CSS or using
wildcard symbols, you can use an alternative approach. This involves accessing CSS styles
through external text-based editors.

Create CSS Selector matching to Active Document Selection.

How to use:

5

1. Locate a cursor to the Active Document element whose style you want to set, change, or create.

2. Click on "+" button resulting in automatic creation of a Full XPath selector without launching Selector
Wizard. By holding the Ctrl button, the "+" button automatically creates a simple selector. This
allows users to change styles instantly.

Copy selected CSS selector(s).

Click on "C" button enables the copying of selector(s) from the imported CSS. Holding the Ctrl
key while clicking the Copy button allows to copy all selectors.

6

Append or insert copied CSS selector(s).

Click on "P" button enables the pasting of selector(s) from the imported CSS. Clicking on the
Paste button appends the selectors. Holding the Shift or Ctrl key facilitates the insertion of
selectors into particular position before or after the currently chosen selector in the list of selectors.

7

Change the order of the selectors: Move up.8

Change the order of the selectors: Move down.9

Find the desired text within the selectors list.

Use the "Arrow up/down" buttons to locate subsequent or preceding text.

10

Click on "</>" button reveals a list of the current element name, attribute names, and their
corresponding values in the Active Document. Once a selection is made, the chosen content is
presented in the "Find:" text box.
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Description# on image

Save button and Utilities options

The Save button applies and saves CSS styles as the default action.

The Utilities button drop-down list provides the following options:

• Edit in the system default application.
• Reload active document CSS.
• Edit in the customer's preferred CSS editor.
• Show the location of the selected CSS file in Windows Explorer.
• Generate default CSS styles for active document based on existing CTM rules.
• Restore CSS selectors from the original file:

• Once users modify the Default CSS Customization and save these changes for the 1st time, the assistant
generates a "*.bak" file holding the original state of the Default CSS Customization.This feature simplifies
the process of reverting to the initial Default CSS Customization state.

• Restore CSS selectors from the session first saved file:

• When users make alterations to any CSS files and save those changes for the first time during each
session in utilizing the styling assistant, the assistant generates a "*.bak1" file. This file retains the CSS
state before the first save during each session. This feature allows users to revert to the CSS state prior
to the first save in the ongoing session before closing the XMetaL Styling Assistant Editor dialog.

Note:  If the present CSS file is altered using an external editor while the XMetaL Styling Assistant Editor is
open, you will encounter a warning message upon refocusing on the assistant.

"User defined CSS" and "Customization default CSS"

Users can switch between "User defined CSS" and "Customization default CSS" modes.

"Customization default CSS" is developed for specific DTD or schemas. It defines the general default view
styles displayed in both Normal and Tags On views. While XMetaL Developer is a recommended platform
for creating this type of CSS, users may modify, add, or generate their own styles through the XMetaL Styling
Assistant Editor in accordance with specific editing requirements or personal preferences.

If users frequently engage in tasks of changing font family, size, styles, and background/foreground colors
for specific XML elements, along with their layout in the editor view, switching to "User defined CSS" mode
is a conventional approach.

@import selector
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In XMetaL Styling Assistant Editor, the @import selectors are supported. Selecting the "User defined CSS"
mode in the XMetaL Styling Assistant Editor results in adding the special @import selector: "@import
url('$CUSTOMIZATION_DEFAULT')" by default.

The "File text box" contains the full path to the editing CSS file.

Double clicking on the @import selector imports the CSS file from the default document customization and
displays all selectors and CSS styles as follows.
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The "<<" button adjacent to the "File text box" becomes active, enabling you to navigate back to the parent
CSS.

To insert the @import selector, several other methods are available:

• Select a Custom-type selector in the "Create Empty Rules" or "Create Rules with current Properties" dialog:

• Choose the option of browsing desired CSS file in Insert button.
• Choose the option of "@import: XMetaL default style" in Insert button.

CSS Styling Assistant Macros

Within the "CSS styling assistant" command group, there are seven distinct CSS styling assistant macros.
To access the list of command groups, press Ctrl+? followed by Ctrl+G. After selecting the "CSS styling
assistant" group and pressing Enter key, all the macros within the group will be displayed.

• <MACRO name="CSS styling assistant: open" hide="false" lang="JScript" desc="Edit Active Document
CSS styles.">
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• <MACRO name="CSS styling assistant: close" hide="false" lang="JScript" desc="Close Active Document
CSS styling assistant.">

• <MACRO name="CSS styling assistant: refresh content" hide="false" lang="JScript" desc="Reload Active
Document CSS styles into the styling assistant.">

• <MACRO name="CSS styling assistant: show selector" hide="false" lang="JScript" desc="Find and show
CSS selector corresponding to current Active Document XML tag.">

• <MACRO name="CSS styling assistant: create custom selector wizard" hide="false" lang="JScript"
desc="Create CSS selector corresponding to current Active Document XML tag.">

• <MACRO name="CSS styling assistant: create simple selector" hide="false" lang="JScript" desc="Create
simple CSS selector corresponding to current Active Document XML tag.">

• <MACRO name="CSS styling assistant: create full XPath selector" hide="false" lang="JScript" desc="Create
CSS selector containing all parent elements and corresponding to current Active Document XML tag.">

Create a selector
You can create a blank selector or copy style rules from an existing selector.

How to create a selector

1. In the XMetaL Styling Assistant Editor, do one of the followings to invoke Create Empty Rules window:

• Click Create new CSS selector.

• In the Selectors list, click the name of the selector whose style rules you want to copy. Click Create
new CSS selector with properties of selected Selector.

2. In the Create Empty Rules dialog,

do the followings:

a. Choose a type of selector.
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b. Locate the cursor on the Active Document element for which you intent to create a style. Then, either
click on the "</>" button located next to the "Select Element:" to select current active document
element, or select the element's name or XMetaL specific selector directly from the "Select Element"
list.

c. Click on the ">" button to add the specified selector to the list of selectors being created.
d. If you want to create a single style rule to apply to all selectors in the list of selectors being created,

click the Add as a grouped selector option.

Note:

• For all types of selectors, the CSS styling wizard allows synchronizing the element selection in Active
Document with the selection in "Select Element" list. Use the "</>" button in the wizard to synchronize.

• New selectors must have style rules associated with them and be saved before the cascading style sheet
editor is closed.

Type of selectors

Simple selectors

The following example causes all Title elements to appear in blue:

Title {color:blue;}

Pseudo selectors

The following rule causes the content inserted before the Title element to appear in blue:

Title:before {color:blue;}

Child selectors

The following rule applies to all Title elements that have Book as a parent:

Book>Title {color:blue;}

Attribute selectors

The wizard allows the synchronization of element selection with a designated attribute value in the Active
Document, using the "Attribute" selector type.

The following rule causes all Emphasis elements that have attribute "role" with value "bold" to appear in blue:

Emphasis[role="bold"] {color:blue;}

Sibling selectors

The following rule specifies the color blue for all Title elements that are preceded by Book element:

Book + Title {color:blue;}

Class selectors

The wizard allows the synchronization of element selection with a designated @class attribute value in the
Active Document, using the "Class" selector type.

The following rule causes all Title elements that have attribute "class" with value "news" to appear in red:

Title.news {color:red;}

Descendant selectors
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The following rule causes all Title elements that are within Book elements to appear in blue:

Book Title {color: blue;}

Custom selector

Under the "Custom" selector type, the "Insert" button presents three options:

• Browse CSS file to import CSS styles.
• Import XMetaL default CSS styles.
• Generate a full path selector to the selected element in Active Document.

After clicking the "Insert" button, the "Insert text box" automatically displays the full path to the selected
element in the Active Document. In order to modify the full path, you can utilize the "+" button in the "Create
Empty Rules" dialog after selecting the element name in the "Select Element" list. This button enables you
to construct a custom selector string, Alternatively, you can directly edit the element path.

When you click the "</>" button adjacent to the "Insert" button, a list will appear containing combinations of
the current element name, attribute name, and corresponding value from the active document. By selecting
an option from this list, you can insert various combinations of the element name, attribute name, and attribute
value into the "Insert text box".
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Creating the new selector "Para[Id="p1"]" and setting the text font color to be blue in XMetaL Styling Assistant
Editor results in the following style rule. This causes the element "Para" with @Id="p1" to appear in blue:

Para[Id="p1"] {color: blue;}

Note: For a description of selector syntax, see the CSS specifications on the World Wide Web Consortium
website at www.w3c.org.

XMetaL specific selectors

XMetaL-specific selectors, which let you take advantage of specific XMetaL functionality. In the list of available
selectors, these appear first unless you change the order.

Table 9: XMetaL-specific selectors

DescriptionName

Applies styles to an entire document. All other selectors

inherit the styles set for this selector unless different styles

are set specifically for subordinate selectors.

$DOCUMENT

Applies styles to any marked sections in SGML documents

or CDATA sections in XML documents.

$MARKSEC

Applies styles to comments within an XML or SMGL

document.

$COMMENT

Applies styles to processing instructions within an XML or

SGML document.

$PROCINS
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Styling processing instructions

You can style processing instructions using the $PROCINS keyword and the following qualifier names:

xm-pi-target

xm-pi-data

Examples of styling processing instructions

The processing instruction with "xm-replace_text" as "xm-pi-target" is used to specify <MiniTemplate> for
each element in the CTM file. For example,

   <Template>
      <Name>Para</Name>
      <MiniTemplate>
         <![CDATA[<Para><?xm-replace_text Paragraph?></Para>]]>
      </MiniTemplate>
   </Template>

When the element is inserted, the value of "xm-pi-data" is displayed as a replacement text. In the above
example, inserting <Para> element shows "Paragraph".The replacement text can be styled using $PROCINS
as the following examples.

The following rule styles all replacement text PIs in green color:

$PROCINS[xm-pi-target="xm-replace_text"] {color: green;}

The following rule colors all PIs with "Paragraph" as "xm-pi-data" value using blue text:

$PROCINS[xm-pi-data="Paragraph"] {color:blue}

The following rule styles all occurrences of PIs with "xm-replace_text" as "xm-pi-target" and "Paragraph" as
"xm-pi-data" in red color:

$PROCINS[xm-pi-target="xm-replace_text"][xm-pi-data="Paragraph"] {color: red;}

Examples of XMetaL Styling Assistant Usage

For users often involved in tasks such as modifying font family, size, styles, and background/foreground colors
for specific XML elements, along with arranging them in the editor view, setting to the "User Defined CSS"
mode in the XMetaL Styling Assistant Editor is a customary method. In this mode, by default, the @import
statement to the default customization is added.

Scenario 1:

1. Move selection between Active Document element and XMetaL Styling Assistant to find and create
selectors using the ">" and "+" toolbar buttons and the Save button, along with the CSS styles wizard.

2. Set styles according to your preferences.

Scenario 2:

1. Remove all styles and @import statements.
2. Select "Generate default CSS" option in the "Save" button.
3. Edit default customization styles according to your preferences.

Scenario 3:

1. Double click on @import default styles statement .
2. Copy all styles.
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3. Return back to the parent CSS using the "<<" button and delete @import default statement.
4. Append copied selectors.
5. Edit default customization styles according to your preferences.

Scenario 4:

This scenario allows to have both default customization styles and overwritten styles.

1. Remove all styles and @import statements.
2. Move selection between Active Document element and CSS styles wizard using the "+" button.
3. Create your own styles customization.

4. Open "Create Empty Rules" dialog using the  button.
5. Select a Custom-type selector and select "Import XMetaL default CSS" option in the "Insert" options.

Setting style properties
You can edit the properties of your style rules through the XMetaL Styling Assistant Editor. The Properties
area lets you select options to set properties, or you can type properties directly in the Style Rule area. By
default, many properties inherit their value from parent and ancestor elements.

The XMetaL Styling Assistant Editor's Properties Area comprises four tabs, each displaying the style properties
applicable within XMetaL. To configure these properties for a given selector, users can choose the relevant
selector within the Selectors area, access the corresponding tab, and proceed to adjust the property values
as needed.

Table 10: Properties

To edit:Click this tab:

Fonts, text alignment, and indentText

Margin, padding, and bordersEdges

Miscellaneous properties, including classification,
whitespace, and counters

Other

XMetaL-specific properties, including indent, prefix, and
view settings

Extensions

You can also add other properties by editing the text in the Style Rule area. However, these properties may
not be visible in XMetaL.

For descriptions of CSS properties see the World Wide Web Consortium website at www.w3c.org.

Extensions properties
The Extensions tab in the XMetaL Styling Assistant Editor contains XMetaL-specific properties.The properties
on this tab are not part of the CSS specifications, and can be viewed only in XMetaL.

Left indent

Use this property to display the element(s) indicated at a set distance from the left margin, regardless of the
position of any ancestor element.

Prefix options

Use this property to display prefix text, the attributes of an element, or the parameters and parameter entities
of a marked section (in Tags On view only).You can set the following prefix options:

XMetaL Author Help36

Setting style properties

http://www.w3c.org/


• To set a rule to display prefix text, type the desired text.

• To set a rule to display all attributes with non-null values for the element(s) to which the style applies, type
[%attribute-list;].

• To set a rule to display the value of a specific attribute for the element(s) to which the style applies, type
[%attribute ATTRIBNAME;], where ATTRIBNAME is the name of the attribute whose value you want
to display.

• If you are creating a display rule for marked sections, you can choose to display marked-section parameters
and parameter entities by typing [%parameters;].

Using counters and auto-numbering
A counter is an element prefix that is incremented for each successive occurrence of that element.You can
create counters in your document using pseudo-selectors and counter properties.

You can add simple or multi-level counters to elements in your document. For example, chapters in a document
may be numbered 1, 2, 3, etc. and subsections of a chapter may be numbered 1.1, 1.2, ... , 2.1, 2.2, ..., etc.
A counter can be initialized to start at a specified value and various numbering styles are available.

Counters are displayed in :before and :after generated text by using the counter and counters
functions. They are configured using the counter-increment and counter-reset properties under the
Other tab.

Simple counter

The following rule associates a counter with the Sect1 element and gives this counter
the name ‘section1’, so that it can be referred to elsewhere in the style sheet.

Sect1 {
counter-increment: section1;
}

Displaying a counter

The following rule displays the counter at the start of the Sect1 element, but it is more
common to display the counter before an element’s title (if there is one):

This rule displays the counter at the start of the Sect1 element, but it is more common to
display the counter before an element's title (if there is one):

Sect1>Title:before {
content: counter(section1);
}

You can include text before or after the counter. For example, the following rule displays
1. , 2. , ... before the titles:

Sect1>Title:before {
content: counter(section1) ". ";
}

Resetting the numbering

The following rules reset the number for each new list:

ItemizedList {
counter-reset: li;
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}
ListItem {
counter-increment: li;
}
ListItem:before {
content: counter(li) ". ";
}

Initializing counters

The following rule resets the counter to 5:

Sect1 {
counter-increment: section1;
counter-reset: section2 5;
}

Multi-level counters

The following rules define two counters, section1 and section2. The counter-reset
property in the Sect1 rule means reset the counter called section2 to zero whenever a
Sect1 element is encountered.

Sect1 {
counter-increment: section1;
counter-reset: section2;
}
Sect1>Title:before {
content: counter(section1) ". ";
}
Sect2 {
counter-increment: section2;
}
Sect2>Title:before {
content: counter(section1) "." counter(section2) ". ";
}

Numbering styles

The following rules specify upper-alpha and lower-roman style counters:

Sect1>Title:before {
content: counter(section1,upper-alpha) ". ";
}
Sect2>Title:before {
content: counter(section1,upper-alpha) "."
counter(section2,lower-roman) ". ";
}

View support for properties and selectors

The tables below indicate XMetaL Author display support for CSS properties and selectors.

Table 11: Assigning property values, cascading, inheritance

XMetaL Author Normal
View

Name

X‘@import’ rule
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XMetaL Author Normal
View

Name

X‘inherit’ value

Table 12: Font properties

XMetaL Author Normal
View

Name

Xfont

Xfont-family

Xfont-style

Xfont-variant

Xfont-weight

Xfont-size

Table 13: Color and background properties

XMetaL Author Normal
View

Name

Xbackground

-background-attachment

Xbackground-color

-background-image

-background-position

-background-repeat

Table 14:Text properties

XMetaL Author Normal
View

Name

Xcolor

Xtext-indent

Xtext-align

X (except double-overline
and double-underline)

text-decoration

-letter-spacing

-word-spacing

-text-transform

sub and super onlyvertical-align

-line-height
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Table 15: Box properties

XMetaL Author Normal
View

Name

Xborder, border-top, border-
right, border-bottom,
border-left

X (only when set to the same
value for all sides)

border-color

X (only when set to the same
value for all sides)

border-top-color, border-
right-color, border-bottom-
color, border-left-color

Xborder-style

Xborder-top-style, border-
right-style, border-bottom-
style, border-left-style

X (only when border-xxx-
width are set to the same

value)

border-width

X (only when set to the same
value)

border-top-width, border-
right-width, border-bottom-
width, border-left-width

-clear

Xfloat

-height

-width

Xmargin

Xmargin-top, margin-right,
margin-bottom, margin-left

Xpadding

Xpadding-top, padding-right,
padding-bottom, padding-left

Table 16: Classification properties

XMetaL Author Normal
View

Name

Xwhite-space

Xdisplay

Xlist-style

Xlist-style-type

-list-style-position

-list-style-image
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Table 17: Generated content, auto-numbering, and list properties

XMetaL Author Normal
View

Name

Xcontent: <string>

-content: <uri>

Xcontent: <counter>

Xcontent: attr(X)

Xcounter-increment

Xcounter-reset

Table 18: Positioning properties

XMetaL Author Normal
View

Name

-position

-top

-right

-bottom

-left

-width

-height

-clip

-overflow

-z-index

-visibility

Table 19: Other properties

XMetaL Author Normal
View

Name

-@media

Xdirection

Xunicode-bidi

-min-width

-max-width

-@page

-page-break-before, page-
break-after

-page-break-inside

-orphans

-widows

-border-collapse
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XMetaL Author Normal
View

Name

-border-spacing

-caption-side

-table-layout

-empty-cells

-cursor

-outline

-outline-width

-outline-style

-outline-color

Table 20: Selectors

XMetaL Author Normal
View

Type

XGrouping

XUniversal Selectors

XType Selectors

XDescendant Selectors

XChild Selectors

XAdjacent Sibling Selectors

XAttribute Selectors

XClass Selectors

-ID Selectors

:first-child onlyPseudo-Classes

:before and :after onlyPseudo-Elements

XMetaL CTM Editor

In the XMetaL Author user environment, the behavior and visual presentation of elements are managed via
the Customization (CTM) file. Modifying CTM properties enables customization of the authoring interface to
align with specific requirements. The XMetaL CTM Editor provides a streamlined interface for viewing and
configuring element properties within the CTM file.

Launching XMetaL CTM Editor

To launch the XMetaL CTM Editor, navigate to Tools > CTM Editor from the main menu after opening a
document.

The CTM associated with the active document is automatically loaded into the editor.
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XMetaL CTM Editor functionality

Description# on image

Locate the element at the current cursor position within the active document.1

Search the element within the list.2

Select the CTM properties category.

The category type or related information for each element is shown in the third column.

3

Expand or collapse the categorized CTM properties in the CTM properties panel.4

Display CTM properties in either categorized or alphabetical order within the CTM properties panel.5

CTM properties panel for the selected element.6

The full path of the CTM file being edited.7

Open file location:8

• Open with:Opens the CTM file using the user's preferred application.

• Open include:Allows the user to select and open the included CTM file in the editor.
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Clicking an element name displays its properties in the CTM Properties panel on the right side of the editor,
where they can be modified. Properties can be defined per element or globally using the #GLOBAL element.
Additionally, an In-Parent context or a Virtual element can be specified.

General Properties
General properties determine basic element characteristics including an alias, if you want to call the element
by a different name, and a description.

Alias

You can enter a real-language name for the selected element in the Alias field.This is useful when the element
name is not very descriptive, or in cases where authors speak a language other than the language of the
DTD. For example, if the element that you want authors to use for main titles is ‘<DT>’, you can use the Name
field to give the element the real-language name ‘Document Title’—or its equivalent in the language of the
authors.

If you do not enter a real-language name for the element, the element name from the DTD is used.This name
is displayed in tags and in the Element List.

Description

You can type a description of the element in the Description text box. If you do not enter a description, the
element name from the DTD is used instead. This text is displayed at the bottom of the Element List.

Change list
You can specify which elements are available in the change list in XMetaL Author through the Change list
property.

In XMetaL Author, the change list is displayed at the left end of the Formatting toolbar. The list contains the
names of elements that the current element can be changed to. The Change List dialog displays the list of
valid elements.

Since all configurations in this dialog box are relative to a parent element, you may have to re-configure
several parents in order to cover all contexts in which the element can occur. For example, if you have two
list elements, for example, Bulleted and Numbered, that can occur inside Book, Chapter, Section, and Para,
you must include Bulleted and Numbered in the change list for each parent.
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Display As
The Display As properties let you associate forms or controls with an element.

You can specify a form or control by clicking the browse button in the Advanced Display Type property.

XFT Form

You can customize your documents and templates with forms (or dialogs).These are associated with specific
elements to facilitate data entry and the XML authoring process.

You can use the XFT Form Wizard to set up forms that are bound to XML content by an XPath expression.
By using the wizard you can specify the following:

• How to run the form (Embedded or Modal)
• How to display the form (Replace, Before, After)
• When to display the form (Always, Dynamic Script)

If you select Dynamic Script, you must create a script for XMetaL to call before it displays the form. Use this
script to create business rules that determine whether or not to display the form at run-time.

For example, the following script shows how a dynamic display script can be used to conditionally display a
form, depending on the parent of the form node.

// Put this script in the Script Text box of the XFT Form Wizard 
// Get the form control 
// Its node member is the DOMNode of the element to be tested 
var aipc = Application.ActiveInPlaceControl; 
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// If the node's parent is "Publisher" ... 
if (aipc.node.parentNode.nodeName = "Publisher") {
// ... then display the form 
aipc.ShouldCreate = true; 
} 
else { 
// ... otherwise do not display the form 
aipc.ShouldCreate = false;
}

In-Place Control

You can use in-place ActiveX controls to represent elements in Normal and Tags On views and determine
their behavior. When you specify that an element is to be displayed as an in-place control, you must specify
a script prefix. This prefix is used in your macros to enable the control to communicate with XMetaL.You
also have the option of specifying Bitmap Printing. This option has been provided because some controls
(for example, the Internet Explorer WebBrowser Control) do not print using the standard ActiveX mechanism.
If one of your controls does not print using the default mechanism, you should enable this option.

Refer to the documentation for the ActiveX control to learn about possible limitations and restrictions associated
with the control.

Associate an element with an in-place control
You can use in-place ActiveX controls to represent elements in Normal and Tags On views.

1. In the Advanced Display Type property, select the In-place Control option.
2. In the ProgID/ClsID text box, type the identifier for the control you want to use.

Note:  Note: If the control you want to use does not appear in the list, you can find its ClsID or ProgID
by consulting the control documentation for the control or by searching the registry (advanced users
only).

3. Type a script prefix.
4. Set the Use Bitmap Printing option.
5. Click OK.
6. Create the macros that enable the control to communicate with XMetaL.

Followed by
You can configure XMetaL to create an element of your choice when Enter is pressed at the end of a particular
element.

By default, if you press Enter inside a specific block element, XMetaL Author creates a new element of the
same type, if the DTD or schema allows it.You can change the default behavior if it is not permitted by the
DTD or schema, or if you want a different element to be created. The original element must be defined as a
block element in the CSS style sheet for the document.

On Insert
The On Insert properties let you specify default content or a script to be run whenever you insert a particular
element.

You can choose the following from the On Insert Type dropdown:

• None. No content or script is to be inserted.
• XML content. Lets you specify a mini template.
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• Script. Lets you specify script and script language.

MiniTemplate

The MiniTemplate property contains the default content for the selected element.You can use this property
to indicate the markup that is to be inserted for this element. The default content can contain replacement
text, which appears in an element by default when the element is inserted. Replacement text is contained in
‘xm-replace_text’ processing instructions.

If no content is specified, XMetaL inserts replacement text based on the element name. For example, for an
element named ‘Para’, the replacement text is ‘{Para}’. XMetaL does not insert replacement text if none is
specified in the Content section and Paragraph is selected in the Treat As section.

The default content must start with the specified element, not a sub-element.This allows you to specify default
attribute values for the element.

Script

You can specify a script to be loaded and run whenever a particular element is inserted. Most scripts are
written in JScript or VBScript, but you can use any language for which you have a scripting engine that
conforms to the Microsoft Scripting Engine Interface. The name of the language must correspond to the
ProgId (for example, PerlScript or Python) of the ActiveX control that implements the script engine.

Inserting a mini-template

For example:

<Title><?xm-replace_text {Book Title} ?><Title>

When the <Title> is inserted, it contains the text ‘{Book Title}’. Authors can select this text
and type over it with real content.

Inserting a script

The following example illustrates the specifying of default content using a template and
using a script.

Consider the following template:

<Warning><Para>
<?xm-replace_text {Warning}?>
</Para></Warning>

The same results can be obtained with this VBScript code:

Selection.InsertElement "Warning"
Selection.InsertElement "Para"
Selection.InsertReplaceableText "{Warning}"

Note: The Selection.InsertWithTemplate method can be used in a script to insert
elements and their default content.

Text layout
You can set text layout properties to determine how an element appears in Plain Text view. These properties
can be set on a per-element basis or globally.
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XMetaL makes XML source files (as displayed in Plain Text view) easier to view by inserting indentation and
line breaks and distinguishing between content and markup. This formatting is called text layout or pretty
printing.You can specify this setting through the Disable Text Layout property in the Global properties.

Text layout properties are also available on a per-element basis. For example, you can

• Preserve space or indent content
• Add blank lines before or after tags
• Change tag color

Layout options are applied to files saved from Tags On and Normal views. These options are also applied
when you switch from Tags On or Normal view to Plain Text view.

Preserve Space

When you turn on Preserve Space for a parent element, any Element Options changes you specify for child
elements are ineffective. If you want to use the Preserve Space option for a parent element, be sure that all
child elements have the appropriate Element Options selected.

Treat As
You can configure XMetaL to treat selected elements as paragraphs, toggling elements, image elements, or
list elements.

You can also rank the elements of each type.Whenever XMetaL can insert a paragraph, image, or list element,
it inserts the first-ranked valid element of the required type. If the first element in the given ranking is not
valid, XMetaL tries to insert the second-ranked element, and so on.

Paragraphs

Designating an element as a paragraph element determines how the element is processed:

• If you attempt to enter text where text is not allowed but where a new paragraph is allowed, XMetaL uses
one of the elements designated as paragraph elements to create a new paragraph element and places the
text inside the new element.

• If you press Enter at the end of any element and there is no followed-by element or required element and
the element cannot be split, XMetaL inserts one of the elements designated as a paragraph element.

• When adding items to the list of elements in the Paragraph Order, only items that have been set as
paragraphs can be added.

Toggling elements

You can assign inline elements to the Bold, Underscore, and Italic buttons. When an element is assigned to
one of these buttons, clicking the button inserts an empty inline element at the cursor location or surrounds
selected text with the inline element markup (if the assigned element is valid in that location).You can also
click the button to remove markup for the assigned element from the selected text.

You can also assign an element to a macro. In this case, the macro should be assigned to a toolbar button.

Images

You can designate an element as an image element.The following attributes are available on image elements:

• Source (a filename, a URL, or an entity name used to map to the image)

• Height

• Width
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• Alt Text

• Valign

• Scale

Lists

You can use special list editing features to insert and edit list elements. The following list types are available:

• Numbered lists
• Bulleted lists
• Definition lists

Numbered and bulleted lists consist of a list element containing one or more list item elements. Some lists
may have a list header element.

Definition lists are two-part lists that consist of a list element and two kinds of sub-elements: term elements
and definition elements.

Global properties
You can specify some properties for all elements on a global basis. Global properties are available through
the #GLOBAL element.

Disable text layout

This property is set to Yes by default, meaning that all text layout properties for every element are disabled.
In order to set any of the Text Layout properties for any element, this property must be set to No.

Paragraph order

When authors press Enter at the end of a paragraph element, XMetaL inserts a new paragraph element.
The default behavior is to insert the same paragraph element type after the current paragraph.You can use
the Paragraph order to set up a list of elements (which you have previously set as Paragraph types using the
TreatAs property) that XMetaL tries to insert. If XMetaL cannot find a valid element to insert from the list, no
element is inserted.

Virtual element
Elements that you specify as Virtual elements are added via script in the macro editor with the AddElement()
and AddElementToInclusion() methods.

To add or remove a virtual element, right-click an element in the CTM editor and select Virtual Element >
Add Entry or Virtual Element > Remove Entry.

In-Parent element
You can define a context for an element by specifying an In-Parent element. If no In-Parent element is
specified, the properties apply to the element in all contexts.
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When you define an In-Parent element you are informing XMetaL Author that the properties assigned to this
element apply only in a specific context. To assign an In-Parent element, right-click an element in the CTM
editor and select In-Parent element.

Assigning an In-Parent element

For example, to assign properties to all Title elements in the following document, you do not need to specify
an In-Parent element. However, to assign properties only to Title elements that appear within Chapter elements,
you need to specify Chapter as the In-Parent element.

<Book>
<Title>My Book</Title>
<Chapter>
<Title>Welcome to Chapter 1</Title>
<Para>This is a paragraph...</Para>
</Chapter>
<Bibliography>
<Title>This is my bibliography</Title>
<Entry>This is an entry...</Entry>
<Entry>This is an entry...</Entry>
</Chapter>
</Book>

Assets (unsupported)
You can organize frequently used objects as assets through the Resource Manager. Assets can be single
files, such as images, text, or markup blocks.You can drag and drop assets into your document.

Follow these stepsTo do this

In the Resource Manager, click the Assets tab. Right-click
the My Assets folder, and select New Folder. Specify a
name and asset type.

Create an asset folder

Click the Desktop tab, select a file, drag it onto the Assets
tab, and drop it in an asset folder.

Add an asset to an asset folder

The Resource Manager contains the Assets tab and the Desktop tab.

The Assets tab contains the following folders:

• Customizable Asset Templates. A set of templates that can be used to create your own asset folders.
An asset template is displayed when you click on a folder.

• Journalist DTD. A set of sample assets to be used with the Journalist DTD.

• My Assets. A folder for organizing your assets.

The Desktop tab gives you access to the files on your computer.

You can create your own asset folders to organize and categorize objects. When you create an asset folder,
you must specify an asset type.You create an asset by dropping a file from your computer into an asset
folder.
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The types of assets that you can create in My Assets are defined by asset templates, which are located in
..\XMetaL <version>\Author\Asset Templates.You can add more templates to this folder, for
example, by copying them from ..\XMetaL <version>\Author\Assets\Customizable Asset
Templates.

Note: You may need to customize some of these templates for your DTD or Schema.

Tip: You can drag and drop images, text, or markup blocks from your documents into asset folders.

Related Links
XMetaL customizations on page 106

Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Images on page 112
You can insert images into your documents if your XMetaL customization recognizes elements in
your DTD or Schema as image elements.

Macros
A macro is a sequence of operations that can be run as a unit. Macros can be associated with a shortcut key,
toolbar button, or menu item.They are useful when you need to repeatedly execute a task that does not have
a built-in shortcut key or command.

Follow these stepsTo do this

Click Tools > Macros. Then select a macro and click Run.Run a macro

Tip: You may want to create keyboard shortcuts for frequently used macros, or associate them with
toolbar buttons or menu items.

DTD-specific macros are available when you edit a document using the associated DTD or Schema; global
macros are available to all documents and when no documents are open.

Macros are stored in the following files:

• Global macros for all users. ..\XMetaL <version>\Author\Macros\xmetal.mcr contains macros
available to all users for all documents. This is the default macro file.

• Global macros for the current user only. %APPDATA%\SoftQuad\XMetaL\<version>\xmetal.mcr
contains macros available to the current user for all documents being edited. Macros in this file take
precedence over any macros of the same name in the above file.

• DTD-specific macros for all users. ..\XMetaL <version>\Author\Macros\<dtdname>.mcr
contains macros available to all users for any document based on the DTD or Schema.

• DTD-specific macros for current user only.
%APPDATA%\SoftQuad\XMetaL\<version>\<dtdname>.mcr contains macros available to the current
user for any document based on the DTD or Schema. Macros in this file take precedence over any macros
of the same name in the above file.
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Related Links
XMetaL customizations on page 106

Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Macro design guidelines
You are advised to observe some guidelines when designing macros.

First, macros should be self-contained, that is, they must not depend on user input during execution. (Therefore,
some actions cannot be included in a macro.)

If a macro involves any of the commands that open dialog boxes, that action should be completed somewhere
in the macro. (Commands or buttons that open dialog boxes have an ellipsis (...) after the command or button
name.) For example, you can create a macro that inserts a particular element, but you cannot create a macro
that simply displays the Insert Element dialog.

Mouse clicks in the document pane are ignored during macro recording. The first time you try to use the
mouse to change the selection, you will hear an alert. The second time, a message appears saying that you
should use the cursor (arrow) keys to change the selection.

Not all commands can be recorded in a macro. A macro that was recorded in Normal or Tags On view can
usually be played back in the other view. Macros recorded in Plain Text view are less likely to work in the
other views.

In addition to the above restrictions, the following actions cannot be recorded in a macro:

• Actions that make a different document the active document (for example, drag and drop between documents)

• Setting table properties

• Spell checking operations

• Most commands in the File and View menus

Record a macro

Note:  Recording is limited to keyboard actions only.

1. Click Tools > Record New Macro.
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2. Perform the sequence of actions that you want the macro to execute.

3. Click Tools > Stop Recording.

4. Select an option from the Create this macro for list.

5. Type a name.

6. (Optional) Do any combination of the following:

• Specify a shortcut key combination to associate with the macro
• Specify an image to associate with the macro

Create a keyboard shortcut

1. Click Tools > Macros.

2. Select a macro.

3. Choose a shortcut key combination.

Associate a macro with a toolbar button

1. Click View > Toolbars and select the Buttons tab.

2. Select Application Macros or <dtdname> Macros (where dtdname is the name of the DTD or Schema
for the current document).

3. Select a macro.

4. (Optional) Do any combination of the following:

• Choose an image to associate with the macro
• Type the text you want to appear as the button tooltip
• Type the text you want to appear in the status bar while the macro is running

Associate a macro with a menu item

1. Click View > Toolbars and select the Menus tab.

2. Select a menu to which you want to add your new command and click Add Menu Item.

3. From the Macros list, select a macro.
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4. Type a name in the Caption text box.

Tip: Type the ‘&’ character immediately before the letter that you want to use as the keyboard shortcut
(the underlined letter).

5. (Optional) Do any combination of the following:

• Type the text you want to appear in the status bar while the macro is running
• Select the Begin Group option to create a separator line above the command in the menu

XMetaL API for providing asynchronous operations
The API enables you to run XMetaL macros when XMetaL enters an idle state or when triggered by external
events, e.g., "specific time elapsed", specific file(s) changed or specific application terminated.

Here are some scenarios that an XMetaL customization developer can achieve via macro scripts:

1. Select a word in an open document - specify the file path that receives proposed alternatives for a selected
word - run third party application passing word and file path as parameters - continue editing in XMetaL
- after application completed or file changed events - run macro that moves selection to selected word -
reads file with alternatives - show alternatives to user.

2. XMetaL monitors the status of specific files in folders. Changing specific files via third party applications
triggers running the XMetaL macro asynchronously. The XMetaL macro script reads the contents of the
file that triggered the event.

• RunMacroOnIdle - runs the XMetaL macro script asynchronously after XMetaL has entered to an idle
state. Optional parameters specify additional delay time and a VARIANT-type parameter that can be passed
to the macro.

• RunAfterProcessDone - runs the XMetaL macro script asynchronously after a specific Windows process
was terminated and XMetaL has entered to an idle state. Optional parameters specify a VARIANT-type
parameter that can be passed to the macro.

• AddFileChangeMacro - runs the XMetaL macro script asynchronously after predefined file(s) were changed
and XMetaL has entered to an idle state. Optional parameters specify the full file path or pattern and a
VARIANT-type parameter that can be passed to the macro. XMetaL provides additional default parameters
containing the full path of the file that triggered the event.

• Additional XMetaL APIs "IsProcessRunning", "TerminateProcessEx", "RunAfterProcessDone2",
"IsFileChangeMacro", "RemoveFileChangeMacro" allow you to maintain a customization based on an
asynchronous event.
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Options
You can set options through the Tools menu.

Settings are stored in an XMetaL configuration file in the following locations:

• Global settings: ..\XMetaL <version>\Author\xmetal.ini contains settings that are available to
all users.

• Settings for the current user only:  contains settings for the current user only. XMetaL Author makes
changes only to this file. Settings in this file take precedence over any settings of the same name in the
above file.

%APPDATA%\SoftQuad\XMetaL\<version>\XMetaL.ini

Table 21: General options

DescriptionOption

Identifies documents by
username and initials

Current user

Specifies a location to
temporarily store remote files

Location to temporarily store remote files

Displays attributes in a tooltipShow tag tips

Re-opens documents that
were open when XMetaL
Author was last closed

Restore last open documents

Moves a selection to the
selected point before the
document was closed.

Restore selection in open document

Note:  Changing this
option requires
restarting XMetaL.

Automatically checks spelling
as you type

Check spelling while typing

Automatically replaces
misspelled words with words
from your word list.

Replace words from my word list while typing

Allows users to create text in
languages that are right to
left

Enable bi-directional text support

Note:  A system
restart is required for
changes to take
effect.

Note: Turning off the
'Check spelling while
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DescriptionOption

typing' option is
recommended when
bi-directional text is
enabled.

Allows users to use
Workbench feature in
Resource Manager

Enable Workbench

Note:  A system
restart is required for
changes to take
effect.

Allows users to complete cell
values automatically

Enable AutoComplete for cell values

Allows users to complete
attribute values automatically

Enable AutoComplete for attribute values

Table 22: View options

DescriptionOption

Specifies a default view for opening documentsOpen new documents in

Provides formatting information for tags in Tags On viewTag icons

Displays inline imagesShow inline images

Displays comments in Tags On viewShow comments

Displays the structure view when opening a documentShow structure view by default

Table 23: Plain Text View options

DescriptionOption

Specifies a text fontFont

Specifies colors for markup and scriptsSyntax Coloring

Determines how tab characters are handledTab

Specifies how to display lines that are longer than the width
of the document pane

Word Wrap

Displays line numbersLine numbering

Table 24: File options

DescriptionOption

Specifies a template for files created through the New Page
button

New

Specifies a default extension when saving new documentsSave As

Saves backup copies of your filesBackups
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DescriptionOption

Specifies the number of recently used documents to displayFile Menu

Specifies the number of changes or minutes after which
your document will be saved automatically

Automatic Saves

Specifies line ending options for different operating systemsEnd of Line

Table 25: Change Tracking options

DescriptionOption

Specifies format, color, and preview options for inserted
text

Inserted text

Specifies format, color, and preview options for deleted textDeleted text

Table 26: Windows and Tabs options

DescriptionOption

Specifies the displayed
Windows theme

Visual theme

Displays a "close" button for
file that is active

Show "Close" button on the active tab

Displays a pop-up menu of
tabbed windows

Show pop-up menu of tabbed windows

Turns animations on when
these panes are unpinned

Animate "auto-hide" docking panes

Table 27: Symbols options

DescriptionOption

Adds a symbol mapped to the entered unicode hex to the
Insert Symbols menu that can be opened by typing the
keyboard shortcut CTRL + Shift +S.

Insert symbol using unicode hex

Deletes a symbol from the Insert Symbols menuDelete symbol

Moves a selected symbol up or down as displayed in the
Insert Symbols menu

Up / Down

Related Links
Spell checker options on page 80

You can specify Spell Checker options through Tools > Spell Checker.Your settings are applied
the next time you open the spell checker.

Thesaurus options  on page 90
You can specify thesaurus options through Tools > Thesaurus.Your settings are applied the next
time you open the thesaurus.

XMetaL customizations on page 106
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.
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Managing documents

This section contains information about managing documents such as creating, opening, printing and saving
documents, creating well-formed XML documents, and working with a repository.

Creating documents
You can create a document from a template, create a blank XML or SGML document, or create a blank,
well-formed XML document.You can set file options, including a default template, filename extensions, and
autosave intervals through Tools > Options.

Follow these stepsTo do this

Click File > New. Then click a tab and choose a template.Create a document from a template

Click File > New. In the General tab, select Blank XML
Document or Blank SGML Document. Then choose a
DTD, Schema, or Rules file.

Create a blank XML or SGML document

Click File > New. In the General tab, select Blank Well-
Formed XML Document.

Create a blank, well-formed XML document

The appearance of your new document and much of the authoring functionality is determined by an XMetaL
customization. When you create a document that is based on a DTD or Schema that does not have a
customization, the following files are created in the same folder as your DTD or Schema:

• Rules file - a Rules file is a DTD or Schema that has been compiled into a binary format. Rules files have
an .rlx extension for XML files, an .rls extension for SGML files, and an .rld extension for Schemas.

• Style sheets for the document view and structure view (.css) - styling is based on element names. XMetaL
Author recognizes many elements defined in XHTML, DocBook, and the Journalist DTD.

• Customization file (.ctm) - this file contains authoring behaviors that are based on the elements and attributes
in your DTD or Schema (for example, some keyboard shortcuts, Enter key behavior, and mini-templates).
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Related Links
Options on page 55

You can set options through the Tools menu.

XMetaL customizations on page 106
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Templates
Templates let you create new documents that use a particular DTD or Schema. They can also provide a
document outline and text that help you in the authoring process.

You should create at least one template for each DTD or Schema. In many cases, you can use the same
template to create either an XML or an SGML document. However, if your DTD was designed for SGML
documents, it may contain features that are not supported in XML.

Templates are stored in the following folder:..\XMetaL <version>\Author\Template.You can organize
your templates in sub-folders. Sub-folders appear as tabs when you click File > New to create a new document.

Related Links
XMetaL customizations on page 106

Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Create a template

1. Click File > New and select the General tab.

2. Select Blank XML Document or Blank SGML Document and click Open.

3. Choose a DTD or Schema to associate with your template.

4. Add elements and content to the template as required.

5. Create a folder in the template folder and save the file (for example, ..\XMetaL
<version>\Author\Template\New_products\Z-series.xml).

Tip:  Give the file a descriptive name that reflects the template use or associated DTD.

Note: The file extension you assign to your template (.xml or .sgm) determines whether an XML or
SGML file is created when the template is opened.

Related Links
Working with elements on page 107

Elements are the building-blocks of your documents. They are defined in your DTD or Schema.
Authoring in Normal view is similar to applying styles, whereas Tags On view lets you work with
elements as structural objects.You can insert elements using the Element List, the Insert menu, or
the In-place, look-ahead element list.
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Opening and closing documents
When you open a file, XMetaL Author checks for a DTD, Schema, or Rules file.

Follow these stepsTo do this

Click File > Open and choose a file, or drag and drop a file
onto the XMetaL Author title bar

In the Select Files to Open dialog, users can open
a document in Tags On, Normal or Plain Text view.

Open a document

File navigation options are available in the Select
Files to Open dialog as follows:

• Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
file is located.

• Find all files in folders - allows users to view all
files in a selected directory, including sub-folders,
in one list.The file extensions filter allows, including
sub-folders, to narrow down list of file specific types.

• A powerful file preview feature.

Click the file icon in the browser address bar and drag it
onto the XMetaL Author title bar

Open a document that is displayed in a Web browser

Click File > Close in the main menu, or right-click and select
Close on the worksheet's tab.

Close a document

Click File > Close AllClose all open documents

When opening a file, XMetaL checks the following conditions and stops as soon as one of the conditions is
true:

• If the file starts with an XML declaration, it is edited as an XML file.

• If the file does not start with an XML declaration and if the filename has the .sgm or .sgml file extension, it
is edited as an SGML file.

If neither condition is true and if the file contains a document type declaration, the file is edited as an XML
file. In this case, XMetaL adds an XML declaration to the document.

If you open an XML document that does not specify a DTD or Schema and the document is not well-formed,
XMetaL attempts to fix the markup.

Related Links
Display mode on page 20

You can choose how much space to allocate for displaying your documents.You can also choose
to display your documents in a tabbed interface so that you can easily switch between open
documents.

Special characters and symbols on page 123
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.
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XMetaL customizations on page 106
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

If XMetaL cannot find the DTD, Schema, or Rules file
If XMetaL Author cannot find a DTD, Schema, or Rules file for the document you are opening, you must
choose an option for editing the document.

XMetaL may not be able to locate the DTD for any of the following reasons:

• Your document contains no document type declaration.

• There are no entries in the catalog that map the external identifier in the document type declaration with a
DTD.

• The DTD is not at the expected location. An incorrect location may have been specified in the catalog. (If
a relative location was specified, it should be relative to the location of your document.)

Select from the following options:

• Browse for a DTD. Opens a dialog from which you can select a DTD.

• Edit as a partial document. Opens the document as a well-formed document in Normal or Tags On view.
You can edit elements and attributes, but no validation takes place. (Not applicable to XML files based on
Schemas.)

• Edit the file in plain text view. Opens the document in Plain Text view.

Some options let you choose an auxiliary DTD. If you do so, the elements and attributes from the auxiliary
file are added to the document you are editing. However, the auxiliary DTD is not used to validate the document
and you can add elements and attributes as necessary.

Related Links
Document views on page 9

You can choose a view for your document through the View menu or from the view buttons in the
document status bar. The view you select depends on how you want to work with your document.
You can set view options, including a default view through Tools > Options.

Authoring structured content on page 103
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When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL
Author ensures that your content is valid by guiding you through the authoring process.You do not
need to have a complete understanding of XML to begin authoring structured content.

WebDAV-enabled folders
To open files in a WebDav-enabled folder, you must have permission. When you open a document in a
WebDAV folder, it is locked for editing. Other users can open the file as read-only. Auxiliary files such as the
DTD are left unlocked.

Customization files can be downloaded from a WebDAV server following the normal search rules. Catalogs
are not downloaded from a WebDAV server; only your local system is searched according to the normal
search behavior for catalogs.

Note:  Microsoft Internet Information Server (IIS) Version 5.0 must be installed, and the folder containing
the target files must be Web Share enabled.

File caching

Files retrieved through WebDAV are stored in your Temp folder (usually ..\Documents and
Settings\<username>\Local Settings\Temp). When you open a file from a WebDAV server, the
URL to this folder is mapped and the cached file is used. If the file in the cache does not exist, the file is
retrieved from the WebDAV folder and placed there. After the document is closed, all the cached items used
by the document are removed.

Related Links
XMetaL customizations on page 106

Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Managing open documents
Documents are displayed in windows in the editing pane. XMetaL provides various ways of organizing and
navigating document windows, and navigating to documents outside XMetaL.

Moving between open documents

If you have more than one document open in XMetaL Author, you can move between the open documents
in the following ways:

• Click the appropriate file name on the Window menu

• Press Ctrl+Tab or Ctrl+Shift+Tab

• Click Next Document ( )/Previous Document ( ) on the Standard toolbar

• Click the "Active Files" downward arrow at the top-right corner of the editing pane and select the open
document you want to view.
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Moving worksheet tabs

You can move and arrange open worksheets' tab order by dragging and dropping the tab(s) you want to
move.

Scrolling through worksheet tabs

If more window tabs are open than can be displayed in the editing pane, you can use the arrows at the top-
right of the editing pane to scroll through the windows.

Working with tab groups

Open documents can be grouped in the editing pane into vertical or horizontal tab groups.

Note:  Only a horizontal OR a vertical tab grouping can be utilized at one time.

Follow these stepsTo do this

Right-click on an open document's worksheet tab, and then click New Horizontal
Tab Group.

To create a horizontal tab group

Right-click on an open document's worksheet tab, and then click New Vertical Tab
Group.

To create a vertical tab group

When documents have been grouped into at least two separate tab groups, right-
click on an open document's worksheet tab, and then click Move to Next Tab
Group.

The document is moved to the next group to the right (in horizontal grouping)
or the group immediately below the current group (in vertical grouping).

To move a document to the next
tab group

When documents have been grouped into at least two separate tab groups, right-
click on an open document's worksheet tab, and then click Move to Previous Tab
Group.

The document is moved to the next group to the left (in horizontal grouping)
or the group immediately above the current group (in vertical grouping).

To move a document to the
previous tab group

Right-click on an open document's worksheet tab, and then click Close All
Documents in Tab Group.

To close all documents in a tab
group

Right-click on an open document's worksheet tab, and then click Close All But
This.

To close all documents in a tab
group except the currently selected
document
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Viewing documents and document folders outside XMetaL

A document's containing folder can be opened from within XMetaL, and the document's full path can be
copied to allow you to quickly navigate to a document's location.

Follow these stepsTo do this

Right-click on an open document's worksheet tab, and then click Copy Full Path.

You can then paste the full path in a directory browser to view the location
and open the document outside XMetaL.

To copy a document's full path

Right-click on an open document's worksheet tab, and then click Open Containing
Folder.

The document's containing folder opens in Windows Explorer.

To open a document's containing
folder

Right-click on an open document's worksheet tab, and then click Show Document
on XMetaL Desktop.

The document's desktop location is displayed in the Resource Manager
pane.

To open a document's desktop
location in XMetaL

Saving documents
You can save the current document or all open documents. XMetaL Author validates the document before
saving it.You can save an invalid document or cancel the save operation.You can also set save options
such as automatic saving and backup creation.
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Save one or all documents from the main menu:

Click thisTo do this

File > SaveSave a document

File > Save As

In the Save As dialog, users can find and filter
content.

Save a document under a different name or in a different

location

File navigation options are available in the Save As
dialog to enable file navigation options such as:

• Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
file is located.

File > Save AllSave all open documents

Save a document from the worksheet tab:

Click thisTo do this

Right-click on the worksheet tab of the document you want

to save. In the menu that appears, click Save.

Save a document

Related Links
Options on page 55

You can set options through the Tools menu.

Special characters and symbols on page 123
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Authoring structured content on page 103
When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL
Author ensures that your content is valid by guiding you through the authoring process.You do not
need to have a complete understanding of XML to begin authoring structured content.

Character encoding
XMetaL Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetaL Author use UTF-8 encoding.

You can enter Unicode characters using standard input devices such as a keyboard, or IMEs (input method
editors).You can also use the keyboard shortcut CTRL + Shift + S or right-click your mouse and select Insert
Symbol to select a symbol from a contextual menu of commonly used symbols (Note: The list of symbols
can be edited from Tools > Options > Symbols). Alternatively, you can copy and paste characters from
other programs.

Unicode characters are displayed in Normal and Tags On views. If a character appears as a box, then the
font in use does not contain that character.The character will appear correctly when the required font is used.
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XMetaL Author determines the file encoding by checking the following conditions, in the following order:

1. If the file contains a byte-order mark, UTF-8 or UTF-16 encoding is determined.

2. If the file contains an XML declaration, then the rules in Appendix F of the XML specification
(www.w3.org/TR/REC-xml#sec-guessing) are used to determine whether the file uses UTF-16 encoding
(that is, the encoding is determined by the ‘<?’ characters in the XML declaration).

3. If the file contains an XML declaration that specifies an encoding string, then this encoding is used.

4. If the encoding cannot be determined, then the default is used: UTF-8 for XML documents and ANSI
(Latin-1) for SGML documents.

Table 28: Supported encoding strings

StringsEncoding Type

ANSI_X3.4-1968US-ASCII

ANSI_X3.4-1986

ASCII

CP367

CSASCII

IBM367

ISO_646.IRV:1991

ISO646-US

ISO-IR-6

US

US-ASCII

CP819ISO-8859-1

CSISOLATIN1

IBM819

ISO-8859-1

ISO_8859-1

ISO_8859-1:1987

ISO-IR-100

LATIN1

L1

UTF-8UTF-8

UTF-16UTF-16

Note:  If the XML declaration contains an encoding string not listed in the above table, the file is opened
in Plain Text view.

Related Links
Special characters and symbols on page 123

You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed
by using the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have
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corresponding keys on US English keyboards. If your document’s encoding supports it, the characters
and symbols themselves (not the character entities) are saved with your document.

Creating well-formed XML documents
When you create a blank well-formed XML document, you must define elements and attributes before you
can create content. Because the document is not based on a DTD or Schema no rules checking or validation
occurs.

The Attribute Inspector and Element List display only the elements and attributes that you add to the document.

XMetaL Author inserts the following processing instruction in your well-formed document:

<?xm-well_formed path =
""?>

Defining an element

1. In the Element List, double-click <Insert Element>.

2. Type a name.

3. Type a description.

The description will appear at the bottom of the Element List when the element is selected.

4. Choose an option:

• Element can be a container. Choose this option if you want the element to be able to contain text
and other elements.

• Element is empty. Choose this option if you do not want the element to have any content.
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Defining an attribute

1. Insert an element in your document.
A new, blank attribute is created for the element.

2. In the Attribute Inspector, right-click on the new attribute and click Add Attribute.

3. Type a name.

4. Type a description.

The description will appear at the bottom of the Attribute Inspector when the attribute is selected. All new
attributes created in well-formed XML documents have character data (CDATA) content.
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Inline attribute editor
The inline attribute editor allows users to edit attributes in the element that is under the cursor. All actions
can be completed via keyboard only.

All keyboard shortcuts defined below, except for opening the inline attribute editor, presupposes that it is
open.

Do thisTo do this

Type CTRL + SHIFT + F6 on your keyboardOpen the inline attribute editor

Enter the search criteria in the search field. The results will
be displayed as you type.

If the search field is hidden, type CTRL+F on your
keyboard to unhide it

Find an attribute by name or description

Hover your cursor over the name of the attribute and the
description will be displayed in the lower pane.

If the lower pane is hidden, type CTRL + I on your
keyboard to unhide it.

Show an attribute's description

Type CTRL + R on your keyboard to toggle the sorting.You
can sort by default order or alphabetically.

Sort attributes

Type CTRL + DelDelete an attribute from an element

Type CTRL + NGenerate a unique ID

Type CTRL + ?Use other utilities for managing reference attributes

Users can also:

• Customize the list of predefined values

• Select an attribute description topic in the DITA Language Specification help system (DITA users only)

• Run custom macros for predefined attributes

69© 2025 JustSystems Canada, Inc.

Inline attribute editor



Archiving linked documents
The tool for archiving linked documents creates a backup (zip) of files opened in XMetaL editor or files found
in XMetaL "Find in files" cross-files operations, including referenced content and images.

Linked documents are archived in the Archive Linked Documents dialog. To access this dialog, press CTRL
+ ? and then find and select Archive linked documents in the dialog that appears.

Do thisTo do this

Click the Scope field and select the scope from the available
options.

Set the scope of the archive

Click the Find linked documents button.Find linked documents

Click the button. In the dialog that appears, select
the attributes you want to add.

Set reference attributes

Note: The Ref. attributes checkbox must be
selected to enable this function.
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Do thisTo do this

Click the  button to the right of the Input folder field.

Select a common folder for all archiving documents

Under archiving options, open the Content drop-down
list, and then select one of the available options.

Select the content included in the archive

Click the  button to the right of the Show field.

Copy the list of paths to linked documents to the clipboard

After you have created the output successfully, click the
Send [email application name] email button.

Send a created zip file via email as an attachment

When the paths for the found documents are shown, select
the document you want to delete and press Delete on the
keyboard.

Remove files manually

In the Path starts with field, select a path from the available
options.

Set where the path will begin for the folder structure in the
created archive

Enter the extension(s) in the File extensions field.Add only files with specific extensions to the archive (e.g.,
find and archive images only)

In the Content field, select All files in input folder and
descendants.

Include all files in the subfolders of the archiving documents
in the archive

Printing
You can print from any document view mode, including Page Preview.
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Follow these stepsTo do this

Click File > Print. Click Options to create headers and
footers.

Print a document

Right-click in the browser pane and choose Print.Print a document in Page Preview mode

Working with a repository
XMetaL Connector is an integration layer that lets you access your repository through XMetaL Author dialogs
and menus.

Note:  Operation availability is determined by the adapter (a software driver for your repository). Refer
to your repository documentation for details.

Table 29: Common repository operations

NotesClick thisTo do this

When you open a topic or map
reference from a repository map,

Repository >
Open from
Repository

Open a topic or map file

you have the option to view the
file or check it out for editing (if
enabled).

Select a template.When you add
referenced components (for

Repository >
New from

Create a new repository file

example, images and links) to theRepository
Template new file, you have access to

repository-specific operations
(such as advanced search) if your
adapter supports it.

Select a template.Repository >
New Map from

Create a new repository map

Repository
Template

Repository >
Open

Open a document that you have
checked out

Checked-Out
Document

Repository >
Explore
Repository

Explore a repository

You may check in a document
only if it is currently open for
editing.

Repository >
Check In
Document

Check in a document

You may check out a document
only if it is currently open for

Repository >
Check Out
Document

Check out a document

viewing. When you check out a
document, the current view of the
document is replaced with the
latest version of the document.

The document reverts to its
previous version.

Repository >
Undo
Checkout

Undo checkout of a document
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NotesClick thisTo do this

Repository >
Document
Properties

View document or map properties

You must set the URL for the
repository before accessing files

Repository >
Repository
Options

Set the URL for the default
repository

for the first time or if you switch
repositories.

Some repositories require that
you log on before any repository
operations are allowed.

Repository >
Log On to
Repository

Log on to a repository

Repository >
Log Off from
Repository

Log off from a repository

Adapter configuration file

Configuration files are located at ..\XMetaL x.x\Author\CRCL\configs. Each adapter instance must
have a configuration file.

Note:  Only one configuration file can have the default attribute of the <AdapterInstance> element
set to true.

Related Links
Toolbars on page 16

You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.
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Editing documents

A full suite of editing tools is available to assist you in the authoring process. Although they are similar to
those found in many word processors, some are structure-aware.

You can cut, copy, and paste selections using menu commands, shortcut keys, or by drag-and-drop.

Follow these stepsTo do this

Click Edit > Cut (Copy), move your cursor to the desired
location and click Edit > Paste

Cut (Copy) and paste a selection

Click Edit > DeleteDelete a selection

Note: You cannot delete a selection if it includes required elements, and you cannot paste a selection
that would cause the markup to become invalid.

Selecting tags and text
Selection behavior is similar to that in word processors, but selection rules prevent you from creating an
invalid document. If you select a start (or end) tag, your selection is extended to include the corresponding
end (or start) tag and all of the text in between.

Follow these stepsTo do this

Double-click the word you want to selectSelect a single word

Click Edit > Select ElementSelect a single element

Click anywhere in the first element to be selected and drag
the cursor until all of the elements are selected

Select consecutive elements

With the insertion point anywhere in the document, press
Ctrl+A

Select the entire contents of a document

The following examples show text and markup selections in Tags On view.
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Finding and replacing text
You can search for a text string and replace it with different text or with a text entity.You can also restrict
your search to a text string that occurs within a specific element.

Follow these stepsTo do this

Click Edit > Find and Replace.Find and replace text

Click Edit > Find and Replace. Then click Options and
select an element.

Find and replace text within a specified element

Click Edit > Find and Replace. Then click Options and
select Replace with entity.

Find and replace text with an entity reference

Choose from the following search options:

• Match case. Finds only text that matches the text and case specified.

• Match whole words only. Matches a sequence of one or more whole words only.

• Use Pattern Matching. Searches by pattern, using special search characters.

• Search backwards. Searches from the current location towards the beginning of the document.

• Wrap. Searches from the current location to the bottom of the the document, and then continues searching
from the top of the document.

• Ignore read-only on replace. Ignores read-only elements when replacing text. (If this option is not chosen,
an error message appears whenever you attempt to replace text within a read-only element.)

• Highlight all occurrences. Highlights all occurrences of the searched for text phrase.

Find and replace operations are designed to keep your document valid:
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• Text searches do not find a match if part of the text is found in a separate element. For example, if you are
searching for ‘World Wide Web’ and ‘Web’ is in an <EMPH> element, no match is found.

• In Normal and Tags On views, element replacements that would invalidate the markup do not occur if rules
checking is on.

Related Links
Finding and replacing across files on page 92

You can perform cross-file searches to find text or markup using simple text and pattern matching
all the way up to very advance XPath expressions.

Search patterns
When you use pattern matching to find words, the characters in the Find box are interpreted as patterns.That
is, the search text can contain special search characters that match a class of text strings, or markup constructs.
If your search text does not contain any special characters, the text is searched for exactly as entered.

The following special characters can be used:

. *
? + ^ $ [ ]

To search for any special character as ordinary text when Use Pattern Matching is selected, precede it with
a backslash (\). For example, use ‘\.’ to match a period (.).

Table 30: Pattern summary

ExampleMatchesExpression

“abc” matches “abc”itselfordinary character

the element name<name or <name>

the entity name&name or &name;

“fo.d” matches “food”any single character.

“l*ama” matches “llama”0 or more occurrences of the
character x

x*

“b(an)*a” matches “banana”0 or more occurrences of the pattern(pattern)*

“be+n” matches “been”1 or more occurrences of the
character x

x+

“b(an)*a” matches “banana”1 or more occurrences of the pattern(pattern)+
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ExampleMatchesExpression

“colou?r” matches “color” and “colour”0 or 1 occurrences of the character
x

x?

“b(an)*ale” matches “banale” or “bale”0 or 1 occurrences of the pattern(pattern)?

“(love|money)” matches “love” or “money”pattern1 or pattern2pattern1 | pattern2

“^Note” matches “Note” at the start of a paragraph (as
in <p>Note...</p>)

pattern immediately following
markup

^pattern

“sub$” matches “sub” at the end of a paragraph (as in
<p>...sub</p>)

pattern immediately before markuppattern$

“t[ai]n” matches “tan” and “tin”any single character in the string[string]

“th[^e]n” matches “than” , but not “then”any single character not in the string[^string]

“[a-c]” matches “a”, “b”, or “c”any character in the range[char1-char2]

“[^a-c]” matches none of the characters “a”, “b”, or “c”any character not in the range[^char1-char2]

If the search text is “(.)read” and the replace text is
“\1ox”, the result is “box”

in a replace string, it is replaced by
the text matched by the nth sub-
expression in brackets in the search
string

\n

If the search text is “fish” and the replace text is “gone
\0ing”, the result is “gone fishing”

in a replace string, it is replaced by
the text matched by the entire
search string

\0

Finding and replacing elements
In Normal and Tags On views, you can search for a specific element in your document and replace it with a
different element if doing so does not invalidate the markup. Only the element tags are changed; the element
content does not change.

Follow these stepsTo do this

Click Edit > Find and Replace and click the Element tabFind and replace an element

Searching for attribute values

You can search for elements with specific attribute values. For example, you can search only for <p> elements
that have a translate attribute value of ‘yes’ and replace them with a value of ‘no’:

If a found element has more than one attribute value set, only those that are specified in the replacement
text are modified.
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Removing an attribute

If you need to remove an attribute, you have the following options:

• Delete the attribute value in the Attribute Inspector. If the value is currently set to an empty string, enter a
new temporary value, press Enter, and then delete the value.

• Switch to Plain Text view and modify the source.

Finding and replacing entities
In Normal and Tags On views, you can search for an entity reference and replace it with a different entity
reference or with text.

Follow these stepsTo do this

Click Edit > Find and Replace and click the Entity tab.Find and replace an entity reference

Click Edit > Find and Replace and click the Entity tab.
From the options, choose Replace with text.

Find and replace an entity reference with text

For example, you can search for the product name entity &prodname; and replace it with the product name
text ‘Z9000’.

Checking your spelling
You can check your spelling using the spell checker or as you write by using background spellchecking.

The spell checker in XMetaL helps you eliminate spelling mistakes.The spell checker also includes tools that
can help you customize the preferences to create the experience you want.You can spell check a document
all at once after finishing a document or you can use background spellchecking that uses wavy red lines to
allow you to identify possible mistakes while you work.

Related Links
Using the spell checker on page 79

You can check your spelling using the spell checker.

Using the background spell checker on page 83
You can check your spelling as you write using background spell-checking.
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Main word lists on page 85
Main word lists are the built-in word lists for a given language.The default main word list is determined
by the language you select.You can use more than one main word list to check your document.

User word lists on page 86
User word lists are unique to your XMetaL Author setup or document.You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Using the spell checker
You can check your spelling using the spell checker.

Follow these stepsTo do this

Click Tools > Spell Checker. In the spell checker, click
Start. When checking stops at a misspelled word, choose
a word from the Replacements box and click Replace.

Replace a single occurrence of a word

Click Replace AllReplace all occurrences of a word

Click Skip OnceSkip an occurrence of a word or phrase

Click Skip AllSkip all occurrence of a word or phrase (and add it to the
user word list for the document)

You can use the spell checker in the following ways:

• Check the spelling in an entire document, part of a document, or only selected text.

• Manually edit text and then resume checking the document.

• Ignore a spelling error once but flag subsequent occurrences of the problem, or ignore the error for the rest
of the proofreading session.

• Replace words by choosing a word from a list of available words, by typing in the correct word, or by defining
an automatic replacement for a word (especially useful for words that are regularly misspelled).

Note: The spell checker does not check processing instructions, comments, hidden elements, entity
references, or form fields.

Word lists

Spell Checker checks spelling by comparing words in your document with the words in one or more lists of
acceptable words. Word lists are categorized as follows:

• Main word lists on page 85

• User word lists on page 86
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The spell checker checks the user word lists before the main word lists.

Related Links
Using the background spell checker on page 83

You can check your spelling as you write using background spell-checking.

Main word lists on page 85
Main word lists are the built-in word lists for a given language.The default main word list is determined
by the language you select.You can use more than one main word list to check your document.

User word lists on page 86
User word lists are unique to your XMetaL Author setup or document.You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Spell checker options
You can specify Spell Checker options through Tools > Spell Checker.Your settings are applied the next
time you open the spell checker.

DescriptionOption

Starts spell checking automatically from the beginning of
the document when you open the spell checker.

Auto Start

Sounds an alert when the spell checker finds a word it does
not recognize.

Beep On Misspelled

Re-checks all spelling from the beginning of the document
when you interrupt the spell checker and then click Resume.

Recheck All Text

Checks for words that contain numbers (for example, postal
codes).

Check Words With Numbers

Checks for duplicate words.Check Duplicate Words

Checks for incorrect capitalization (for example, two upper
case letters at the beginning of a sentence).

Check Irregular Capitalization

Asks for user input before replacing a word.Prompt Before Auto Replacement

Suggests words that sound similar to a flagged word.Show Phonetic Suggestions

Controlling the active dictionary via xml:lang
The xml:lang attribute value can be used to control which dictionary the spell checker uses.
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Whenever a spell checking action is in progress, the xml:lang attribute value will be inspected to determine
if a different dictionary should be used instead of the default dictionary. The following table described INI
variables that correspond to a particular dictionary, setting the INI variable to the xml:lang value you wish to
map to that dictionary:

Table 31:Table of INI Variable Names, Default Values, Internal Codes, Standard Codes and Recommended Values

WT FilesRecommended
INI Value

ISO-639-2ISO-639-1WT Legacy
Internal
Language Code
Default Value

WT INI Variable
Name

WT10LDAF.DLLaf;afrafrafAFWT_AFRIKAANS

WT10LDCA.DLLca;catcatcaCAWT_CATALAN

WT10LDCZ.DLLcs;ces;czeces, czecsCZWT_CZECH

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

WT10LDDK.DLLda;dandandaDKWT_DANISH

WT10LDNL.DLLnl;dut;nlddut, nldnlNLWT_DUTCH

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

WT10LDEN.DLLen;engengenENWT_ENGLISH

WT10LDFR.DLLfr;fra;frefra, frefrFRWT_FRENCH

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

WT10LDGA.DLLgl;glgglgglGAWT_GALICIAN

WT10LDDE.DLLde;deu;gerger, deudeDEWT_GERMAN

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.
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WT FilesRecommended
INI Value

ISO-639-2ISO-639-1WT Legacy
Internal
Language Code
Default Value

WT INI Variable
Name

WT10LDGR.DLLel;ell;gregre, ellelGRWT_GREEK

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

Note:
Ancient
Greek (before
the year
1454) is "grc"
and I assume
it is not
supported by
the spell
checker.

WT10LDIS.DLLis;ice;islice, islisISWT_ICELANDIC

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

WT10LDIT.DLLit;itaitaitITWT_ITALIAN

WT10LDNO.DLLno;nornornoNOWT_NORWEGIAN

WT10LDPO.DLLpt;porporptPOWT_PORTUGUESE

WT10LDRU.DLLru;rusrusruRUWT_RUSSIAN

WT10LDSL.DLLsk;slk;sloslo, slkskSLWT_SLOVAK

Note:  Both
codes are
considered
synonyms
and should
be treated
equally.

WT10LDST.DLLst;sotsotst{NULL}WT_SOTHO

WT10LDES.DLLes;spaspaesESWT_SPANISH

WT10LDSV.DLLsv;sweswesvSVWT_SWEDISH

WT10LDTN.DLLtn;tsntsntn{NULL}WT_TSWANA

WT10LDTR.DLLtr;turturtrTRWT_TURKISH
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WT FilesRecommended
INI Value

ISO-639-2ISO-639-1WT Legacy
Internal
Language Code
Default Value

WT INI Variable
Name

WT10LDXH.DLLxh;xhoxhoxh{NULL}WT_XHOSA

WT10LDZU.DLLzu;zulzulzu{NULL}WT_ZULU

zxxzxx{NULL}WT_NOLANGUAGE

en-AU;eng-AUeng-AUen-auOZWT_ENGLISH_AUS

en-CA;eng-CAeng-CAen-caCEWT_ENGLISH_CAN

en-GB;eng-GBeng-GBen-gbUKWT_ENGLISH_UK

en-US;eng-USeng-USen-usUSWT_ENGLISH_US

fr-CA;fra-
CA;fre-CA

fra-CA, fre-CAfr-caCFWT_FRENCH_CAN

fr-FR;fra-
FR;fre-FR

fra-FR, fre-FRfr-frFRWT_FRENCH_NAT

WT10LDDE.DLLde-DE;deu-
DE;ger-DE

deu-DE, ger-DEde-deDEWT_GERMAN_NAT

WT10LDDE.DLLde-CH;deu-
CH;ger-CH

deu-CH, ger-CHde-chSDWT_GERMAN_SWI

WT10LDPO.DLLpt-BR;por-BRpor-BRpt-brBRWT_PORTUGUESE_BR

WT10LDPO.DLLpt-PT;por-PTpor-PTpt-ptPOWT_PORTUGUESE_PO

WT10LDES.DLLes-US;spa-USspa-USes-usEAWT_SPANISH_AMER

WT10LDES.DLLes-ES;spa-ESspa-ESes-esESWT_SPANISH_SPAIN

zxxzxx{NULL}WT_NODIALECT

Using the background spell checker
You can check your spelling as you write using background spell-checking.

Background spell-checking displays red, wavy lines for any misspelled word to let you easily see and correct
spelling mistakes.You can also choose to correct a word that is highlighted as misspelled. Background spell-
checking also includes a feature that automatically replaces misspelled words as you type, using words from
the user word lists and main word list (if only one match exists).

You can use background spell-checking in the following ways:

• View misspelled words as soon as you have typed them.

• Allow the background spell-checking feature to automatically correct words that are similar to words in the
main or user word lists.

• Manually correct words that are similar to words in the main or user word lists.

Note:  Background spell-checking is on by default.

Related Links
Turning on background spell-checking on page 84

Background spell-checking can be turned on or off. The change affects all documents.

Automatically correcting spelling on page 84
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You can set up XMetaL to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Manually correcting spelling on page 84
You can manually correct misspelled words with words from the main word list and user word lists.

Turning on background spell-checking
Background spell-checking can be turned on or off. The change affects all documents.

1. Click Tools > Options.

2. In the General pane, select the Check spelling while typing check box.

3. Click OK.
The Options dialog box closes and changes are made to your settings.

Related Links
Automatically correcting spelling on page 84

You can set up XMetaL to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Manually correcting spelling on page 84
You can manually correct misspelled words with words from the main word list and user word lists.

Automatically correcting spelling
You can set up XMetaL to automatically correct misspelled words that are similar to words in the main word
list or user word lists. This feature is triggered for an individual word only when the spacebar is pressed
immediately after that word.

Note: Text in hyperlinks is not automatically corrected.

1. Click Tools > Options.

2. To automatically replace misspelled words, select the Replace words from my word list while typing
check box.

3. Click OK.
The Options dialog box closes and changes are made to your settings.

Related Links
Turning on background spell-checking on page 84

Background spell-checking can be turned on or off. The change affects all documents.

Manually correcting spelling on page 84
You can manually correct misspelled words with words from the main word list and user word lists.

Main word lists on page 85
Main word lists are the built-in word lists for a given language.The default main word list is determined
by the language you select.You can use more than one main word list to check your document.

User word lists on page 86
User word lists are unique to your XMetaL Author setup or document.You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Manually correcting spelling
You can manually correct misspelled words with words from the main word list and user word lists.

1. Place your mouse cursor over a misspelled word that is highlighted and right-click your mouse.
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A menu appears and displays options for correct spelling.

2. Select one of the listed options.
The misspelled word is replaced by the selected word from the main word list or user word lists.

Related Links
Automatically correcting spelling on page 84

You can set up XMetaL to automatically correct misspelled words that are similar to words in the
main word list or user word lists. This feature is triggered for an individual word only when the
spacebar is pressed immediately after that word.

Turning on background spell-checking on page 84
Background spell-checking can be turned on or off. The change affects all documents.

Main word lists on page 85
Main word lists are the built-in word lists for a given language.The default main word list is determined
by the language you select.You can use more than one main word list to check your document.

User word lists on page 86
User word lists are unique to your XMetaL Author setup or document.You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.

Main word lists
Main word lists are the built-in word lists for a given language. The default main word list is determined by
the language you select.You can use more than one main word list to check your document.

Follow these stepsTo do this

Click Tools > Spell Checker. In the spell checker, click
Options > Main Word Lists. Then click Add List and
choose a list.

Add a main word list

Click Options > Main Word Lists.Then click Remove List
and choose a list.

Remove a main word list

Related Links
Using the spell checker on page 79

You can check your spelling using the spell checker.

Using the background spell checker on page 83
You can check your spelling as you write using background spell-checking.

User word lists on page 86
User word lists are unique to your XMetaL Author setup or document.You can add words to your
user word list and tell Spell Checker to skip them, replace them with a different word, or suggest
alternatives for them.
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User word lists
User word lists are unique to your XMetaL Author setup or document.You can add words to your user word
list and tell Spell Checker to skip them, replace them with a different word, or suggest alternatives for them.

Follow these stepsTo do this

Click Tools > Spell Checker. In the spell checker, click
Options > User Word Lists. Then choose a word list and
click Set Default.

Set the default user word list

Click Tools > Spell Checker. In the spell checker, click
Options > User Word Lists. Then click Add List and
choose a word list.

Add a user word list

User word list files have the extension ‘.uwl’. The word list that is installed by default is WT10xx.uwl (where
‘xx’ is a language code). This file is available to any document created or edited in your setup of XMetaL
Author. If you have more than one of these lists installed on your system, you can add or remove them from
the set of word lists that the spell checker uses for your document.

The spell checker checks the default user word list before it checks the other user word lists or main word
list(s) In addition to the default word list, each document has its own word list.

Note: When you ignore a word during spell checking by clicking Skip All, that word is added to the
document user word list.

Adding an entry

To add an entry to the user word list:

1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.

3. Do one of the following:

• Enter the word in the Word/phrase text box
• Add a misspelling or a phrase that you want the spell checker to replace automatically and enter the

replacement in the Replace with text box

4. Click Add Entry.
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Related Links
Deleting an entry on page 87
Changing the replacement text for an entry on page 87
Changing an entry on page 87

Deleting an entry

To delete an entry in a user word list:

1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.

3. Select an entry in the Word/phrase text box and click Delete Entry.

Changing the replacement text for an entry

To change the replacement text for an entry in a user word list:

1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.

3. Select an entry in the Word/phrase text box and edit the text in the Replace With text box.

4. Click Replace Entry.

Changing an entry

To change an entry in a user word list:

1. Click Tools > Spell Checker.

2. Click Options > User Word Lists and select a word list.

3. Select an entry in the Word/phrase text box and click Properties.

4. Choose an option:

• Skip word. Select this option if you do not want the spell checker to flag the word as incorrect.
• Auto-replace entry. Select this option if you want the spell checker to automatically replace any

instance of the word or phrase in your document with the text in the Replace with text box.
• Exception entry. Select this option if you have multiple Replace with entries for one word and you

want the spell checker to ask you which replacement text to use when it encounters the word in a
document.

5. Edit the text in the Word/Phrase text box as required.
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This is the text that the spell checker finds (or ignores).

6. Edit the text in the Replace with text box as required.

If you want to enter more than one choice for replacement text (for Exception entry types), each choice
must be on a separate line in the Replace with text box.

Note:  If the Auto-replace entry option is enabled, any text in the Replace with text box is ignored.

Language settings
You can choose a language for the current file or set it as the default language for the spell checker and
thesaurus.You can also add and remove languages.

Follow these stepsTo do this

Click Tools > Spell Checker. In Spell Checker, click
Options > Language. Then enable the Save as default
Writing Tools language option and choose a language.

Set the default language

Click Options > Language.Then click Add and type a two-
letter code for the language you want to add (the code must
be unique) and a description (the name of the language).

Add a language

Click Options > Language. Then select a language and
click Remove.

Remove a language

You can use the spell checker to format dates, time, currency symbols, and other text according to a language
convention (for example, “12 avril 1996” for a French document).

Related Links
Checking your spelling on page 78

You can check your spelling using the spell checker or as you write by using background
spellchecking.

Using the thesaurus on page 89
You can look up a word and display synonyms, antonyms, and other related information using the
thesaurus.

Checking a selected word's spelling and synonyms
The word that is currently under the cursor can be checked with the hot key Ctrl + . (Ctrl + period).

The word is checked as follows:
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• If the word is misspelled, correct words are proposed in the dialog that opens.

• If the word is spelled correctly, a list of synonyms, antonyms and groups of related words are displayed.

You can navigate forward and backward between the lists of proposed words. Every related word can have
its own list of related words, and it's possible to return back or move forward in the search chain.

Using the thesaurus
You can look up a word and display synonyms, antonyms, and other related information using the thesaurus.

Follow these stepsTo do this

Select a word in your document, click Tools > Thesaurus,
and click Look Up. Expand the desired definition to display

Replace a word using the thesaurus

a list of synonyms and other words. Choose a word and
click Replace.

Look up a word in the thesaurus and expand the desired
definition to display a list of synonyms and other words.
Choose a word and click Insert.

Insert a word from the thesaurus
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Thesaurus options
You can specify thesaurus options through Tools > Thesaurus.Your settings are applied the next time you
open the thesaurus.

DescriptionOption

Displays the thesaurus entry for the current word when the
thesaurus is opened.

Auto look-up

Closes the thesaurus after you insert a word in your
document.

Auto close

Suggests alternate spellings if the word is spelled incorrectly
or not found in the thesaurus.

Spelling assist

Displays words that have the same or similar meaning as
the word being looked up.

Synonyms

Displays words that have an opposite meaning.Antonyms

Sets a language-specific data file for the thesaurus.Set data file
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Tracking your changes
In Normal and Tags On views, you can display changes as marked insertions or deletions. When change
tracking is active, text that is inserted in a document appears in a distinctive color or formatting.You can hide
text that has been deleted, or you can display it in a distinctive color and with strikethrough formatting.

Follow these stepsTo do this

Click Tools > Track ChangesTurn on (off) track changes

Click Tools > Accept or Reject Changes. Then click Find
previous (Find next).

Scroll through changes

Click Tools > Accept or Reject Changes. Then click
Accept all (Reject all).

Accept (reject) all changes

Click Tools > Accept or Reject Changes. Then click
Accept (Reject).

Accept (reject) changes one at a time

The following types of changes can be tracked:

• Text inserted or pasted

• Text deleted or cut

• Text moved by drag-and-drop

Changes can be accepted or rejected on an individual or global basis. When marked changes are accepted,
the changes are incorporated into the document and the revision marks are removed.When marked changes
are rejected, the changes are removed, and the deleted text (if any) is restored to the document.

Note: When rules checking is active, changes that are necessary to make the document valid are not
rejected.

Related Links
Options on page 55

You can set options through the Tools menu.
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Cross-file Operations
You can perform certain actions or operations, such as finding text or spell checking, across multiple files.

You can perform certain actions or operations, such as finding text or spell checking, across multiple files.
You will have the option to choose from several different locations, including the DITA Maps currently open,
all open documents, and the current document.

Finding and replacing across files
You can perform cross-file searches to find text or markup using simple text and pattern matching all the way
up to very advance XPath expressions.

You can search for text, markup, and XPath expressions with the Find in Files feature. The results will be
displayed in the Results pane. The results will be sorted alphabetically by filename.You can remove, select,
highlight and replace results, as well as perform new searches on the results.

Double-clicking on a search result opens the containing document.

Find text across files
You can search across files for text. The Find in Files dialog box can be opened from the editing pane.
Results can be displayed on one of two pages, allowing you to keep the results of two searches displayed
at one time.

1. Click Edit > Find in Files.
The Find in Files dialog box opens.

2. Enter the search string in the Text field.

3. Select the search location from the Look In drop-down list. Alternatively, click Browse to browse for the
search location. The following options are available in the Look In drop-down list:

• All Open Documents - searches all documents that are currently open
• Current Document - searches the topic file you have currently open
• Checked files in: Find [1 or 2] Results pane - searches the already checked files in the Find 1 or 2

Results pane (Note: This option is only available when initiating a search from the Find 1 or 2 Results
pane)

4. Select Look in subfolders to include in the search all subfolders located under the folder of the file you
are searching.
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5. (Optional) Select from one of the following options:

• Match case - search results include only words that have the same capitalization as the search word
• Match whole words only - search results will only be returned for word matches with a whitespace

occurring on either side of the word. (For example, if searching for 'use', only occurrences of the word
'use' are found, and search results will not return words such as 'user' or 'uses'.)

• Match whole phrase - when searching for a phrase, results are returned only for the exact series of
words being searched

• Match all words - search results only include files that contain all the search words in any location
within the searchable document(s). The words can be in any order, and do not have to be displayed
in any sequence.

• Use pattern matching - see Search patterns on page 76
• Use regular expression matching - see definition of regular expression

6. Select the Find 1 or Find 2 results pane to display results.

7. Click Find.
Results are displayed in the selected window in the Results pane. Double-clicking on a search result
opens the containing document.

Related Links
Finding and replacing text on page 75

You can search for a text string and replace it with different text or with a text entity.You can also
restrict your search to a text string that occurs within a specific element.

Find markup across files on page 93
You can search for occurrences of specific elements or attributes across files.

Find markup using XPath expressions on page 94
Find markup using XPath expressions.

Find markup across files
You can search for occurrences of specific elements or attributes across files.

1. Click Edit > Find in Files.
The Find in Files window opens.

2. Click the Markup tab.

3. Specify the Elements or Attributes you want to find, along with one of the following options:

• exists
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• contains
• equals
• does not equal
• does not exist

4. Select the search location from the Look In drop down menu. Alternatively, click Browse to browse for
the search location.

5. Select Look in subfolders to include all subfolders in the search.

6. Select the Find 1 or Find 2 window to display results.

7. Click Find.
Results are displayed in the selected window in the Results pane.

Find markup using XPath expressions
Find markup using XPath expressions.

1. Click Edit > Find and Replace.
The Find in Files window opens.

2. Click the XPath tab.

3. Enter a path expression in the XPath field, or select a path expression from the History drop-down list.

4. Select the search location from the Look In drop-down list. Alternatively, click Browse to browse for the
search location.

5. Select Look in subfolders to include all subfolders in the search.

6. Select the window, Find 1 or Find 2, in which you want your results displayed.

7. Click Find.
The results are displayed in the selected window in the Results pane.

Related Links
W3C Schools XPath Tutorial

Spell checking across files
You can spell check across files by using the Spell Check in Files feature.You will need to select the folder
you want to spell check.

To do this:
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1. Click Tools > Spell Check in Files.
2. Enter the name of the folder you want to spell check.
3. Select the 'include subfolders' check box to spell check content in all subfolders.
4. Select from any of the following output options:

• Show markup attributes - Displays markup attributes in the results
• Show suggestions - Displays replacement options for correct spelling with the results. Tapping on a

replacement option inserts it in place of the original text
• Fast spell check - The spell check does not load the DTD or XSD for each XML document being spell

checked.

NOTE: If your documents have DTD-inferred attributes such as xml:lang="fr-FR", you may get the wrong
dictionary applied during the spell check when using Fast Spell Check.

5. Click Spell Check to perform the spell check across files.

Results are displayed in a tab in the Results pane.

Note: The Spell Check in Files feature will not differentiate between markup and text.

Replacing results across files
After you have performed a cross-file search or spell check, you can replace any or all of the results.

1. In the Results pane, select the check boxes of the results you want to replace, OR click the Check all

items button ( ) to select all results.

Note: You can click Uncheck all items ( ) to clear all check boxes.

2. In the Replace with: field, enter the replacement text or markup.

3. (optional) Click the Set Replacement Options button ( ) to set replacement options. For instructions,
see Setting replacement options on page 95.

4. Click the Replace all checked items button ( ) to replace only the items you have checked,

OR click the Replace all highlighted items button ( )

After you have replaced text or markup, you can click the New search in checked files button ( ), or press
F7, to perform a new search on the already searched files for which results are displayed in the current tab
of the Results pane.

Setting replacement options

1. In the Results pane, click the Set replacement options button ( ).
The Replace Options dialog appears.

2. In the General section, set the following:

• Open files - when a replacement is performed, the affected file is opened.When Open files is checked,
you can perform undo operations for each open file to undo text replaced using the 'Replace with' feature.

• Track changes - all changes made by the replacement operation will be displayed
• Make backup files - Create backup files. if you chose to make backup files, enter the default file extension

for the backup files.

3. In the Replace All Checked Options section, set the following parameters:
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Don't redo prior replacement even if checked - if an identical replacement operation has been performed
on a checked field, it will not be repeated even if that file is again checked

•

• Uncheck items after replacement - the results that are checked will be unchecked after the replacement
operation has finished

4. In the Interpret-as-markup strictness section, select one of the following options:

• Full - checks the markup compatibility of the replacement value and the location into which it is inserted
as well as its children

• Partial - checks the markup compatibility of the replacement value and the location into which it is
inserted

• None - markup is not checked

5. Click OK.
The new settings now apply to all future replace actions in the Results pane.

Running cross-file operations
The Run Cross-File Operation feature allows you to run other cross-file operations that may have developed
specifically for your needs.

Follow these stepsTo do this

Click Tools > Run Cross-File OperationRun cross-file operation

The Run Cross-File Operation feature allows you to run the chosen cross-file operations:

• Accept All Changes - accepts all the changes tracked in the selected folder or given set of files
• Detect Duplicate IDs - looks for duplicate attribute values for specific attribute type within each document
• Validate References - validates all the cross references by asserting if the file is present or not; it will report

any broken links
• Word Count - counts the words in each file and report the number of words in each file and the total number

of words

You can apply the cross-file operation to any of the following:

• All Open Documents - searches all documents (topic files) that are currently open

• Current Document - searches the topic file you have currently open

• You can also click Browse to select a specific folder on which to run the cross-file operation. The cross-file
operation will apply to all files in the folder (and subfolders, if the Include subfolders check box is selected).
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Cross-file operations
Cross-file operations provide searching, spell checking and other operations across multiple files in a folder
or references from a ditamap.

Cross-file operations can be limited to a defined set of files. By default, xml, sgml, sgm, dita, and ditamap file
types are selected.

To set cross-file operation preferences:

1. Select Tools > Options from the main menu.

The Options dialog box opens.

2. Under Cross-File Operations, select General to add or remove file types whose processing you want to
limit.

3. You can optionally choose to include or exclude attributes from the DTD.

Note:  Selecting this check box causes cross-file operations to run slower.

4. Click OK to save changes.

Results pane
The Results pane displays the results of cross-file operations, such as the Find in Files feature, and
error-reporting features, such as the Validation Log.

Follow these stepsTo do this

Click View > Results > ValidationShow Validation log

Click View > Results > XIncludeShow XInclude link errors log

Click View > Results > Find 1Show Find 1 results

Click View > Results > Find 2Show Find 2 results

Click View > Results > Spell CheckingShow Spell Checking results

Click View > Results > Cross-File OperationShow Cross-File Operation results

Results for the following features will be displayed in the Results pane:

• Validation - Lists markup errors

• XInclude - Displays XML inclusion link errors
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• Find 1 and 2 - Lists search results for the Find in Files feature

• Spell Checking - Lists all spelling errors

• Cross-File Operation - Lists results for the Run Cross-File Operation feature

• Accept All Changes - For each XML document, all XMetaL track changes will be accepted

• Detect Duplicate Ids - Look for duplicate occurrences of ID attribute values within each document

• Validate Cross References - For each XML document, check for broken references
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• Word Count - Count all the words in all the topics of this ditamap

Related Links
Panes on page 13

Panes provide access to the markup in your document and let you organize resources.You can
have one or more panes open in your work area at any time.You can dock a pane so that it is
attached to the work area border, or the pane can float.You can pin a pane to keep it open, or un-pin
a pane to hide it.

Results pane actions
A list of actions, including the their button, name, and description. Most of the features will have similar actions,
such as previous and next.

Table 32: Common actions

DescriptionNameButton

Select the previous location in
the results list (Shortcut:
Shift+F4)

Previous

Select the next location in the
results list (Shortcut: F4)

Next

Toggle line wrapping (applies
to list view only)

Wrap

Switch view (tree versus list)Switch View

Expand all the results to
display in a tree view

Expand All

Collapse all the results to
display in a folder view

Collapse All

Text to search for amongst
result items

Find in result

Text to replace searched for
result

Replace with

Find previous occurrence of the
phrase

Find previous
phrase
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DescriptionNameButton

Find next occurrence of phraseFind next
phrase

Close resultsClose Tab

Table 33: Actions specific to Find in Files

DescriptionNameButton

Highlight all results in the active
document

Toggle
highlighting

Remove results that are
highlighted and that have their
check boxes selected

Remove
selected
item(s) from
results

Open the Replace Options
dialog to set replacement
options

Set
replacement
options

Select all check boxesCheck all
items

Unselect all check boxesUncheck all
items

Denote that the replacement
you are using is an element

Replace as
markup

Replace all results that are
highlighted with the text from
the Replace With text field

Replace
highlighted
text

Replace all results that are
checked with the text from the
Replace With text field

Replace all
checked items

Perform a new search only
in the files that you have

New search in
checked files

checked and for which
results are displayed in the
current tab of the Results
pane. (Shortcut: F7)

Table 34: Actions specific to Spell Check in Files

DescriptionNameButton

Add the word to the dictionaryAdd to
dictionary
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DescriptionNameButton

Re-check spelling in those files
only in which spelling errors

Re-check
found files
only were found in the initial spell

check (Keyboard shortcut: F7)

Show spell checker after
jumping to result

Show Spell
Checker

Highlight all results in the active
document

Toggle
Highlighting

Replace all results that are
highlighted with the text from
the Replace With text field

Replace
highlighted
text

Open the Replace Options
dialog to set replacement
options

Set
replacement
options

Text case assistant
The text case assistant provides text casing adjustment options for selected text.

To change text case, select the text for which you want to change the case, and then either click Ctrl + F3
(by default) or right-click to open the context menu and select Text Case and one of the available options.
The options are:

• Sentence case. - only the first letter of the sentence is in upper case when a full stop is included in the
selection

• lowercase - all letters in the selection are displayed in lower case

• UPPER CASE - every letter in the selection is capitalized

• Capitalize Each Word - the first letter of every word in the selection is capitalized

• tOGGLE cASE - the case is inverted for each word in the selection

Note: The tOGGLE cASE option is only available in the right-click menu and not when using Ctrl + F3.

To set text case assistant preferences:

1. Select Tools > Options from the main menu.
The Options dialog box opens.

2. UnderAssistants, selectText Case.

3. In the Display section,

• select Show in context menu to include the text case assistant in the right-click menu or select, or
• select Show in Format toolbar to display the text assistant in the Formatting toolbar.

Note:  For this change to take effect, a system restart is required.
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4. The trigger is, by default, Ctrl + F3. This trigger key can be edited in the Trigger section by selecting a
keyboard trigger from the list.

5. Click OK to save changes.

Working with Markdown documents
XMetaL supports the Markdown syntax and provides an easy to use split-screen editor.You can write
documents in Markdown as well as convert documents into Markdown and convert Markdown documents
into HTML and MS Word Document.

When editing a Markdown document, the editor has two panels. The Markdown syntax is highlighted in the
editor's left pane.GitHub Flavored Markdown (which is a strict superset of CommonMark) rules are used.The
right side is a web preview that is synchronized in real-time. For reference, see the remote-components topic
in the Remote Lighting (LwDita) sample document in Help > Samples.

The Markdown document can be converted to HTML and MS Word Document.
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Authoring structured content

When you create a document instance of a DTD or Schema in Normal or Tags On view, XMetaL Author
ensures that your content is valid by guiding you through the authoring process.You do not need to have a
complete understanding of XML to begin authoring structured content.

Here are some of the ways in which XMetaL Author helps you create documents that conform to a DTD or
Schema:

• The Element List displays only elements that are valid at the current element. Required elements are
displayed in bold.

• The Attribute Inspector displays the attributes for the current element. Attributes that require a value are
displayed in bold.

• Commands and menu items are unavailable if using them would result in an invalid document.

• You are prevented from typing text in the current location if the DTD or Schema does not allow it. If you
type at a location where text is not allowed, text is wrapped in the first valid paragraph element (if available).

• You are prevented from deleting an element if it is required by the DTD or Schema.

• You are prevented from inserting a CDATA section or other marked section that would result in an invalid
document.

• You are prevented from pasting elements or text at an invalid location. The Smart Insert feature inserts
them at the next valid location in the document or the paste operation is not completed.

• You are prevented from dropping assets from the Resource Manager at an invalid location. The Smart
Insert feature inserts them at the next valid location in the document or the paste operation is not completed.

• You are prevented from inserting elements at an invalid location. The Smart Insert feature inserts them at
the next valid location in the document.

• When working with change tracking, you cannot reject a change that is necessary to make the document
valid.

• When using Find and Replace, you cannot make an element replacement that would make the document
invalid.

Related Links
Appendix A: XML basics on page 234

XML (Extensible Markup Language) is a recommendation of the World Wide Web Consortium (W3C).
It is a language for describing the structure and content of a document. Authors use XML to “mark
up” their documents for a consuming application such as a Web browser or print formatting engine.
XML is an application of SGML (Standard Generalized Markup Language). XML is more flexible
than other markup languages such as HTML because it allows you to create your own markup.This
makes it better suited to describing and processing complex information.

Validation and rules checking
Validation checks to see if the markup is correct and complete with reference to your DTD or Schema. Rules
checking ensures that you do not break the required structure as you edit your document by allowing you to
insert only valid elements.

Follow these stepsTo do this

Click Tools > Validate DocumentValidate a document
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Validation occurs automatically when you save your document or when you switch from Plain Text view to
Normal or Tags On view.You can validate an entire document, or you can select a selection of your document
to validate. Errors are displayed in the Validation Log.

Validation checks that the following conditions have been met:

• All elements, attributes, and entities used in the document have been declared.

• All required elements are present.

• All required attributes are present.

• All attributes are in the correct form.

• All ID attribute values are unique, and each IDREF attribute value matches an ID attribute value.

Rules checking is less stringent than validation in that it checks that no errors have been made, but does not
check that the markup is complete. For example, rules checking does not check required elements, undeclared
entities, or missing ID values.

Rules checking occurs in Normal and Tags On views only.

Validation using Schematron
The Schematron differs in basic concept from other schema languages in that it not based on grammars but
on finding tree patterns in the parsed document. This approach allows many kinds of structures to be
represented which are inconvenient and difficult in grammar-based schema languages.

NOTE: XMetaL now supports XSLT 2.0 for Schematron validation using Saxon-CE version 1.1. Saxon-CE
implements XSLT 2.0 at a minimum conformance level meaning it is a "Basic XSLT 2.0 Processor" as defined
by the W3C XSLT 2.0 Specification.

To validate using the Schematron:

1. From the Tools menu, select Validate using Schematron (or hit CTRL + F9).

2. In the Schematron results pane, user the drop-down list to select a Schematron file to apply, and then
click the Schematroll button to run the validatation.

3. You can also adjust the Schematron processing settings by going to the unified Options pane and clicking
on the Tools > Schematron option.

For more information on Schematron validation, see http://schematron.com/.

Schematron Options
You can control options for global parameters, processing and debugging in the Tools > Schematronsection
of the Options dialog box.

Table 35: Global Parameters

DescriptionOption

Please refer to http://www.schematron.com for more details.Pass through non-Schematron elements

Add diagnostics to assertion results

Generate XPath values for SVRL @location attributes

XMetaL Author Help104

Validation using Schematron

http://schematron.com/
http://www.schematron.com


Table 36: Schematron Processing

DescriptionOption

Please refer to http://www.schematron.com for more details.Run Document Schema Definition Languages (DSDL)

phase

Run Abstract Patterns expansion phase

Run custom SVRL to HTML results stylesheet

Table 37: Debugging Options

DescriptionOption

The debug version of Saxon-CE provides error and event

logging capabilities with a configurable logging threshold.

Use debug version of Saxon-CE

For definitions of the logging levels, see
http://www.saxonica.com/ce/user-
doc/1.1/html/coding/logging.html

Logging Level

The default logging level is set to SEVERE.
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XMetaL customizations
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an XMetaL
customization is the DTD or Schema. Journalist is provided as an example customization. For detailed
information about creating and deploying customizations, see the XMetaL Customization Guide.

Table 38: Customization files

DescriptionName

The customization file. Contains authoring behaviors that
are based on the elements and attributes in your DTD or

<dtdname>.ctm

Schema (for example, some keyboard shortcuts, Enter key
behavior, and mini-templates).

The style sheet for documents. Styles are based on element
names. By default, XMetaL recognizes many elements
defined in XHTML, DocBook and the Journalist DTD.

<dtdname>.css

The style sheet for the structure view.<dtdname>_structure.css

Contains toolbars and menus.<dtdname>.tbr

Contains macros.<dtdname>.mcr

When you open a document, XMetaL searches for customization files in the following locations, in the following
order:

1. The same folder as the DTD or Schema

2. Your personal settings folder (usually %APPDATA%\SoftQuad\XMetaL\<version>\)

3. The XMetaL Author installation folder (usually ..\XMetaL <version>\Author\) and sub-folders

If the customization file or style sheets are not found, they are created in the same folder as the DTD or
Schema.

When you work on a shared computer, you may want to save your customization files to your personal settings
folder. Customization files that are saved in your personal settings folder are not deleted when you uninstall
XMetaL Author.

Journalist customization

The Journalist customization is shipped with XMetaL Author to give you an introduction to authoring structured
documents. This customization is designed to support the authoring of article-type documents. Templates
have been provided.

The Journalist customization is based on the following DTD:

..\XMetaL <version>\Author\Rules\journalist.dtd

Some of the formatting and behaviors in this customization include the following:

• A mini-template consisting of an Article Title, Section 1 Title, and paragraph. Special formatting is applied
to each.

• Type a title and press Enter. A paragraph element is inserted.

• If the selection or insertion point is inside a sequence of nested block elements, pressing Enter repeatedly
moves the insertion point up the hierarchy of nested elements.
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• Follow the prompts in the replacement text that is displayed when you create an element.

• Clicking to the right of a table moves the insertion point outside of the table.This is particularly useful when
the table is at the bottom of the document.

• If you are editing a <pre>-like element (one in which whitespace is preserved), press Enter to insert a line
break, and Shift + Enter to close the element and start a new paragraph.

• To see the context of the current element, check the context bar to the left of the horizontal scrollbar.

• Followed-by elements are defined for some elements. For example, when your cursor is positioned before
the end tag of an ordered list (</OrderedList>) and you press Enter, a <Para> element is inserted.

Related Links
Custom toolbars and menus on page 23

You can create new toolbars and menus and customize existing ones.You can assign buttons and
menus to built-in commands or user-defined macros.

Macros on page 51
A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Options on page 55
You can set options through the Tools menu.

Creating documents on page 58
You can create a document from a template, create a blank XML or SGML document, or create a
blank, well-formed XML document.You can set file options, including a default template, filename
extensions, and autosave intervals through Tools > Options.

Images on page 112
You can insert images into your documents if your XMetaL customization recognizes elements in
your DTD or Schema as image elements.

Working with elements
Elements are the building-blocks of your documents. They are defined in your DTD or Schema. Authoring in
Normal view is similar to applying styles, whereas Tags On view lets you work with elements as structural
objects.You can insert elements using the Element List, the Insert menu, or the In-place, look-ahead
element list.

Follow these stepsTo do this

In the Element List, click the Insert option, select an element
and click Apply or double-click an element

Insert an element or wrap a selection in an element

In the Element List, click the Change option, select an
element and click Apply

Change an element

Click Edit > Split Element or press EnterSplit an element

Click Edit > Join Element to PrecedingJoin two adjacent elements

Click Edit > Remove TagsRemove tags (Unwrap an element)

Some elements include a mini-template, which contains elements and prompt text that you can replace with
your own content. For example, the <OrderedList> element in the Journalist customization contains a
mini-template.
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The current element refers to the element containing the insertion point or selection. If an entire element is
selected, the current element is the parent of that element, not the selected element itself. In Normal and
Tags On views, the context of the current element (that is, its position in the element hierarchy) is displayed
in the document status bar.

Elements are categorized as follows:

• Block elements. These elements are preceded by and followed by line breaks, such as <Para> in the
Journalist DTD.

• Inline elements. These elements are not preceded or followed by line breaks. They are often used for
typeface modifications, such as <Strong> and <Emphasis> in the Journalist DTD. In some customizations,
these elements can be inserted using the Formatting toolbar.

• Empty elements. These elements cannot have any text content. They are designated by the  icon in
Normal and Tags On views. Empty elements are often used to reference images.

• Read-only elements. The content or attributes of these elements cannot be edited, for example,
<LastModDate> in the Journalist DTD.

Related Links
Panes on page 13

Panes provide access to the markup in your document and let you organize resources.You can
have one or more panes open in your work area at any time.You can dock a pane so that it is
attached to the work area border, or the pane can float.You can pin a pane to keep it open, or un-pin
a pane to hide it.

Toolbars on page 16
You can show/hide toolbars, create new toolbars, or modify existing ones through View > Toolbars.

Creating well-formed XML documents on page 67
When you create a blank well-formed XML document, you must define elements and attributes
before you can create content. Because the document is not based on a DTD or Schema no rules
checking or validation occurs.

Keyboard shortcuts on page 228

XMetaL Author Help108

Working with elements



Shortcut keys for menu commands are indicated in the menus. All menus, menu items, and dialog
box controls are accessible by pressing the Alt key and the underlined letter (also called an access
key or mnemonic) associated with that control. XMetaL Author also supports shortcut keys for window
and dialog box navigation and other functions.

In-place, look-ahead element list
The in-place, look-ahead element list is a popup list of candidate elements to insert in Normal View.You may
bring it up by pressing Ctrl+Enter.

The in-place, look-ahead element list contains elements that are valid, by default, within three containers of
the current one. The element list pane only contains valid elements for the current container.

Editing the in-place, look-ahead element list
The display properties, insert actions, and keyboard combination for triggering the in-place, look-ahead
element list can be edited using the QuickMarkup Assistant Preferences window.

To edit the in-place, look-ahead element list:

1. Select Tools > Options from the main menu.

The Options dialog box opens.

2. Under Assistants, select QuickMarkup.

3. In the Display section, customize the following display properties of the list:

• Width - edit the width of the list

• Height - edit the height of the list

• Position - select whether the list appear above or below the cursor

• Depth - select the number of container levels of valid elements that are displayed

• Include table elements - include table-specific elements in the list

4. In the Insert Action section, select the action to be taken when inserting an element.

• Element-only - XMetaL inserts only the selected quick-insert element

• Using mini-template - XMetaL inserts the element using the mini-template defined in the customization
(.ctm) file used to customize XMetaL for the DTD

• With required elements - XMetaL analyzes the DTD or XSD and, based on the selected quick-insert
element, inserts any additional elements that are required to make the document valid in that area of
insertion

5. In the Trigger section, customize which CTRL+ keyboard combination opens the in-place, look-ahead
element list.
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6. Click OK to save changes.

Setting attribute values
You can set attribute values through the Attribute Inspector.

Follow these stepsTo do this

In the Attribute Inspector, type or select an attribute valueSet an attribute value for an element

The Attribute Inspector panel will, whenever possible, automatically suggest an attribute value if the same
attribute already has a value assigned elsewhere in the document on the same element type.This can greatly
speed up the repetitive task of assigning the same value to the same attribute throughout the document.

Tip: You can select any ancestor of the current element from the list at the top of the Attribute Inspector.

Special characters in attribute values

The following characters must be escaped.

Escape sequenceCharacter

&lt;<

&gt;>

&quot;"

&apos;'

&amp;&

Related Links
Panes on page 13

Panes provide access to the markup in your document and let you organize resources.You can
have one or more panes open in your work area at any time.You can dock a pane so that it is
attached to the work area border, or the pane can float.You can pin a pane to keep it open, or un-pin
a pane to hide it.

Options on page 55
You can set options through the Tools menu.

Inserting and editing lists
You can insert lists into your documents if your XMetaL customization recognizes elements in your DTD or
Schema as list elements.

Follow these stepsTo do this

Click  (Numbered List) on the Formatting toolbar
Insert a numbered list

Click  (Bulleted List) on the Formatting toolbarInsert a bulleted list

Select one or more paragraphs and click  or 
Convert paragraphs to a list or change list type
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Table 39: Keyboard shortcuts

Follow these stepsTo do this

Position the cursor in a list item and press Enter (press
Enter twice if the contents are surrounded by a sub-element
such as a paragraph)

Insert a list item

Insert a list item and press TabInsert a list within a list

Select one or more list items and press TabConvert list items to a nested list

Select one or more list items and press Shift+TabConvert list items to paragraphs

Position the cursor in a list item and press TabDemote one or more items to a sub-list

Position the cursor in a list item and press Shift+TabPromote a sub-list up one level to its containing list

Position the cursor in a list item and press Enter twice (once
if you are already in an empty list item and three times if
the list item contents are surrounded by a sub-element)

Terminate a list

Tip: You may find Tags On view preferable when working with lists.

If your DTD or Schema declares the HTML <UL> or <OL> elements, XMetaL Author recognizes them as list
elements.Your DTD should also declare the <LI> (list item) element. The Journalist DTD declares the
<ItemizedList> and <OrderedList> elements.

Definition lists consist of pairs of terms and definitions.You can use definition lists for any purpose that is
suited to two-part lists. The <VariableList> element in the Journalist DTD is an example of a definition
list:

<VariableList> <VarListEntry>
<Term>Term1</Term> <ListItem>Definition1</ListItem>
</VarListEntry> <VarListEntry> <Term>Term2</Term>
<ListItem>Definition2</ListItem> </VarListEntry>
</VariableList>

Sort a list
You can sort an entire list, or selected list items in a list.

1. (optional) If you only want to sort certain list items, highlight the items you want sorted in the list.

2. Click Edit > Sort.
The Sort List dialog box opens.

3. If you selected list items to sort in step 1, select to sort either Selected Items or the Entire List.

4. In the Type field, select to sort by one of the following:

• Text - sorts columns in order, alphabetically and by numerical value
• Number - sorts columns in order by number. Sorting pays only attention to numerical values, and entries

beginning with letters are not sorted and instead appear at the beginning or end of the range depending
on your sorting direction.

• Natural - sorts values in a natural order, numerically and alphabetically
• Date - sorts values by date

5. Select either Ascending or Descending sorting direction.

6. Click OK.
The list is sorted.
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Images
You can insert images into your documents if your XMetaL customization recognizes elements in your DTD
or Schema as image elements.

Follow these stepsTo do this

Click Insert > Image and select an image.

- OR -

Insert an image

Drag and drop an image (from within or outside
XMetaL) to where you want to place it. It will be
automatically placed in an image element.

File navigation options are available in the Choose
Image File dialog as follows:

• Show Folder - displays the folder for a selected file
to allows users to navigate to the folder where the
image is located.

• Find all files in folders - allows users to view all
files in a selected directory, including sub-folders,
in one list.The file extensions filter allows, including
sub-folders, to narrow down list of file specific types.

• A powerful file preview feature.

Insert an image element using the Element List, then specify
the entity name as the value of the source attribute (or
attribute that represents the image file)

Insert an image represented by an entity

If your DTD or Schema declares the HTML <IMG> element, XMetaL Author recognizes it as an image element.
Your DTD should also declare the following attributes of the <IMG> element: SRC, ALT, HEIGHT, and WIDTH.
The Journalist DTD declares the <Graphic> and <InlineGraphic> elements.

Related Links
Assets (unsupported) on page 50

You can organize frequently used objects as assets through the Resource Manager. Assets can be
single files, such as images, text, or markup blocks.You can drag and drop assets into your document.

XMetaL customizations on page 106
Formatting and authoring functionality are provided by an XMetaL customization. The basis for an
XMetaL customization is the DTD or Schema. Journalist is provided as an example customization.
For detailed information about creating and deploying customizations, see the XMetaL Customization
Guide.

Supported display formats
XMetaL Author can display several image formats.

Table 40: Supported display formats

NotesFile extensionName

Only the Windows BMP format is
supported.

BMPWindows Bitmap
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NotesFile extensionName

EPS files must contain an embedded
TIFF header.

EPSEncapsulated PostScript

Only the first image in an animated GIF
is displayed.

GIFGraphic Interchange Format
(Compuserve)

JPG (or JPEG, JPE, JFIF, JIF)Joint Photographic Experts Group

ICOWindows Icon

WMF files must include a placeable
header.

WMFWindows Metafile

EMFEnhanced Metafile

PNGPortable Network Graphics

Only the first image in a file containing
multiple images is displayed.

TIF (or TIFF)Tagged Image File Format

PCXPC Paintbrush

TGATruevision Graphics Adapter or TARGA

Requires installation of an SVG viewer
(for example, Adobe SVG Viewer).

SVGScalable Vector Graphics

Related Links
Options on page 55

You can set options through the Tools menu.

Tables
XMetaL Author supports the HTML and CALS table models. If your DTD or Schema uses either of these
models, you can use the Table menu to insert and edit tables.

Note:  XMetaL Author does not support both table models in the same DTD or Schema.
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Appropriately formatted content from other applications can be pasted or dragged and dropped into an XMetaL
document as a table.

You can choose to display or hide table grid lines for tables that do not have set borders through the View
menu.

Navigating within tables

Here are some convenient ways to navigate between table cells:

• To move between cells, press an arrow key

• To move to the next cell in a row, press Tab

• To move to the previous cell in a row, press Shift+Tab

Related Links
Keyboard shortcuts on page 228

Shortcut keys for menu commands are indicated in the menus. All menus, menu items, and dialog
box controls are accessible by pressing the Alt key and the underlined letter (also called an access
key or mnemonic) associated with that control. XMetaL Author also supports shortcut keys for window
and dialog box navigation and other functions.

HTML tables
If your DTD or Schema declares the <TR> and <TD> elements, XMetaL Author assumes the HTML table
model.

HTML tables consist of rows and cells. Table rows (as denoted by <TR> elements) may be grouped into
header, footer, and body sections (<THEAD>, <TFOOT>, and <TBODY>). Table cells may contain header-type
or data-type information (<TH> or <TD>).

Here is an example of an HTML table:

<TABLE><CAPTION>Live births,
Feb to Mar</CAPTION> <THEAD>
<TR><TH>Gender</TH><TH>Number</TH><TH>%</TH></TR>
</THEAD> <TBODY>
<TR><TD>Female</TD><TD>62</TD><TD>50.8</TD></TR>
<TR><TD>Male</TD><TD>60</TD><TD>49.2</TD></TR>
</TBODY> </TABLE>

CALS tables
If your DTD or Schema declares the <tgroup> element, XMetaL Author assumes the CALS table model.
XMetaL supports a definition of the CALS DTD developed by OASIS.

CALS tables contain the <tgroup> grouping element. <tgroup> elements contain a table header, table
body, and table footer (as denoted by <thead>, <tbody>, and <tfoot> elements, respectively). Headers
and footers are optional.You can insert a header when you insert the table, or you can change the row type
(for example, change a body row to a header row) through the Row tab of the Table Properties dialog.

You can insert a CALS table with a maximum of 150 rows and 150 columns. If you need more, you can add
them after you create the table.

Here is an example of a CALS table:

<table><title>Live births, Feb to
Mar</title> <tgroup cols="3"> <thead>
<row><entry>Gender</entry><entry>Number</entry><entry>%</entry></row>
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</thead> <tbody>
<row><entry>Female</entry><entry>62</entry><entry>50.8</entry></row>
<row><entry>Male</entry><entry>60</entry><entry>49.2</entry></row>
</tbody> </tgroup> </table>

Inserting and editing tables

You can insert and edit tables from the Table menu. When you insert a table, you specify basic table layout
including the number of rows and columns.You can add or remove rows or columns and split or merge cells
in a table. These operations affect the table structure.

When editing tables, the auto-suggest table cell feature will, whenever possible, automatically suggest a text
value for a table cell. This can greatly speed up the repetitive task of filling in table column values throughout
the document.

Insert a table

1. Place the cursor in the location you want to insert the table.

2. Click Table > Insert Table.
The Insert Table window opens.

3. Select a table type (CALS only).

4. Select the number of rows and columns in the table.

5. Click OK.
The table is inserted into the selected location.

To add a caption:

Note:  For HTML tables only

1. Place the cursor in the table.
2. Click Table > Insert Caption

Insert a cell, row, or column

Insert a cell

You can add a cell by splitting an existing cell into two rows or columns.

1. Place the cursor in a table.
2. Click Table > Split Cell Into Columns or Split Cell Into Rows

Insert a row

1. Place the cursor in a table.
2. Click Table > Insert Rows or Columns

Note: To add a row to at the bottom of a table, you can also place the cursor in the last cell in a table
and press the Tab key.

Insert a column

1. Place the cursor in a table.
2. Click Table > Insert Rows or Columns
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Edit a cell, row, or column

Move a row or column

1. Place the cursor in a row or column.
2. Click Table > Move Row or Column.

The Move Row or Column dialog opens.

3. Choose an option.
4. Click Apply to apply the action and continue with more actions, or click OK to apply the action and close

the dialog.

Move a cell

You can move cells by cutting (or copying) and pasting them.

1. Select a block of cells.
2. Click Edit > Cut (Copy).
3. Place the cursor in the location you want to paste the cells.
4. Click Edit > Paste.

Tip: You can copy your selection by holding down the Ctrl key while you drag and drop the selected
block of cells to its new location.

Note: You can use the cut (copy) and paste operations to re-position a selected block of table cells.
However, the paste location must have the same configuration as the block of cells you are cutting. If
you are cutting and pasting between tables in different documents, both documents must use the same
DTD or Schema. Content in the target cell block is overwritten with the pasted content.

Merge cells

1. Place the cursor in a cell.
2. Click Table > Merge cell.

The Merge Cell dialog opens.

3. Select a merge option.
4. Click Apply to apply the action and continue with more actions, or click OK to apply the action and close

the dialog.

Contract a cell

If a cell spans two or more rows or columns, you can contract it to the proportions of the adjacent rows or
columns.

1. Place the cursor in the cell that spans two or more rows or columns.
2. On the Table Advanced toolbar, click one of the following options:

• Contract Cell from Left
• Contract Cell from Right
• Contract Cell from Bottom
• Contract Cell from Top

3. The cell is split, and the border is aligned with adjacent borders.
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Delete a cell, row, or column

Delete a cell

You can add a cell by merging it with another existing cell.

1. Place the cursor in a table.
2. Click Table > Merge Cell.

Insert a row

Note: The row is deleted without a prompt.

1. Place the cursor in a table.
2. Click Table > Delete Row.

Note: To add a row to at the bottom of a table, you can also place the cursor in the last cell in a table
and press the Tab key.

-OR-

1. Select the entire row of a table.
2. Press the Shift key and the Right Arrow key.

The row is highlighted blue.

3. Press the Delete key.

Delete multiple rows

1. Select the entire rows that you want to delete.
2. Press the Shift key and the Right Arrow key.

The rows are highlighted blue.

3. Press the Delete key.

Delete a single column

Note: The column is deleted without a prompt.

1. Place the cursor in a table.
2. Click Table > Delete Column

Copy a cell
The contents of a table cell can be quickly copied to other selected cells in the same table.

1. Beginning the cell from which you want to copy content, select all the cells which you want to include the
same content of that initial cell.

2. Select Table > Copy Cells.
The content is copied to all selected cells.

Note:  If any of the other cells contain content, it will be overwritten by the copied content.
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Fill series of table cells
A cell with numerical content can be used to create a numerical series in a table. The content of the anchor
cell that is being used to initiate the series must be a number (e.g., 123) or end in a number (e.g.,
loremipsum123).The series proceeds left to right, top to bottom in the table.The series affects whole numbers
only so, for example, an initial value of 1.9 creates a series with values 1.9, 2.9, 3.9, and so on.

1. Enter the initial value in the anchor cell.

Note: The anchor cell must be the top left cell in the table.

2. Select the cell(s) for which you want to fill the numerical series, starting with the anchor cell.

Note:  If any of the other cells contain text content, it will be overwritten by the series.

3. Select Table > Fill Series.

The series is displayed in selected cells in the table.
Fill cell attributes
Cell attributes can be copied from an anchor cell to other cells in the table in one operation. The anchor cell
is the cell in which you start a multi-cell selection.

1. Select the cell(s) for which you want to fill cell attributes, starting with the anchor cell.
2. Select Table > Fill Cell Attributes.

The Select Table Cell Attributes dialog opens.

3. Select the check boxes for the attributes you want to copy to the other cells, or click Select All to select
all attributes.

4. Select the display order:

• Ascending - alphabetical order
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• Descending - reverse alphabetical order
• Specified Attributes First - Displays the attributes with content first in alphabetical order, and then all

empty attribute sin alphabetical order

5. (optional) After you have made selections, you can click Selected Attributes First to bring all selected
attributes to the top of the list.

6. (optional) Click Select None to remove all selections, or click Invert Selection to select all unselected
attributes, and unselect all currently selected attributes.

7. Click OK to apply all changes.

Split a table
CALS and custom tables can be split into two or more individual tables at the table element level.

1. Place the cursor in the table you want to split.

2. Click Table > Split Table to split above the cursor location or Table > Split Table (Below) to split a table
below the cursor location.
The table is split into two tables immediately above or below the row where the cursor is located. The split
location is identified by dotted lines in both tables.

Related Links
Merge a table on page 119

Tables that have been split from each other can be merged back into one table.

CALS tables on page 114
If your DTD or Schema declares the <tgroup> element, XMetaL Author assumes the CALS table
model. XMetaL supports a definition of the CALS DTD developed by OASIS.

Split a table group
CALS and custom tables can be split into two or more individual table group at the tgroup element level.

1. Place the cursor where you want to split the table (either above or below the cursor).

2. Click Table > Split Table Group to split above the cursor location or Table > Split Table Group (Below)
to split a table below the cursor location.
The table is split into two tables immediately above or below the row where the cursor is located. The split
location is identified by dotted lines in both tables.

Related Links
Merge a table on page 119

Tables that have been split from each other can be merged back into one table.

CALS tables on page 114
If your DTD or Schema declares the <tgroup> element, XMetaL Author assumes the CALS table
model. XMetaL supports a definition of the CALS DTD developed by OASIS.

Merge a table
Tables that have been split from each other can be merged back into one table.

1. Place the cursor in the table you want to merge.
2. Click Table > Merge Table (Below) if the split is below the cursor location, or click Table > Merge Table

if the split is above the cursor location.

Related Links
Sort a table on page 119

You can sort tables, or selected rows in a table. Sorting is available for HTML and CALS tables as
well as custom table models.

Sort a table
You can sort tables, or selected rows in a table. Sorting is available for HTML and CALS tables as well as
custom table models.
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1. (optional) If you only want to sort certain rows, highlight the rows you want sorted in the table.

2. Place the cursor in the table, and then select Table > Sort....
The Sort dialog box opens.

3. (If you selected rows to sort in step 1) In the Scope section, select to sort either Selected Rows or the
Entire Table.

4. Select the @colname check box to view the columns by the @colname tag. Otherwise, the columns will
be identified by number and text content.

5. In the Sort By section, select the sort type from the available options (as below), and then select either
Ascending or Descending and Case Sensitive or Case Insensitive.

Note: Although the attribute colname can be changed in the <entry> element in the table, the name of the
column is not changed and it is the same as specified in the <colspec> element. That name is used when
@colname is checked in 'Sort Table'.

• Text - sorts columns in order, alphabetically and by numerical value
• Number - sorts columns in order by number. Sorting pays only attention to numerical values, and entries

beginning with letters are not sorted and instead appear at the beginning or end of the range depending
on your sorting direction.

• Natural - sorts columns in a natural order, numerically and alphabetically
• Microsoft® Excel Style - sorts columns in the same way that Excel sorts values alphanumerically
• Date - sorts values by date

6. In the Then Sort By sections, select additional criteria.

Example: If you sorted by Number above, and you have identical number values in your table, you can
use a second sort that places the values into a hierarchy of your choosing.

7. Click OK.
The table is sorted.

Enter a tab character in a table cell
You can insert a tab inside of an element in which whitespace is preserved (for example, the HTML <PRE>
element) using a macro.

1. Switch to Plain Text view.

2. Click in a location where text is allowed.

3. Click Tools > Record New Macro.

4. Press Tab.

5. Click Tools > Stop Recording.

6. Complete the macro.

7. Switch back to Normal or Tags On view.

8. Position the cursor inside a table within a <PRE>-like element.

9. Run the macro.

Related Links
Macros on page 51

A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Inserting tables from other applications
You can copy content from other applications, such as spreadsheets and text editors, and paste it into your
document as a table.

Pasted selections are converted into a table if the following conditions are met:

XMetaL Author Help120

Enter a tab character in a table cell



• There are at least two lines in the selection

• Each line consists of items separated by tabs

• Each line has at least two items

• Each line has the same number of items

Formatting table properties
You can set formatting properties in the Table Properties dialog or the Attribute Inspector.You can also set
some formatting properties when you insert a table (HTML tables only).

Follow these stepsTo do this

Place the cursor anywhere inside a table, click Table >
Table Properties, and select the Table tab

Format a table

Place the cursor in a column, click Table > Table
Properties, and select the Column tab

Format a column

Place the cursor in a row, click Table > Table Properties,
and select the Row tab

Format a row

Place the cursor in a cell, click Table > Table Properties,
and select the Cell tab

Format a cell

Select cells within a column or row, click Table > Table
Properties, and select the Selection tab

Format a selection

Note: The availability of properties depends on the table model in your DTD or Schema. Changing some
of the properties may not yield visible changes to the tables.

In HTML tables, you can resize rows and columns from the Table Properties dialog box or by dragging the
row and column boundaries. In CALS tables, only columns can be resized. CALS tables support absolute
and proportional column widths, or a mix of the two. Proportional values are expressed as a number followed
by an asterisk (*).

Tip: You can change the width of a column without affecting the width of other columns in the table by
holding down the Shift key while you drag the right edge of the column to the desired width.
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Working with entities
You can create and manage entities through the Tools menu and insert entity references through the Insert
menu. When you create an entity, an entity declaration is added to your document’s internal subset. Entities
are organized in entity sets.The list of entity sets contains all of the entities defined in the internal subset and
the DTD.

Follow these stepsTo do this

Click Tools > Text Entities, External Entities, or Graphic
Entities. Then complete the required fields and click New.

Create an entity

Select an entity, make the required modifications, and click
Change.

Modify an entity

Select an entity and click Delete.Delete an entity

Click Insert > Entity Reference, select an entity from the
available sets and click Insert.

Insert an entity reference

Double-click the entity iconOpen a document represented by an external entity

Text entities are displayed as icons (for example, ) in Tags On view, and as the entity’s replacement
text (the content) in Normal view.

External entities are displayed as icons in Tags On and Normal views.You can double-click this icon to open
the corresponding file. The contents of the referenced file are parsed just as if they occurred in the current
document. Therefore, you need to ensure that the contents are valid at the location in your document.

Graphic entities are displayed as icons in Tags On and Normal views.

Graphic entities have the following content types:

• Notation.The graphic entity consists of non-SGML characters. (Almost all graphic entities are of this type.)

• Char. Data. The data in the graphic entity is not system-specific.

• Specific Char. Data. The graphic entity contains characters understood only by a local formatting system.

Entity naming conventions

Follow these rules for entity names:

• The first character of the name must be a letter.

• In SGML files, the remaining characters must be letters, digits, or the period (.) or hyphen (-). In XML files,
The underscore (_) and colon (:) are also allowed, but the colon should be avoided unless you are indicating
a namespace.

• In SGML files, names cannot be longer than 128 characters.

• A document cannot declare more than one entity with the same name, even if they are different types. If
the document declares an entity that has already been declared in the DTD, the declaration in the document
takes precedence.

• Entity names are case-sensitive. For example, ‘ProdName’ and ‘Prodname’ are considered to be different
names.
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Create a text entity

Before you begin, switch to Normal or Tags On view.

1. Click Tools > Text Entities.

2. Enter a name in the Name field.

You will use this name to refer to the entity in your document.

3. Enter the text content in the Content field.

4. Click New.
The new text entity is listed in the Text Entities field.

Create an external entity

Before you begin, switch to Normal or Tags On view.

1. Click Tools > External Entities.

2. Enter a name in the Name field.

You will use this name to refer to the entity in your document.

3. Click Choose and select a file.

4. (Optional) Enter a public identifier in the Public Name field.

5. Click New.
The new entity is listed in the File Entities field.

Create a graphic entity

Before you begin, switch to Normal or Tags On view.

Note: This procedure applies to SGML documents only. In order to declare a graphic entity, your DTD
must contain a corresponding NOTATION declaration.

1. Click Tools > Graphic Entities.

2. Enter a name.

You will use this name to refer to the entity in your document.

3. Click Choose and select a file.

4. Specify a content type and graphic format.

Graphic types correspond to NOTATION declarations in the DTD.

5. Click New.

Special characters and symbols
You can use the Special Characters and Symbols toolbars, or the Insert Symbols menu (displayed by using
the keyboard shortcut CTRL + Shift + S), to enter characters and symbols that do not have corresponding
keys on US English keyboards. If your document’s encoding supports it, the characters and symbols themselves
(not the character entities) are saved with your document.

The character/entity conversion table (..\XMetaL <version>\Author\charentmap.xml) is used for
mapping entity references to characters.
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XML files with Unicode encoding

When you open an XML file with Unicode encoding in Tags On and Normal views, the following rules apply,
in the following order:

1. The entity references for the characters ‘<’, ‘>’, and ‘&’ are rendered as characters.

2. Other entity references are rendered as characters if they are included in the character/entity conversion
table, and if your operating system and version of XMetaL Author are capable of displaying the character.

When you save an XML file with Unicode encoding, the following rules apply, in the following order:

1. The characters ‘<’, ‘>’, and ‘&’ are converted to entity references.

2. If the document encoding allows it, other characters are saved as actual characters.

3. If not, and if the character/entity conversion table has a corresponding entity reference, the character is
saved as an entity reference.

4. If none of the above apply, the character is saved as a character reference.

SGML files with Unicode encoding

When you open an SGML file with Unicode encoding, entity references are converted to actual characters if
they included in the character/entity conversion table, and if your operating system and version of XMetaL
Author are capable of displaying the character.

When you save an SGML file with Unicode encoding, the characters are saved according to the following
rules, in the following order:

1. If the character/entity conversion table has an corresponding entity reference, the character is saved as
an entity reference.

2. If not, and if the document encoding allows for it, characters are saved as actual characters.

3. If neither of the above applies, the character is saved as a character reference.

Files with ASCII or ISO-8859-1 encoding

For files with ASCII or ISO-8859-1 encoding, non-ASCII or non-ISO-8859-1 characters are saved as entity
references if they are in the character/entity conversion table, and as character references if they are not.

Related Links
Character encoding on page 65

XMetaL Author supports US-ASCII, ISO-8859-1 (Latin-1), and Unicode™ (UTF-8 or UTF-16) character
encoding. By default, XML files that you create with XMetaL Author use UTF-8 encoding.

Inserting CDATA sections
You can insert CDATA sections using the Insert menu.

Follow these stepsTo do this

Click Insert > CDATA SectionInsert a CDATA section

Tip: You can also wrap selected text in a CDATA section using the procedures above.
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Other marked sections

In SGML documents, you can change the CDATA keyword or add other keywords in Plain Text view. When
you use keywords concurrently, the following order of precedence applies:

1. IGNORE

2. CDATA

3. RCDATA

4. INCLUDE

TEMP is not overridden by any other keyword.

INCLUDE is the default for all marked sections.

Inserting comments
You can insert comments using the Insert menu. Comments can be viewed in Tags On view if the Show
comments option is active.

Follow these stepsTo do this

Click Insert > CommentInsert a comment

Tip: You can also change selected text to a comment using the procedures above.

Related Links
Options on page 55

You can set options through the Tools menu.
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Inserting processing instructions
You can insert processing instructions using the Insert menu. Processing instructions are commonly used
to store prompt text.

Follow these stepsTo do this

Click Insert > Processing InstructionInsert a processing instruction
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Importing databases

You can import the contents of a database or spreadsheet file into your structured document as a table.When
you import a database, you create an SQL query that allows you to import only the data you need and in the
format you want. When you import data, you apply elements and attributes that are used in your DTD or
Schema.

Most customizations include a menu command or a toolbar button you can use to open the Import Database
dialog box. For example, the Journalist customization includes the following macros:

• Import Table

• Update Table

When you run the Import Table macro, the Import Database dialog box opens.This is the interface for selecting
your data, creating your query, and formatting output.

After you import data into your XMetaL Author document, you can update it (reload the data from the source
database) using the Update Table macro.

Related Links
Macros on page 51

A macro is a sequence of operations that can be run as a unit. Macros can be associated with a
shortcut key, toolbar button, or menu item. They are useful when you need to repeatedly execute a
task that does not have a built-in shortcut key or command.

Choosing a database
The source database can be a file, a folder, or a DSN (Data Source Name).You can choose a database from
the Select Database dialog box.
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Follow these stepsTo do this

In the Import Database dialog, click Select. Select the
Driver option and choose a driver. If you select a Microsoft

Select a database file or folder

Access or Microsoft Excel driver, choose the File option. If
you select any other driver, select the Folder option. Then
click the browse button and select the database file or folder.

Select the DSN option, and then choose a DSN.Select a DSN

Creating a query
Once you have selected a database or DSN, you need to select fields to import.You do this by creating a
query.You can specify a display name, sort order, and filters through the Field Properties dialog box.You
can also perform table joins.

Follow these stepsTo do this

In the Import Database dialog box, click the Query Builder
tab and select a table.Then select fields from the Available
Fields list and click Add.

Choose fields to import

In the Selected Fields list, choose a field and click Edit.Set field properties

You can specify the following field properties:

• Display name - The name for the field as you want it to appear in your table.

• Show - Choose an option to show or hide the field in the table.

Note:  Hiding a field is not the same as removing it. A hidden field can still be used in a filter condition.

• Sort order - Choose Ascending or Descending.
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Note:  Lowercase letters are considered to be lower in order than uppercase letters.

• Filter condition - If you selected any option other than None, specify value(s) to match.

Note: Text strings must be enclosed within single quotes.

Table joins
You can retrieve data from two or more tables using a table join. The two tables must have at least one field
in common.

For example, two tables of employee information (a payroll table and an employee information table) could
both have an employee ID field. (The field names do not have to be identical, but the type of data must be
the same.) You can create a new output record that joins records in the two tables by matching up values in
the shared field. For example, you could create records consisting of a salary value from the payroll table
and a name from the employee information table. The salary is paired with the correct name because their
employee ID values match.

Note:  A field does not have to be in the Selected Fields list in order to be used in a join. An unselected
field can be the field that is matched to the corresponding field in the second table, but that does not
appear in the final table.
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Creating a joined table query

To create a joined table query:

1. In the Import Database dialog box, click the Query Builder tab.

2. From the Table list box, select a table from the current database.

This is the primary table (the table to which you want to join a second table).

3. Click Table Joins.

4. From the Select Join Field list, choose the field that to use to join the data from the two tables.

This field must contain data common to both tables.

5. Choose the equivalent field from the Join Onto list.

6. Click Add.

Formatting table output
Once you have defined your query, you need to determine the formatting for your table data in XMetaL Author.
You apply elements and attributes that are used in your DTD or Schema.You can specify formatting through
the Output Format tab in the Import Database dialog.

Options

Choose from the following options:

• The table model supported by your DTD.

• An orientation. Choose Vertical if you want the fields to be imported as columns (as in the original database)
or Horizontal if you want the fields to be imported as rows.

• Headers. Choose Show to include the table header (the first row) in the output, or Hide to suppress it.

Output names

You can edit the element names in the Name to Use column. These are the element names that are used
when the data is written in your document.

Note: The elements must be declared in your DTD.

You can also specify a case for the element you are editing.
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XML templates support

XMetaL offers advanced capabilities for creating and inserting templates that contain reusable XML content.
This reusable content may include text, elements, images, tables, lists, references, and other common
structures. Users can efficiently locate, preview, and insert predefined XML content fragments into a document
with just a few keystrokes or mouse clicks.

XML template support is available for DITA and any other customization such as Journalist, DocBook, and
S1000D.

Opening Insert Template dialog

Open the Insert Template dialog by using the XMetaL quick navigation tool to run the "Insert XML Template"
macro or by pressing Ctrl+,.

The dialog displays the templates associated with the active document.

Toolbar buttons in Insert Template dialog

Basic UI setting:
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Toolbar button in Basic UI setting:

Description# on image

Search for the title of the reusable template.1

The current filter is set to "Word contains" or "Word starts with".2

Create a new template from the fragment.3

Delete the template.4

Edit the template.5

Enable or disable preview in the active document.6

Paste content.7

Display the list of available content groups.8

Refresh the content.9

Display the template content.10

Configure reusable content settings.11

Full UI setting:

Toolbar buttons in Full UI setting:

Description# on image

Paste the selected title of reusable content into the active document.1

Enable or disable preview in the active document.2

Paste the selected reusable content into the active document.3
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Description# on image

Search for the reusable template in the Title area.4

Copy the selected text from the active document into the Title filter.5

Search for the reusable template in the Content area.6

Create a new template from a fragment.7

Delete the template.8

Edit the template.9

Copy the selected text from the active document into the Content filter.10

Find reusable content using the text in the Content filter box.11

Display the list of available content groups.12

Find the next item.13

Find the previous item.14

Refresh the content.15

Hide the template content.16

Configure reusable content settings.17

Note:

• Since the title content is used as the file name for the template file, certain characters such as @, :, and /,
which are not permitted in file names, will be removed.

Creating new template

To create a new template from a fragment, click toolbar button #[3] in the Insert Template dialog with Basic
UI or #[7] in the Full UI dialog.

The Create XML Template dialog, or Create DITA Template dialog for DITA, is then displayed:

Enter the following information:
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• Component range - Select the current element, Selected Text, or <ph> element.

• Description - Type a description for the XML template.

• Save reusable template in: - Specify the directory in which the reusable template should be stored:

• Project Specific Template folder

• Default Templates folder or Default DITA Templates folder for DITA

• Configuration - It opens template folders configuration

• Open saved file - When selected, the saved reusable template file will automatically open in XMetaL.

Note: To save a reusable template in a non-default Project Specific Template Folder, users must first
create a new template configuration file through the Reusable Content Settings dialog by following these
steps:

• In the Reusable Content Settings dialog, click View File Content for the active template configuration.
• In the Active Template Configuration dialog, click Add New Configuration or Duplicate Configuration.
• Enter a configuration title and specify the path to the project-specific template folder.
• Save the new configuration.
• Save the reusable content settings.

When the Project Specific Template Folder option is selected in the Create Template dialog, clicking the
Select Template Folder button displays the list of available non-default template folder paths. Users may
select the desirable non-default template folder.

Content groups

After creating new templates from the fragment, click toolbar button #[8] in the Insert Template dialog with
Basic UI or #[12] in the Full UI dialog to display the list of available content groups:

New Template Configuration

If the template configuration folder corresponding to the active document rules does not exist at
C:\ProgramData\SoftQuad\XMetaL\WhiteBoard\reusablecontent, clicking the Create New Template from
Fragment toolbar button (#[3] in the XML Template dialog with Basic UI or #[7] in the Full UI dialog) opens
the New Template Configuration dialog:
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There are two options for configuring a new template:

• Add a new configuration root folder to C:\Users\<USER
NAME>\Documents\SoftQuad\XMetaL\ReusableContent.

• Join an existing configuration by selecting the appropriate root folder name.

There are two buttons available:

• Edit the configuration by opening the RuleToElementConfig.txt, which defines the mapping between
document rules and the configuration folder.

• Show the location of RuleToElementConfig.txt on the Desktop tab in Resource Manager.

Insert Template Settings

Opening Insert Template settings dialog

To open the Insert Template Settings dialog, click the Reusable Content Settings button in the Insert
Template dialog.
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The Insert Template settings dialog includes the following areas:

• On Activate: Configure settings applied when the Insert Template dialog is activated.
• Insert content: Configure settings applied when reusable content is inserted.
• Resolve default: Define which reference attributes and ID attributes are resolved.
• Find options: Set options for locating reusable content in the Insert Template dialog list.
• Active Template configuration: View and edit the reusable configuration file, access the document rules

file and default template settings file, and create a configuration map.
• Selected template: Display information about the selected template, including title, content group, template

file location, and template settings file location.

Toolbar buttons in Insert Template settings:
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Description# on image

Open the Select attribute dialog to choose an attribute of the selected element in the active document:1

The selected attribute is added to the Reference attributes box.

Open the Active template configuration dialog to view or edit the reusable text file content (.rtc):2

Users can modify the content using the buttons at the bottom of the dialog.
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Description# on image

Additional features include:

• Display available configurations.

• Add a new configuration.

• Duplicate an existing configuration.

• Delete a template.

• Save the modified content.

• Show the configuration file location.

• Search for text within the editor using buttons to navigate to the next or previous match.

Open the Template resources dialog to create a template configuration map:3

Once created, the map opens in Resource Manager.

View the file content of the document rules to configuration folder map (RulesToElementConfig.txt).4

View the file content of the active template settings (templdef.rtx).5

Show the file location of the active template settings on the Desktop tab in Resource Manager.6

Open the selected template file (.xml).7

Show the selected template file location on the Desktop tab in Resource Manager.8

Open the selected template settings file (.rtx).9

Show the file location of the selected template settings on the Desktop tab in Resource Manager.10

How to modify or delete the existing configuration root folder

• To manually modify the configuration, open RuleToElementConfig.txt by selecting View file content button
#[4] for RuleToElementConfig.txt within the Insert Template Settings dialog. This file is located at
C:\Users\<USER NAME>\Documents\SoftQuad\XMetaL\ReusableContent. Edit or remove the #FOLDER
entry that defines the root folder name, including any associated public and/or system identifiers.
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• For a more structured approach, it is recommended to first remove the appropriate whole #FOLDER entries
or entries for specific folders from the configuration file, then run the Insert XML template macro using
[Ctrl + ,]. This action opens the New Template Configuration dialog, allowing users to either create a new
configuration root folder or join an existing one. This method ensures that all necessary subfolders and
default settings are properly generated.
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MathML support

MathML (Mathematical Markup Language) is an XML-based markup language used for Microsoft Copilot
mathematical notation and its content. It's an open standard developed by the W3C (World Wide Web
Consortium) to natively integrate mathematical formulas into web pages and other documents. XMetaL
provides enhanced support for creating and editing MathML elements.

XMetaL supports MathML editing through either the MathLive editor or the MathType editor. Users can activate
the preferred MathML editor by running the “Activate MathLive MathML Editor” or “Activate MathType MathML
Editor” macro through XMetaL quick navigation tool (Ctrl+/).

When MathLive editor or MathType editor is activated, inserting a MathML container element, such as

<mml:math> or <mathml>

automatically opens the MathLive editor or MathType editor.

The mathematical formulas entered in the MathML editor is inserted into the MathML container element by
clicking the Insert button.

In the MathML editor, a variety of mathematical formula templates is available through the toolbar buttons
and the menu.
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You can modify formulas in the document by double-clicking the MathML container element, which opens
the MathLive or MathType editor.

After insertion, mathematical formulas are displayed as inline graphics directly within XML documents.

You can toggle between the XML tag view and a graphical view. Selecting the “Show source” button in the
upper-right corner of an inserted MathML image switches the view to the source. To return to the graphical
MathML view, collapse and then expand the “equation” element.The graphical view provides options to zoom
in or out using [Ctrl +] and [Ctrl –], and to reset the element size to its default using [Ctrl + 0].

Note: To use the MathType editor, the following are required:

• Internet access
• Python installed
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Quick navigation tool

XMetaL exposes over 700 commands that you can run when you have documents and maps open. Most of
these commands are exposed via menus, toolbars, macros, scripts, keyboard shortcuts, but finding the
commands can be difficult as it requires switching between keyboard and mouse, memorizing commands,
toolbar images, macro names, etc.

Finding and executing XMetaL commands

Tapping the  icon in the Whiteboard toolbar, or by entering the CTRL + ? on the keyboard, opens the
dialog where you can find and execute all available XMetaL commands.

The following features will help users quickly navigate in XMetaL:

• A hot key for showing popup menu with commands titles and context sensitive search option.

• If commands are organized in groups - allowing filtering commands by groups (Active Document macros
group, Insert group, help group etc.)

• Showing commands descriptions when it is defined

• Search filtering options "word contains", "word start with", search in "titles and keywords" or "titles, keywords
and descriptions"

• Customer defined group of commands. Any command can be in one click added/deleted to/from "My group
of commands"

• Optional settings for sorting results

• Easy navigation between command groups and dialog controls (Up/Down/Enter keys and short cuts) -
mouse is not required, easy run in full screen editor mode

• You can extend menu and groups content by dropping actions definition text files to predefined folder.
Customer extensions define "title" - "descriptions" - "text or hex symbol - of paste content" - "showing in
menu priority" - "keywords for fast search". For example inserting mathml symbols, unicode symbols or
frequently used phrases.

• The Whiteboard toolbar provides easy access to your favorite and recently used documents, all XMetaL
commands, and application utilities.

The following commands, macros, documents and applications can be found:

• XMetaL main menu commands

• XMetaL default or customer commands surfaced via customization scripts

• Application level macros

• Active Document customization macros

• Toolbars commands

• XMetaL document templates

• Active DITA MAP menu and toolbars command

• Favorite and predefined XMetaL folders.You can mark a folder as a "favorite" in the XMetaL environment.
Folder and subfolder content will be shown in a special file openEx dialog or selected on the XMetaL desktop
explorer

• Favorite and predefined XMetaL applications.
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Favorite actions can include calls to third-party applications where the parameter can contain a path, word
under cursor, or selected text in an active document. XMetaL includes examples, some of which show how
to, for example, find selected text on the web or pass text to free web translation services.

XMetaL contains command-line examples of opening an active document, map or referenced files in Notepad++
and Paint, searching a word or selected text in Google or Wiki as well as translating document content to
different languages via free online services.

The following image and table explains the main components of the quick navigation dialog, as well as
shortcuts and key that will help you with quick navigation.
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DescriptionShortcut or key# on
image

Name of subgroup command (if available)1

Name of active group of commands2

Number of available filtered commands in the group3

Search edit boxCtrl+F (or Ctrl+Up
when in
commands list)

4

When focus is on the search box, set the focus to the selected command in the list. If
Ctrl, select first item in the list

Down or
Ctrl+Down

5

Switch search type; either "word contains" or "word starts with"Ctrl+Space6

Switch between "All commands" and "Selected command" groupsCtrl+> or Ctrl+<7

Add/delete command to/from "My group commands"Ctrl+Insert8

Show/hide command description. The description starts with a group titles chain.Ctrl+I9

Activate the user preferences dialogCtrl+P10

Activate popup menu with the list of command groupsCtrl+G11

Switch search type "in titles and keywords" or "in titles, keywords and command
descriptions"

Ctrl+D12

Show/Hide search box textCtrl+U

Run selected commandEnter

If selected command is "Favorite Folder" or "Favorite Library", then activate XMetaL
explorer folder and select this folder

Shift+Enter

Selected parent group of the active groupCtrl+Shift+<

If My group of commands is selected, then remove it from the groupDelete

If My group of commands is selected, move the selected command up or down
• Shift+Up

• Shift+Down

Close menuEsc

Resize dialog
• Ctrl++

• Ctrl+-

• Ctrl+Shift++

• Ctrl+Shift+-

Move dialog
• Alt+Space

Tips

• If you don't remember a command name but you do remember other commands in the group or group
name, start to type it. When you see it in the list, use the Down key to select it and click Ctrl+> to see all
commands in the group.

• If you frequently use some of the commands, go to Preferences and add a short keyword for command (for
example, the abbreviation 'qln' for "Quick Insert references") and use it to search.
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• If you frequently use some of the commands, go to Preferences and change the command priority (default
is "6"), "1" is highest and the command will appear either close to the top or bottom of the list depending
on the set value.

• if you search for your favorite folder, type the "[" character in the search box (all folders contain them).
• if you search for XMetaL predefined folders, enter the "#" character (all folders contain them).

Click thisTo do this

Add selected item to 'My Group'

Hide and show details

Open command settings

Show commands related to the selected item in the

command list

Show all available commands

Select to show only a group of commands

In the search, the entered word is contained in the name

of the action

In the search, the entered word is at the beginning of the

name of the action

Apply the search only to the title name of the action

Apply the search to both the title and the details of the action

Viewing and customizing favorites

Viewing and adding favorites

Tapping the  icon in the Whiteboard toolbar or using the Ctrl+Shift+? hot key opens a dialog where you
can access favorite actions. In this dialog, you can apply your favorite and recently used actions in XMetaL.
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In the 'favorites' dialog, all actions are easy to find and run using hot-keys via context sensitive search and
filtering groups. All controls have tooltips containing the associated hot-keys.

Click thisTo do this

Hide or show the command line or full path

Hide or show the search field

Pin or unpin the dialog to stay open after performing the action

In the search, the entered word is contained in the name of the action

In the search, the entered word is at the beginning of the name of the action

Apply the search only to the title name of the action

Apply the search to both the title and the details of the action
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You can add favorite actions by clicking the  icon in the Whiteboard toolbar and then selecting one of the
options in the Add to favorites dialog.

Customizing favorite applications

You can select a Windows application that can be run from the command line, assign title to it, and specify
command-line parameters. The title will appear in the list of commands in "Run application" group. The
command line will appear in the command details. Based on the active map or document and document
selection, there is a list of predefined command-line keywords that XMetaL resolves in the command line.

• Word currently under the cursor

• Selected text

• The text content of a tag currently under the cursor

• Specific attribute value of an element under the cursor

• Active document path

• Active map path

Favorite applications can be customized in the Customize Favorites dialog.
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Here are some tips and guidelines for customizing favorites:

• In the Title edit box, when you change existing title, you must press Enter to complete/update application
settings

• In the Application edit box, the command line works the same as for the title. Be careful with application
path as it will executed as is. So if you have a space in the path, use double quotes around it.

• You can use the  (Duplicate) button as an easy way to duplicate a selected application that is close
to what you want and change the parameters or application.

XMetaL resolves the following parameters:

• %sel_tag_encode% - active document - tag content where cursor – escaped for use in browsers

• %sel_word_encode% - active document – word under cursor – escaped for use in browsers

• %WEB_TAB% - use IE application on XMetaL desktop resource manager

• "%REFATTR_ %" active document attribute(s) of element where cursor is – example
"%REFATTR_FileRef;href;fileref%"

• %REFATTR_NOID_ %" - the same - except id part starting with (“#...”) is removed when it presents,
%REFATTR_NOID_href;URL;Linkend;conref;FileRef;fileref;src;xlink:href%"

• %DOC% - full path to active document
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• %MAP% - full path to active map

Four customizable quick access buttons in the Whiteboard toolbar ( , ,  and ) can be assigned
any favorite action as needed. The buttons' tooltips display the title of the assigned action. The predefined
hot-keys for the buttons are Ctrl+1, Ctrl+2, Ctrl+3 and Ctrl+4.

For more customizing the buttons:

• Select the item you want to relate to one of the buttons. The selected function is displayed in the Title field.
• Click the button to which you want to relate the function. The function is now set for the selected button.
• Click Run Application to test the function in the Title field.

Application utilities

Tapping the  icon in the Whiteboard toolbar opens a dialog where you can run XMetaL macros.

Click thisTo do this

Hide or show the command line or macro description

Hide or show the search field

Pin or unpin the dialog to stay open after performing the

action

In the search, the entered word is contained in the name

of the action

In the search, the entered word is at the beginning of the

name of the action

Apply the search only to the title name of the action

Apply the search to both the title and the details of the action
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Document Ex commands

The following document Ex features can be accessed by tapping the button in the Whiteboard toolbar.

Find document Ex feature

The Find feature allows you to:

• view a file’s name and a document’s titles in favorite, predefined and recently used folders as well as
Windows libraries,

• find and open documents in favorite, predefined and recently used folders as well as Windows libraries by
title, file name or content of specific XML document elements, and

• add and remove favorite folders.
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Recently Used documents Ex feature

It is invoked by Ctrl+' or selecting "#All favorites and recently used files" in "Open Document dialog.

The list of favorite and recently used documents allows you to:

• view documents titles of recently used and favorite documents,
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• find and open documents by title, file name or content of specific XML document elements, and

• add and remove favorite documents.

Opened documents Ex feature

It is invoked by Ctrl+D.

This feature allows you to:

• view documents titles of all opened documents,

• open document to select, close, open in alterative applications, find documents by title, file name or content
of specific XML document elements, and

• add and remove selected documents to/from favorite document list.
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Bookmarks and comments

This tool allows users to store active document selected text as a bookmark, add or modify bookmark's
comments, find bookmarks by titles or comments, and open the document and move selection to the
corresponding bookmark.

Bookmarks and comments feature includes:

• Allows marking active document text as a bookmark without changing document content

• Allows adding/modifying bookmark comments without changing document content

• Contains four predefined groups of bookmarks

• Bookmark can be assigned (or reassigned) to any group.

• Every group of bookmarks has a designated highlighting color.

• Every group of bookmarks can be shown or hidden.

• Bookmarks can be sorted or ordered manually.

• Allows finding bookmarks by bookmark or comments text, opening the document, and scrolling to the
selected bookmark

• Context popup menu and bookmark macros with connection to "Find and Execute XMetaL Command"
allow fast access and efficient bookmarks and comments management.

• Allows fast navigation between bookmarks

• Allows showing only bookmarks of specific document

• Contains three types of user interfaces for flexible and efficient work with document bookmarks and
comments:

• Bookmarks manager - basic

• Comments basic

• Bookmarks manager - advanced

Adding bookmarks and comments

Bookmarks can be added via calling the XMetaL macro silently or through the user interface.

For the silent scenario, you select text in the active document and use the XMetaL quick navigation tool for
calling the "Bookmark: add" macro:

1. Press Ctrl+?
2. Start to type "bookmark"
3. Select "Bookmark: add" macro
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4. Press "Enter"

For the user interface scenario, use the XMetaL quick navigation tool for calling the "Bookmark: manager"
macro:

1. Press Ctrl+?
2. Start to type "bookmark "
3. Select "Bookmark: manager" macro
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4. Press "Enter" to open the Bookmarks manager dlg

The easiest way to add bookmark is through the "Add Bookmark" context menu.

Bookmark manager

Basic UI

The basic UI of bookmark manager allows users to do basic actions for adding, finding and maintaining
bookmarks, opening document corresponding to bookmark, and selecting bookmark locations.

After activating the bookmark manager dialog, clicking on "New" group of bookmarks adds a bookmark to
the list of bookmarks and highlights it in the document with corresponding color .
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Note: All bookmark manager buttons have tool tips when the dialog is activated.

Description# on
image

Assign bookmark to group of bookmarks "1". Cyan is the highlighting color of the group.1

Assign bookmark to group of bookmarks "2".Yellow is the highlighting color of the group.2

Assign bookmark to group of bookmarks "3". Green is the highlighting color of the group.3

Assign bookmark to group of bookmarks "4". Red is the highlighting color of the group.4

Highlight all bookmarks in active document.5

Hide all bookmarks in active document.6

Show filtering edit box. It allows to show in bookmarks list only items that contain (or start with) specific
text in title or assigned comments.

7

Sort/Unsort bookmarks list. The order in unsorted bookmarks list can be changed via using keyboard keys
Shift+Up Arrow and Shift+Down Arrow.

8

Refresh list of bookmarks.9

Switch Bookmark manager with advanced UI.10

In the bookmarks list, you can do the following:
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• For navigation to a bookmark location in the document , double click on a bookmark item in the list.
• Press the Delete key for deleting a single bookmark and press Ctrl+Delete key for deleting all bookmarks.
• For fast navigation between bookmark locations, use keyboard in combination Ctrl key and Up Arrow and

Down Arrow in bookmarks list.

At the bottom of the bookmark manager dialog, the following features are available:

Description# on
image

Select type of the selected bookmark information; full path of the document or XPath of bookmark location
in the document.

1

Bookmark info2

Show list of files containing bookmarks and select first bookmark associated with file.3

Allows showing only bookmarks located in "Bookmark info" file.4

Force to close bookmark manager after navigation to bookmark location.5

Allows synchronizing active document bookmark under cursor with the list of bookmarks.6

Advanced UI

In addition to basic UI, the advanced UI of bookmark manager allows users to:

• add/delete/modify comments to bookmark

• add user name and time of comment modification

• reassign bookmark to other group

• change bookmark location in document

• show/hide only specific group of bookmarks in the list

• highlight /un-highlight specific group of bookmarks in the document
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image

Comments window. Use combination of Ctrl key and "+" "-" full keyboard keys for vertical resizing of
comments window.

1

Insert date and user name.2

Reassign selected to group of bookmarks "1". Cyan is the highlighting color of the group.3

Reassign selected to group of bookmarks "2".Yellow is the highlighting color of the group.4

Reassign selected to group of bookmarks "3". Green is the highlighting color of the group.5

Reassign selected to group of bookmarks "4". Red is the highlighting color of the group.6

Reassign Active document selected text location to selected bookmark.7

Save bookmark comments.8
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Description# on
image

Combobox of bookmarks groups. List of bookmarks shows only bookmarks in the selected group.9

Highlight bookmarks selected in "Combobox of bookmarks groups".10

Hide bookmarks selected in "Combobox of bookmarks groups".11

Comments UI

Comments basic UI

The Comments basic UI allows users to:

• add/edit/view comments for existing bookmarks

• perform all actions of "Bookmarks Advanced UI" for selected bookmark

• allow/disallow activating a dialog after adding bookmark in silent mode

• control dialog positioning on the screen after activation

How to activate the Comments basic UI

The Comments basic UI can be activated via the XMetaL quick navigation tool by calling the "Bookmark:
comments" macro:

1. Move a cursor to the bookmark location in active document
2. Press Ctrl+?
3. Start to type "bookmark"
4. Select "Bookmark: comments" macro
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5. Press "Enter" to open the Comments basic UI dialog

The other way to activate the Comments basic UI dialog is using the context popup menu:

1. Move a cursor to the bookmark location in an active document
2. Activate the context menu and select "Edit bookmark comments" (if comments are exist already) or "Add

bookmark comments"

The Comments basic UI dialog is:
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Toolbar buttons and options in the Comments basic UI dialog

The Comments basic UI allows you to perform all actions of "Bookmark manager - advanced UI" limited to
only one bookmark as follows.

Description# on
image

Insert date and user name.1

Reassign selected to group of bookmarks "1". Cyan is the highlighting color of the group.2

Reassign selected to group of bookmarks "2".Yellow is the highlighting color of the group.3

Reassign selected to group of bookmarks "3". Green is the highlighting color of the group.4

Reassign selected to group of bookmarks "4". Red is the highlighting color of the group.5

Reassign Active document selected text location to selected bookmark.6

Synchronize active document bookmark under cursor with the Comments dialog if a cursor was moved to
another bookmark.

7

Delete bookmark.8

Save bookmark comments.9

Always show the Comments basic UI dialog after adding bookmark in silent mode.10

Show the Comments basic UI dialog at bookmark location in active document.11
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Context Menu for Bookmark
The Bookmark context menu provides easy access to features like creating new bookmarks, opening the
comments dialog, managing bookmarks, and deleting bookmarks.

Bookmark Context Menu

When the text with a bookmark is selected:

The following bookmark-related options are available:

1. "Bookmark: comments" opens the comments dialog.
2. "Bookmark: manager" opens the Bookmark manager tab within the Resource Manager.
3. "Bookmark: delete" removes the selected bookmark.

When the text without a bookmark is selected:

The following bookmark context menu allows you to add a new bookmark to one of four color groups (1-4).
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Hide all highlights:

To hide all highlights in the active document generated by bookmarks, select any highlight and then use the
specific context menu item provided for hiding all highlights.
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Note:  Selecting this context menu item hides highlights from Bookmark as well as from XChatbot,
XGrammarly, and the Web. To make hidden bookmarks visible, open the Bookmark manager and click
the "Show all Active Document bookmarks" button.
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XMetaL utilities

XMetaL offers customers valuable features, including "Find text on WEB", "Integration with ChatGPT", and
"Integration with Grammarly". The "Find text on WEB" utility assists authors in efficiently searching relevant
information.The "Integration with ChatGPT" and "Integration with Grammarly" utilities help authors to enhance
the quality of documentation, resulting in a significantly improved authoring experience within the XMetaL
platform.

Find text on WEB

This feature enables authors to search the internet within the XMetaL environment quickly. Instead of switching
to a separate browser, authors can perform research, verify facts, and access up-to-date information within
the XMetaL platform. This saves time and ensures the accuracy of the content being created.

Integration with ChatGPT, Bing AI and Google Gemini

XMetaL has integrated with ChatGPT, Bing AI and Google Gemini web services into the XMetaL environment
to offer enhanced writing assistance. Authors now have the capability to utilize advanced AI-powered
suggestions, context-aware prompts, and real-time feedback to enhance and improve their content. This
utility makes it easier for authors to articulate complex ideas, improve sentence structures, and enhance the
overall clarity of their writing.

Integration with Grammarly

With this integration, XMetaL users can leverage the comprehensive grammar and spelling-checking capabilities
of Grammarly within the XMetaL environment. This ensures that the content is free from errors, adheres to
language conventions, and maintains a high level of professionalism. Grammarly also offers suggestions to
improve writing style and readability, leading to polished and refined documentation.

Find text on WEB

Tapping the  icon in the Whiteboard toolbar, or entering the CTRL + ? to locate the "Find selected text on
WEB" macro, opens the WEB Browser tab in the Resource Manager.

This utility demonstrates XMetaL script customization based on integration with Microsoft Edge.The following
features help users to find the selected text and more:

• Allows finding Active document selected text on the WEB or passing selected text as a URI parameter to
online WEB services

• Allows maintaining home page, search engines and favorite sites

• Allows defining xml template and pasting it to an XMetaL active document. Parameters of the xml template
are web page title, web page URI, clipboard content, and active document selection

• Allows running XMetaL macro scripts. Macro script has full access to XMEdge ActiveX control interfaces,
web page scripts, and the XMetaL script environment

• Contains examples of Google, Bing and WIKI search engines, Google online translate service, paste
templates, and test macro
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Opening WEB Browser Page in Resource Manager

There are multiple methods to utilize the utility. To begin, you can select text within the active document and

click the "Find selected text on WEB" button  in the whiteboard toolbar, as shown below.

Another convenient option is to open the web browser page through the Web context menu.

Additionally, users can employ the XMetaL quick navigation tool to activate the "Find selected text on WEB"
macro:

1. Select text in active document
2. Ctrl+?
3. Start typing "find"
4. Select macro and press "Enter"
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Find text on WEB utility toolbar
The utility's toolbar buttons similar to generic web browser buttons are displayed on the WEB Browser tab in
the Resource Manager.

The following utility's toolbar buttons let you do multiple actions:

DescriptionShortcut or key# on
image

Home PageCtrl+H1

PreviousCtrl+<2

NextCtrl+>3

ReloadCtrl+R4

Show FavoritesCtrl+G5

Add to FavoritesCtrl+Insert6

Navigation URI or "Find text" edit box7

Find text or open URI located in "Navigation URI or "Find text" edit box"8

Find Active Document selected text on WEB9

Browse for file in file system10
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DescriptionShortcut or key# on
image

Insert link to Active Document11

Settings12

Close Tab13

Note:

• All buttons show tool tips when the toolbar is activated.

• For maintaining the "Favorites" list , you can use:

• "Del" key for deleting
• "Shift+Up Arrow" and "Shift+Down Arrow" keys for changing order

• When clicking on the "Insert link to ActiveDocument" button based on utility settings, one or another action
happens:

• The current web page URI and title are sent as parameters for "xml template".The generated xml content
is pasted in Active Document.

• The XMetaL runs macro specified in utility settings. The macro script has access to all current web page
data via the XMEdge ActiveX control API.

Settings in WEB Browser

Settings

The Settings dialog allows you to:

• add/remove/select link for the "Home Page" button

• add/remove/select link to the WEB page that provides access to WEB search engine and online WEB
service. Selected WEB page link is assigned to "Find text or open URI" and "Find Active Document selected
text on WEB" buttons.

• assign action to "Insert link to Active Document" button. Available actions are "Paste template" and "Run
Macro" .

• add/remove/select xml template for the "Paste template" action

XMetaL Author Help170

Settings in WEB Browser



Other features in Settings dialog include:

• The "Uri" edit box contains an editable web link to a current web page.

• By using "Add current web page Uri" buttons, you can add new entries to the lists of "Home Pages" and
"Search engines" as follows:
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• "Find text on WEB..." operations append Active Document selected text or "Navigation URI or Find text"
edit box content to selected link.

• Optional parameter %sel_word_encode% forces text to be encoded before appending to web link. It is
useful when document selected text should be sent to web services, for example for translation.

• You can use the "Paste Link" edit box for defining a template for the "Insert link to Active Document" button
or click on "Build template assistant" button.

Available template parameters:

• %SEL% - Active Document selected text

• %SEL_WORD% - Active Document selected text words

• %TITLE% - web page title

• %URI% - web page URI

• %GEN_ID% - generate unique id

• %CLIPBOARD% - clipboard text content

Templates examples:

• Journalist ULink document selection as link text: <ULink URL="%URI%">%SEL_WORD%</ULink>

• Journalist ULink web page title or selction as link text: <ULink URL="%URI%">%TITLE%</ULink>

• Docbook URI document selection as link text: <uri xlink:href="%URI%">%SEL_WORD%</uri>

• Docbook URI web page title or selection as link text: <uri xlink:href="%URI%">%TITLE%</uri>

• (Selected text or HTML page title : URI) : (%TITLE%: %URI%)

Note:  Selected text from the active webpage can be formatted using the template and then copied
into active documents.

Build template assistant

Clicking on the "Build template assistant" button in the Settings dialog opens the "Build template assistant"
dialog.
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This will allow you to build the template easily:

• You can use the "Import Active Document selected content" button to import the Active Document selected
xml content as a starting point.

• You can insert/replace text in the template with template parameters by typing or clicking on parameter
button.

Context Menu for Web Operations
The Web context menu offers convenient access to multiple options, facilitating the search for selected text
in the active document on the web and the insertion of links into the active document.

Web Context Menu

When WEB-Browser tab is open and active in Resource Manager:

Multiple web-related options can be accessed by following the steps.

The search engine option:

1. Select the text where you want to find the information on the web.
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2. Right-click to open the context menu for search engine and choose the desired option.

The option for inserting a link into the document:

1. Locate the specific location within the active document where you intend to insert a link.
2. Right-click to access the context menu for inserting a link into the active document and choose the desired

option.

When WEB-Browser tab is not open or not active in Resource Manager:

The web-related context menu is accessible for locating the selected text in the document.
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Hide all highlights:

To hide all highlights in the active document generated by Web operation, select any highlight and then use
the specific context menu item provided for hiding all highlights.

175© 2025 JustSystems Canada, Inc.

Context Menu for Web Operations



Note:  Choosing this context menu item hides all highlights not only following a web search but also after
operations involving XChatbot, XGrammarly, and Bookmark. To make hidden bookmarks visible, open
the Bookmark manager and click the "Show all Active Document bookmarks" button.

Integration with ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and
Grok

XMetaL 20.0 introduces a native access option that allows customers to directly access AI websites like
ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok within the XMetaL Resource Manager
tab. This enables seamless integration of document editing with the ability to access these AI websites.

The following features enable users to access the AI website through XMetaL:

• Enhancing accessibility and efficiency by facilitating seamless switching and utilizing tools within XMetaL
editor and AI input window.

• Establishing a mechanism for transferring document content and responses between XMetaL and AI.
• Converting XML markup in the editor to a compatible format that can be accepted as input by AI.
• Converting AI responses to a format that XMetaL can process as input.
• Providing customers with a dedicated tool to access AI responses, enabling them to extend, automate, and

customize XMetaL according to their specific tasks.
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• Introducing a mechanism for supporting and accessing AI request instruction templates, where template
parameters can be selected from the active document, specific markup content, or the entire document.

Key requirements for using ChatGPT

• Internet connection.

ChatGPT is a cloud-based language model powered by AI. A stable internet connection to access the
service is required.

You may need to add the https://chat.openai.com domain to the "Allow list" on your firewall or security
settings.

• OpenAI Account.

To access the full capabilities of ChatGPT, you might need to sign up for an account on the OpenAI platform
and obtain the necessary API key or credentials.

Key requirements for using Microsoft Copilot AI

• Internet connection.

Microsoft Copilot AI is a web service that enhances the Microsoft Copilot search engine with AI capabilities.
A stable internet connection to access the service is required.

You may need to add the https://copilot.microsoft.com domain to the "Allow list" on the system firewall or
security settings.

• Microsoft account.

Certain personalized features and benefits are available to users who sign in with their Microsoft credentials.

Key requirements for using Google Gemini

• Internet connection.

Google Gemini is a conversational generative artificial intelligence chatbot developed by Google, based
initially on the LaMDA family of large language models (LLMs) and later the PaLM LLM.

A stable internet connection to access the service is required.

You may need to add the https://gemini.google.com/ domain to the "Allow list" on the system firewall or
security settings.

• Google account.

Users who log in using their Google credentials have access to specific personalized features and
advantages.

Key requirements for using DeepSeek

• Internet connection.

DeepSeek is a generative-AI chatbot developed by the Chinese company DeepSeek. It is powered by the
company’s own in-house large language models, including the open-weight DeepSeek-V and DeepSeek-
R series.

You may need to add the https://chat.deepseek.com domain to the "Allow list" on the system firewall or
security settings.
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• DeepSeek account.

Signing in to DeepSeek saves your conversation history, allowing you to revisit past chats anytime. It unlocks
file upload capabilities, letting you process documents, images, and PDFs. Additionally, it syncs your data
across devices and maintains context for longer, continuous conversations.

Key requirements for using Grok

• Internet connection.

Grok is an advanced generative-AI chatbot developed by xAI. It is powered by xAI’s own proprietary large
language models, designed and trained in-house rather than based on external model families such as
LaMDA or PaLM.

You may need to add the https://grok.com domain to the "Allow list" on the system firewall or security
settings.

• Grok account.

Logging into Grok saves users full chat history across devices, gives you much higher usage limits (and
access to Grok 4 with a subscription), and unlocks extras like voice mode and conversation sharing.

Security and JSCI disclaimer of using ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and
Grok in XMetaL Environment.

ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok are powered by an artificial intelligence
language model that generates text based on user input.

It may exhibit biases or inaccuracies due to training data limitations and limitations of the underlying technology.

Users are responsible for evaluating and verifying the information provided by ChatGPT, Microsoft Copilot,
Google Gemini, DeepSeek, and Grok web services.

JSCI does not assume liability for actions taken based on ChatGPT, Microsoft Copilot, Google Gemini,
DeepSeek, and Grok web services responses.

XMetaL Author XML editor environment provides access to the web services.

ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok integrated in XMetaL environment don't
have access to documents opened in the XMetaL editor.

JSCI takes precautions to maintain security and privacy but advises caution when sharing sensitive information
with ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok web services. JSCI is not responsible
for unauthorized access, misuse, or data sharing with ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek,
and Grok.

Known issues of integrations with ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok
web services.

Integration with web services relies on a stable internet connection. Due to the high volume of requests, web
service responses can be delayed, user interface reactions slowed down or web service hangs. In this case,
the recommendation are:

• Reload the web service.
• Close-reopen the web service integration tab in XMetaL.
• Log off from the service account then log in again.
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Opening ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek, and Grok in Resource Manager

To use this utility, you can utilize the XMetaL quick navigation tool for invoking the "XChatGPT: open",
"MSCopilot: open", "XGoogleGemini: open", "XDeepSeek: open", or "XGrok: open" macro.

1. Ctrl+?
2. Start typing "XChat", "MSCop", "XGoogle", "XDeep", or "XGrok" to show the list of commands
3. Select a macro and press "Enter"

Including a paragraph with a textual description within an active document editor window is possible using
only a keyboard without switching windows or performing extensive mouse clicks.

Example:

How to do:

1. Select text in the Active Document.
2. Press "Ctrl+\" to open "predefined instructions" list.
3. Select the instruction and press Enter key.
4. Locate a cursor in the Active Document to add the response or replace the content.
5. Press "Ctrl+]" to open "active document update command" list.
6. Select the update command.

Note:
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Access to the Chatbot website may hang because of the user's invalid inputs or other limitations. The
"Instructions" base web page can change URI if the response contains links and a user follows the link. Use
the "Home" or "Reload" buttons in this case.

XMetaL tries to generate an instruction from the selected template, put it into the Chatbot input box, and then
send it automatically. However, Chatbot's internal implementation may not always allow to do it. In this case,
a user should click the "Send message" button at the right of the Chatbot input text box.

When Grammarly is active, Grammarly analyzes the Chatbot input text box and sometimes influences sending
action. In this case, a user should click the "Send message" button at the right of the Chatbot input text box.

Toolbar
The integration's toolbar buttons are displayed on the XChatGPT, MSCopilot, XGoogleGemini, XDeepSeek,
and XGrok tab in the Resource Manager.

Integration's toolbar buttons

The toolbar buttons of this utility provide you with the ability to perform multiple actions.

DescriptionShortcut key# on
image

Home PageCtrl+H1

Previous2

Next3

Reload4

AI Website URL5

Settings6

Close Tab7

Add instruction to a predefined listCtrl+Insert8

Select predefined instructionsCtrl+\9

• After choosing an instruction from the predefined instructions list, it will be executed
automatically.

• If you hold down the Ctrl+Shift key while selecting an instruction, it will not be executed
automatically. In order to run the instruction, you will need to click on the "Run
instruction" button.

• When the Ctrl key is pressed during the selection of an instruction, template parameters
are resolved and the instruction is subsequently copied to the Chatbot input window.
After making modifications to the content, you can proceed by clicking on the "Send
message" button in the Chatbot input window. This action enables you to send the
modified instruction.
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DescriptionShortcut key# on
image

Run instruction10

Favorite instruction 111

Favorite instruction 212

Select the active document update commandCtrl+]13

Update document14

• XMetaL attempts to find the appropriate position in the document for inserting the
content.

• If the Ctrl key is pressed, XMetaL will try to replace the active document's content.

• If the template begins with a markup tag, it will attempt to replace the container element
where the cursor is located.

• If it doesn't start with a markup tag, it will replace the container element's content.

Favorite update command 115

Favorite update command 216

• All buttons display tooltips when the toolbar is activated.

Available options for sending instructions to ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek,
and Grok:

• Input text into the Chatbot input window by typing or copying and pasting.
• Select a predefined instruction from the list.
• Predefine an instruction or question with a placeholder for a parameter in the "Send instruction" edit box.
• Utilize the "Run instruction" button to send the same instruction with different selected content in the Active

Document.
• Make the current instruction your favorite by pressing the Ctrl key and clicking the "1" or "2" button. If the

selection is in the Chatbot, hovering over the button will display the favorite instruction text.

When the active document is in focus, pressing the Ctrl+\ key will open the list of predefined instructions.
Another method to access the list of predefined instructions is by selecting the "[Chatbot]: send instruction
(...)" macro using the Ctrl+? key and then pressing the Enter key. After using the arrow keys to select an
instruction, pressing the Enter key will run the instruction automatically without needing to use the mouse.

Note:

• When selecting an instruction from the list, you can use the following shortcuts:

• Find via Ctrl+F
• Sort via Ctrl+R
• Delete via Del
• Delete all via Ctrl+Del
• Reorder via Shift+Up/Down arrows
• Copy template to "send instruction" text box without automatic sending via Shift+Enter

• The process of assigning an instruction to the "Run instruction" button and the "Favorite instruction 1/2"
button is separate from the list of instructions. Modifying or deleting existing instructions from the list does
not have any impact on the instruction assigned to these buttons.

• Executing the instruction using the "Favorite instruction 1/2" button does not alter the content of the "Send
instruction" box.
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• After selecting an instruction from the list and triggering its automatic sending, the majority of instructions
will display their selected name in the "Send instruction" editable box. However, there are certain instructions
where the selected name may not be displayed.

• The selected text in the document cannot contain keywords such as "%CALL aiPasteDitaPreprocess(0)%".
Attempting to send an instruction with such content will result in an error.

Available options for pasting responses from ChatGPT, Microsoft Copilot, Google Gemini, DeepSeek,
and Grok:

• Copy the selected text in the response to the clipboard and then paste it into the document.
• Select the update command from the list and press "Update document" button.
• Make the current update command your favorite by pressing the Ctrl key and clicking the "1" or "2" button.

If the selection is in the Chatbot, hovering over the button will display the favorite update command text.

When the active document is in focus, pressing the Ctrl+] key will open the list of pasting templates. Another
method to access the list of pasting templates is by selecting the "XChatbot: process response..." macro
using the Ctrl+? key and then pressing the Enter key. By selecting a template using the arrow keys, pressing
the Enter key will automatically update the document without requiring the use of a mouse.

Note:

• When there is no selection in the response, pasting a template with %SEL% or %EL_SEL% will update the
document with the content of the last response.

• The ability to assign templates to the "Update document" button and the "Favorite update command 1/2"
button is separate from the list of available templates for pasting. The available templates can be modified
or deleted as needed. However, once templates are assigned to these buttons, they remain permanent.

• When the response consists of multiple paragraphs separated by newlines, XMetaL applies the template
to each paragraph.

• The quality of the Chatbot's answer depends on the wording of the instruction text. Modifying the "Send
instruction:" template text can help improve the answers.You can press the "+" button to add a new
instruction to the predefined instructions list.

Settings

Settings dialog

In the "Settings" dialog, you have several options available:

Predefined instructions:

• Move the instruction up or down in the list of predefined instructions.

• Export instructions to or import instructions from the text file.

• Edit the predefined instruction using the edit box.

• Replace, add, or remove the selected instruction from the list of predefined instructions. These changes
will be reflected in the "Send instruction:" drop-down list in the
XChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok tab of the Resource Manager.

• Set the favorite predefined instruction to the "Favorite instruction 1/2" button.

Ignore content of tags:

• List the ignored elements when sending an instruction to
ChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok.

Pasting templates:
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• Edit the selected pasting template using the edit box.

• Align the template content in the edit box.

• Replace, add, or remove the selected pasting template from the drop-down list of pasting templates.These
changes will be reflected in the "Update active document" drop-down list in the
XChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok tab of the Resource Manager.

• Export pasting templates to or import them from the text file.

• Set the favorite pasting template to the "Favorite update command 1/2" button.

• Open the "Build template assistant" dialog.

Other features in the Settings dialog include:
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• The "Predefined instructions" edit box can be used to define an instruction or question with a placeholder
for a parameter after ":". XMetaL automatically inserts a "new line" character after the first ":" in the predefined
instruction templates.

Available instruction parameters:

• %SEL%: Active document selected text
• %TAG%:Text content of the document node where the cursor is
• %TAG [parent tag name] [parent tag name] ...%: Extending the selection to the first parent element with

the specified tag names. For example, "%TAG section topic chapter%". The selection will be extended
to the first parent element, "section", "topic", or "chapter".

• %DOC%: Whole document
• %TAGX%, %DOCX%: Sending Active Document content including XML tags.You can instruct Chatbot

to preserve "XML tags names" in response. For example, it allows one to rephrase the part or whole
document and then paste it back.

• %CLIPBOARD%: Clipboard text content

• The "Pasting templates" edit box can be used to define a pasting template, or you can use the "Build
template assistant" button. Pasting templates are markup content with parameters.

Available pasting template parameters:

• %EL_SEL%: Whole response that includes the selected portion

• %EL_LAST%: The last response

• %SEL%: Selected text in the response

• <%TAG%>...</%TAG%>: Selection container node. XMetaL replaces it with a tag name of the Active
Document element that contains the selection.

• %GEN_ID%: Generate unique ID

• %CLIPBOARD%: Clipboard text content

• <%>...</%>: Template block Start/Stop boundary

Templates examples:

• <%TAG%>%EL_SEL%</%TAG%>

• <ItemizedList><%><ListItem Id="li_%GEN_ID%"><Para>%SEL%</Para></ListItem></%></ItemizedList>

Note:

• If the selected text is in the Chatbot response window, sending an instruction with %SEL% will prioritize
this text over the selection in the active document or browser window.

• Modifying the instruction or update command assigned to the "favorite instruction 1/2" button or the "favorite
update command 1/2" button in the Settings dialog will result in a corresponding change in the instruction
or command displayed on the main XChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok page.
However, the button's tooltip on the main XChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok page
will not update unless you restart XChatGPT/MSCopilot/XGoogleGemini/XDeekSeek/XGrok.

• The chatbot response can be inserted into the DITA document with support for bold, italic, tables, and lists.

For example, you make a selection in the document and send the instruction "Write chapter about {use
tables, lists, bold, and italic text for formatting} : %SEL%". Selecting the update command "DITA HTML
Insert (%CALL aiPasteDitaPreprocess(0)%)" inserts the elements with the response formatted using
tables, lists, bold, and italic text in the DITA document.
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Build template assistant

The "Build template assistant" button in the Settings dialog opens the "Build template assistant" dialog. This
allows you to build templates quickly:

• You can import the selected XML content from the Active Document as a starting point by utilizing the
"Import Active Document selected content" button.

• You can insert or replace text in the template using template parameters. This can be done by either typing
or clicking on the parameter button.

Context Menu for AI Assistant
The AI assistant context menu provides the quick access to the various options of finding the instruction and
updating active document.

AI Context Menu

When Chatbot tab is open and active in Resource Manager:

You have multiple options for AI-related instructions.
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The instruction to send to XChatbot:

1. Identify the section where you aim to refine or enhance.
2. Right-click to reveal the context menu for sending instructions to the XChatbot and choose the desired

instruction. .

The instruction to update the document:

1. Locate the specific location within the active document where you intend to perform the update.
2. Right-click to access the context menu for updating the document from the XChatbot response and choose

the desired instruction.
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When Chatbot tab is open but not active in Resource Manager:

The "AI assistant" context menu is available for sending to the Chatbot.

Hide all highlights:

To hide all highlights in the active document generated by XChatbot, select any highlight and then use the
specific context menu item provided for hiding all highlights.
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Note: When this context menu item is selected, it hides not only AI-related highlights but also any other
highlights from XGrammarly, Web, and Bookmark.To make hidden bookmarks visible, open the Bookmark
manager and click the "Show all Active Document bookmarks" button.

Integration with Grammarly
XMetaL 18.0 brings a new feature that allows customers to access Grammarly directly from the XMetaL
Resource Manager tab. This seamless integration provides the convenience of editing documents while
utilizing Grammarly's features.

The Grammarly platform is an advanced web-based writing assistant designed to proofread and edit documents.
It conducts thorough checks for spelling, grammar, and punctuation errors while offering rephrasing suggestions
and enhancing vocabulary usage. The latest extension, GrammarlyGO, is a generative AI tool that facilitates
rapid composition, rewriting, and generation of new ideas, along with offering personalized and relevant
suggestions.

The Grammarly web assistant is integrated into XMetaL Resource Manager, offering swift access to both the
XMetaL editor and Grammarly tools. This integration facilitates smooth data exchange between the two
platforms and encompasses the following features:
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• The integrated features between Grammarly and XMetaL Resource Manager offer a convenient side-by-side
layout for editing documents.

• Users can easily switch between Grammarly and Active Document views.
• The supported text processing scopes in Grammarly include:

• processing the active document.
• processing a selected fragment from the active document.
• writing new text content.

• Through XMetaL's quick navigation commands manager (Ctrl+?), users can pass Grammarly commands
and save processed text from the active document environment.

• The document and document fragment post-processing commands allow users to:

• replace the original content of the active document.
• replace the corresponding XML element in the active document with the selected element in the

spell-checker view.

• Various new text or new text fragment processing commands are available such as:

• inserting text into a new element.
• appending text to the selected element.
• replacing selected element content with new text.
• pasting text at a designated location.

• Additional tools allow:

• showing or hiding XML markup tags.
• synchronizing selections in the active document and spell-checker view.

Key requirements for using Grammarly

• Internet Connection

Grammarly operates as an online platform, so a stable internet connection is essential for accessing its
features and functionalities.

You may need to add Grammarly *.grammarly.com domain to the "Allow list" on your firewall or security
settings.

• Grammarly Desktop Edition for Windows must be installed on your system

This will allow you to access Grammarly writing suggestions directly in a wide array of native applications
including XMetaL and websites.

Download link: https://www.grammarly.com/desktop/windows

Follow installation instructions and "Grammarly for Windows and Grammarly for Mac user guide" from
website.

• Grammarly Account

To utilize Grammarly's advanced features and personalized settings, users must create a Grammarly
account. This account will also allow you to sync your writing across different devices.

Security and JSCI disclaimer of using Grammarly in XMetaL Environment.

Users are responsible for evaluating and verifying the information the Grammarly web service provides.

JSCI does not assume liability for actions taken based on Grammarly web service responses.
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XMetaL Author XML editor environment provides access to the web services.

Grammarly, integrated into the XMetaL environment, doesn't have access to documents opened in the XMetaL
editor.

Only data the user explicitly puts into Resources Manager Spell-checker window are available for Grammarly.

JSCI takes precautions to maintain security and privacy but advises caution when sharing sensitive information
with Grammarly. JSCI is not responsible for unauthorized access, misuse, or data sharing with Grammarly.

Known issues

Integration with web services relies on a stable internet connection. Due to the high volume of requests, web
service responses can be delayed, user interface reactions slowed down or web service hangs. In this case,
the recommendation are:

• Close-reopen the Grammarly integration tab in XMetaL.
• Log off from the Grammarly account then log in again.

• In some cases, the Grammarly Desktop application should be shut down and then restarted again. Some
of symptoms that require this action are

• Grammarly doesn't replace spell checker content in Resource Manager with suggestions text.

• Grammarly suggestions window doesn't appear when the mouse hovers over Grammarly highlighted
word.

Opening XGrammarly in Resource Manager

To utilize this utility, use the XMetaL quick navigation tool to invoke the "XGrammarly: open" macro.

1. Ctrl+?
2. Start typing "XGram" to show the list of commands
3. Select a macro and press "Enter"

The easiest way to activate XGrammarly is through the "XGrammarly" context menu.
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Note:

• Once the "Check spelling" button is clicked, Grammarly becomes visible. Additionally, when text is selected
in the spell-checker, GrammarlyGO also appears.

• The content produced by GrammarlyGO can be inserted or replaced at the selection point in the spell-checker
by using the "Insert" button in the GrammarlyGO response window. However, in some cases, it may get
inserted or replaced at the selection point in the active document with every second insertion. To address
this, you can use the Copy button in the GrammarlyGO response window and paste the content into the
spell-checker window as a workaround.

Toolbar

The toolbar buttons of the utility are displayed on the XGram tab within the Resource Manager.

Grammarly Integration's toolbar buttons

With the toolbar buttons in this utility, you have the versatility to execute numerous actions.

191© 2025 JustSystems Canada, Inc.

Toolbar



Description# on image

Check spelling, grammar, and clarity of active document content1

Check spelling, grammar, and clarity of active document selected content2

Enter new text3

Copy spell-checked content to the active document4

Option for Save changes5

Close Tab6

Hide XML tags in the spell-checker window7

Show XML tags in the spell-checker window8

Show active document selected text in the spell-checker window9

Show spell-checker selected text in the active document10

Spell-checker window11

Note:

• The "Option for Save changes" (#5) offers the ability to update either the entire content initially provided
for spell-checking or only the element content corresponding to the changed text in the spell-checker window.

• The functionality of "Show in the spell-checker window" (#9) and "Show in the active document" (#10) is
operational when the content in both views is identical. In cases where the contents become unsynchronized
due to document changes or changes in the spell checker view, the commands attempt to locate the closest
matching words, if available.

• Text entry mode (#3) retains a history of previously input information.

Context Menu for XGrammarly
The XGrammarly context menu provides quick access to various options for spell checking, grammar checking,
clarification, and updating the active document.

XGrammarly Context Menu

When XGram tab is open and active in Resource Manager:

Multiple XGrammarly-related options are available:
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The checking option:

1. Identify the section where you aim to perform spell and grammar checking or clarifying.
2. Right-click to reveal the context menu for checking options and choose the desired option.

The instruction to update the document:

1. Locate the specific location within the active document where you intend to perform the update.
2. Right-click to access the context menu for updating the document from the XGrammarly and choose the

desired option.

When XGram tab is open but not active in Resource Manager:

The XGrammarly related context menu is available for spell and grammar checking, clarifying sections in the
active document, and updating the document.

193© 2025 JustSystems Canada, Inc.

Context Menu for XGrammarly



Hide all highlights:

To hide all highlights in the active document generated by XGrammarly, select any highlight and then use
the specific context menu item provided for hiding all highlights.
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Note:  Selecting this context menu item hides highlights not only from XGrammarly but also from XChatbot,
the Web, and Bookmark. To make hidden bookmarks visible, open the Bookmark manager and click the
"Show all Active Document bookmarks" button.
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XMetaL Project

In modern technical documentation projects, which may include thousands of documents and images, swift
access to content is critical for technical writers. Effective cross-referencing between topics is essential for
producing high-quality documentation, though it can be complex and time-consuming. Facilitating this process
is a key requirement.

The XMetaL Project is a framework within XMetaL Author designed to structure and manage content in
extensive documentation projects. It establishes the structure and relationships among various documents
and resources, facilitating rapid access and enabling bulk processing.This tool enhances content management
efficiency and accuracy in documentation projects.

Features:

• Hierarchical Organization: Defines the hierarchical structure of content, including parent-child relationships
between documents, resources, and virtual folders.

• Navigation: Facilitates content navigation by specifying the order and relationships of documents.
• Quick Access to Documents and Resources: Enables users to locate elements by title, file name,

keywords, or content, and open them directly within the XMetaL environment or a specified application.
• Cross-File Operations: Supports tasks such as text or markup replacement, archiving, spell checking,

inserting cross-references, validating links, and creating documentation templates. These operations can
be performed on selected XMetaL Project items, open documents, or file system folders.

• Import of Existing Documentation: Enables bulk import of documents from open XMetaL documents,
maps, folder contents, and results from XMetaL cross-file searches, including referenced documents and
resources.

• Adding New Content: Allows for the rapid bulk addition of new documents using XMetaL document
templates.

• Reorganizing Content: Facilitates copying and moving project elements across the file system while
preserving references throughout the project scope.
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XMetaL Project main menus

The XMetaL Project offers various features accessible through the following main menus:

Table 41: Project Menu

Follow these stepsTo do this

Click the Project menu and then select New...Create a new project

Click the Project menu and then select Open...Open the project in the Resource Manager

Click the Project menu and then select Save or Save_As...Save or Save As the project

Click the Project menu and then select Settings...Configure the XMetaL Project parameters

Click the Project menu and then select Show in explorerDisplay the project's location in Explorer
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Follow these stepsTo do this

Click the Project menu and then select ExitExit the project

Table 42: Edit Menu

Follow these stepsTo do this

Click the Edit menu and then select Synchronize
selection...

Select the item in the project that synchronizes with the
Active Document

Click the Edit menu and then select Insert folder...Insert a folder into the project

Click the Edit menu and then select Insert reference to
Active Document...

Insert an Active Document into the project

Click the Edit menu and then select Insert reference to...Insert a reference to:

• Open documents and maps

• Folder content

• Existing files

• Results tab content

• New XML documents

Click the Edit menu and then select Update titles...Update project titles

Click the Edit menu and then select RenameRename the selected item in the project

Click the Edit menu and then select DeleteDelete the selected item

Click the Edit menu and then select Delete AllDelete all items in the project

Click the Edit menu and then select Transform selected
node to new project...

Transform the selected node in the project to a new XMetaL
project

Click the Edit menu and then select Open with...Choose the appropriate application to open the selected
item

Click the Edit menu and then select Show in explorerOpen windows explorer to locate the selected item in the
project

Click the Edit menu and then select HierarchyChange the hierarchy in the project by selecting:

• Move item Up/Down

• Promote item

• Promote item and siblings

• Demote item

• Demote item and siblings

• Collapse

• Expand

Table 43: Find Menu

Follow these stepsTo do this

Click the Find menu and then select Document...Find and open the documents in the project that contain the
specified keywords

Click the Find menu and then select Content...Find the words
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Table 44:Tools Menu

Follow these stepsTo do this

Click the Tools menu and then select Archive...Archive the project or documents

Click the Tools menu and then select Spell check
documents

Perform a spell check on all documents in the project

Click the Tools menu and then select Generate resources
map...

Generate a resources map of the project, with tree nodes
representing the hierarchical folder structure of the
documents within the Windows file system

Open the resources map, click the Tools menu and then
select Relocate resources...

Relocate the resource by copying or moving it within the
resources map

Open the resources map, click the Tools menu and then
select Transfer to 'New Document' template...

Transfer the selected resource in the resources map to the
'New Document' template by copying or moving it under the
XMetaL templates folder

Table 45: Links Menu

Follow these stepsTo do this

Click the Links menu and then select Insert reference...Insert links into the document within the project

Click the Links menu and then select Find cross-
references candidates...

Find keywords for cross-reference candidates and display
them in the Results window

Click the Links menu and then select Set keywords...Set keywords in the documents within the project

Click the Links menu and then select Find keywrods
candidates...

Find keywords candidates in the project and display them
in the Results window

Click the Links menu and then select Delete all keywords...Delete all keywords from the project

Click the Links menu and then select Find and validate...Find references in the project that meet the following
conditions:

• Broken references

• Linked documents

• Documents containing references

• References to xml

• References to non-xml

• References to WEB content

• References to content within documents only

• Reference attribute contains value

• Reference element text contains values

The Edit and Links menus provide an extensive selection of valuable features:

199© 2025 JustSystems Canada, Inc.

XMetaL Project



Creating new XMetaL Project

A new XMetaL Project is created using the "New XMetaL Project" wizard, accessible via the Project > New
menu item:
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Note: When the "Include referenced files" checkbox is enabled, both the @href and @conref attributes
are consistently added during the creation of a new project.

Docs Desk
Docs Desk is an XMetaL Project on page 196 that provides permanent, always-accessible support for technical
writers through macro calls or shortcuts.

The XMetaL project offers efficient and convenient tools for cross-file content searching, spell checking,
archiving, and reference insertion. These operations apply not only to project items but also to documents
and maps opened in XMetaL, file system folders, and search result tabs. Additionally, straightforward import
functions allow for the seamless addition or removal of documents from existing documentation projects.

Docs Desk serves as a versatile tool for technical writers, enabling daily document and file system resource
processing without altering the original document projects.

Opening Docs Desk
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Clicking the "Open Docs Desk" button in the Whiteboard toolbar will open the XMProject.xwb project document
within the Resource Manager.

Edit

Find Document

The "Find Document" feature is a modeless dialog box that presents a structured view of all project files in a
single, flat list.This list includes various identifiers such as document titles, keywords, and file names, facilitating
the efficient location of specific documents. The dialog's context-sensitive filtering capabilities enable users
to search for, manage, and organize documents with ease, allowing for quick actions such as finding, opening
or closing files. Additionally, it supports synchronization between the project structure and currently opened
documents, ensuring that selections within the project are consistently reflected across all open files.

Furthermore, it allows technical writers to view, filter, and verify keywords linked to specific documents. This
functionality ensures that the correct keywords are applied, promoting accurate content categorization and
facilitating easier retrieval of documents during the writing and review process.

A customized version of the "Find Document" dialog is available as an optional tool within the "Insert Cross
References" feature. This tool is specifically designed to assist users in setting the reference target attribute
by enabling them to efficiently locate and select the appropriate document or section to reference.

To open the Find document dialog box, navigate to Find menu and select Document.
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Figure 1: Find Document: User Interface

To set "Quick find keyword parameters", click the Set quick find keyword parameters button [1] in Find
document dialog box:
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Find Content

The "Find Content" feature is a modeless dialog that streamlines cross-file operations for efficient text and
markup search and replacement.This tool offers a user-friendly interface for managing content across multiple
files, simplifying tasks such as text searches and replacements.

The dialog's WYSIWYG interface is designed to facilitate the extraction of various components from active
documents, including plain text, XML markup elements, attributes, and attribute values. This functionality
enables users to set and apply a wide range of search conditions efficiently.

To open the Find words dialog box, navigate to Edit menu and select Content or click Find content toolbar
button.
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Figure 2: Find Content UI : Main

Scope of the Find Operation:

• Entire XMetaL project or a selected subtree
• Active documents or maps
• All open documents
• Specific file system folders
• Desktop tree content within XMetaL Resources Manager

There are two available check boxes: one for including referenced files and another for including referenced
projects in the search operation.

Tip: When multiple tab groups are created by right-clicking on the file name tab, the "Active tab
documents" setting restricts searches to the active tab group only.
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Scope of "Find What":

• Plain text or text within markup
• Markup tags
• Content within markup tags
• All instances of words within a specific markup tag

The "Find What:" feature is designed to optimize the search process by aligning found text to whole word
boundaries by default. It offers a "one-click" functionality that allows users to quickly copy selected text from
the active document into the search box [1], automatically extending the selection to the nearest word
boundary. This feature also supports a search history, enabling users to organize or remove past queries.
For advanced users, the tool provides the ability to utilize regular expressions for more complex search
conditions.

Result View Settings:

• Customization options for the result set include the ability to show or hide markup tags and control check
boxes.

• Highlighting and coloring of found words are available to improve visibility.

Markup Filtering and Advanced Functionality

The "Find What" extension includes a simple yet powerful tool for filtering markup. Various settings allow
users to apply conditional filtering to text based on specific criteria. Additionally, this extension offers advanced
functionality by permitting the use of text files as input instead of the standard search box. These text files
can specify the target text and may include an optional "Replace with..." parameter, listing potential
replacements for the identified text.
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Figure 3: Find Content UI: Keywords in file

Results Find tab:

This replacement list is displayed as a series of buttons in the result set, where button labels show
replacement's option.
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Figure 4: Find Content UI: Keywords in file - Results window with replace options

Advanced Markup Filtering

The markup filtering feature enables users to create advanced search conditions by specifying lists of markup
tags in two edit boxes under the "Markup filter (elements)" section. Tags in the first edit box represent the
first condition, identifying the ancestors of the searchable text, while tags in the second edit box represent
the second condition. These conditions can be combined using logical operators such as "IN" and "AND IN"
or "IN" and "NOT IN." The system first validates the condition in the first edit box before applying the condition
in the second edit box.

XMetaL Author Help208

Find Content



Figure 5: Find Content UI: Advanced markup filtering

To enhance usability, a "one-click" operation allows users to automatically copy the container element of the
current selection into the search condition box for either the first or second edit box [2]. For more advanced
search requirements, users can utilize XPath expressions as filters [3]. The feature includes an integrated
XPath expression builder, which assists in constructing these expressions and provides quick access to
predefined XPath expressions. Additionally, the builder offers "one-click" access to the container element of
the current selection and includes comprehensive options for filtering based on tag names, attributes, and
attribute values, making it a valuable resource for precise markup filtering.

Tools

Archive Project

The Archive XMetaL Project feature provides an efficient solution for archiving projects and their associated
content.

To open the Archive linked documents dialog box, navigate to Tools menu and select Archive, or click
Archive toolbar button.
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Figure 6: Archive UI

Spell Check Project

The Spell Check XMetaL Project feature provides an efficient method for verifying the spelling of projects
and their referenced content.This functionality supports the accuracy and professionalism of written materials.

To perform spell checking within a project, navigate to Tools menu and select Spell check documents, or
click Spell Check toolbar button.
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Figure 7: Spell check results tab

Resources Map

An XMetaL project, whether a generic documentation project or an XML document, defines a logical data
structure in which elements directly reference one another. For example, a documentation index file may
reference various topics, and a document topic may link to other topics, images, or external documents.

The Resources Map is a specialized type of XMetaL project, generated to mirror the hierarchical folder
structure of elements (documents) within the Windows file system. In this structure, tree nodes represent
folders, while tree leaves represent file names.
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Generate Resources Map

Input parameters for generating a Resources Map include open XMetaL documents, projects, or maps.

The algorithm used to generate a Resources Map traverses the input elements and their referenced content,
creating a tree structure that captures all resources. This structure provides technical writers with a
comprehensive view of the physical locations of all documentation files.

XMetaL Project's editing functionality allows users to rename or relocate elements, including logical folder
names, within the Resources Map tree.

To open the Generate Resources Map dialog box, navigate to Tools menu and select Generate resources
map,

Scope for generating resources map:

• All Project items
• Selected item and descendants
• Selected item only
• Active document
• All open documents
• Project documents
• Project resources

Two options are available for including referenced files or referenced projects.
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Figure 8: Resources Map

Relocate Resources

The "Relocate Resources" command, available under XMetaL Project Tools menu, is exclusively for the
Resources Map. This command enables users to create, copy, or update the file system by replicating the
folder and file structure as defined in the Resources Map tree. It also updates referenced content according
the new folder structure.

The procedure for relocating resources is outlined as follows:

1. Modify the Resource Map: Insert, delete, or rename folders or references as required.

2. Access the Tools Menu: Navigate to the Tools menu and select the Relocate Resources option.
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3. Relocate Resources: Choose either Copy or Move to transfer the resources to the new location, ensuring
the file system is updated accordingly.

Transform to New Document Template

The "Transform to New Document Template" command, available under XMetaL Project Tools menu, is
specific to the Resources Map, This command allows users to convert the Resources Map into an XMetaL
document template. The transformed content is then accessible in the list of XMetaL's templates under the
"New Document" command. When this template is applied, a copy of the transformed Resources Map files
is created in a user-specified folder. For example, a new documentation project might include mandatory
elements such as an index, preface, chapters, topics, glossaries, and images, with some topics featuring
predefined internal structures and images. These project files can serve as a fundamental template for other
similar projects.

The procedure of transforming to new document template are followings:

1. Generate the Resources Map: Create a resources map that aligns with the desired new document template.
2. Access the Tools Menu: Navigate to the Tools menu and select the Transform to New Document Template

option.
3. Configure Template Settings: Select the XMetaL template group and specify the template name.
4. Relocate Resources: Select either Copy or Move to transfer resources to the new XMetaL document

template location, ensuring the template is updated as required.

Links

Insert References

High-quality documentation enables efficient navigation between related topics, chapters, or chunks of relevant
information, with topics potentially referencing external web resources. However, the requirements for valid
XML reference formats add complexity to a technical writer's work. While automated systems can generate
numerous cross-references, they may sometimes be irrelevant, redundant, or non-compliant with technical
writing standards. Additionally, as document content evolves, links may break or become obsolete. In such
cases, technical writers require tools to manually or semi-manually maintain existing references and create
new ones.

The XMetaL "Insert References" feature is designed to streamline the technical writer's work by providing
tools to locate content within a documentation project or on the web while managing the technical details of
setting valid XML reference elements. This allows the technical writer to focus on the document's semantics
and maintain clean content.

The "Insert References" tool is implemented as a modeless dialog.This dialog provides controls for selecting
an XML reference template based on document type requirements, the format of the reference target, and
the technical writer's preferences.

To open the Insert references dialog box, navigate to Links menu and select Insert reference, or click
Linking assistant toolbar button.
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Figure 9: Insert reference: default UI
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Description# on image

Insert reference1

Select reference template2

Remove reference tag3

Remove surrounding tag4

Find content5

Find cross-references candidates6

Lock link location to Active Document selection7

Select reference location8

Settings for "Insert reference" action9

Set target to Active Document selection10

Target type and ID format11

Find target document by keyword12

Browse for target13

Paste target markup14

Select target location15

Settings for "Set target" action16

Insert web reference into Active Document17

Find Active Document content on the WEB18

Example of a typical scenario of inserting reference in manual mode:

1. The author begins by reviewing the document, identifying any text that may require referenced content.
The selected text is marked as a potential link candidate by clicking the "Pin Reference" button .

2. The author searches for relevant content either within the project documentation using XMetaL tools such
as "Find content" button [5], or on the web using "Find Active Document content on the WEB" button [18].

3. Once the appropriate content is located, the author selects the "Set as Target" button [10], followed by
the "Insert Reference" button [1]. For the "WebLink Rsrc tab" as the target type, the author just clicks the
"Insert Reference" button [1].

Example of a typical scenario of inserting reference in semi-manual mode:

1. The author assigns keywords to topics through the "Links" menu by selecting either "Find Keyword
Candidates" or "Set Keywords".

2. To locate documents containing those keywords within the project, the author uses the "Find cross-reference
candidates" button [6].
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3. This generates a list of potential reference documents, enabling the technical writer to navigate between
the reference location and the target document.

4. The author can then adjust the reference location or target as necessary and finalize the process by
clicking the "Insert Reference" button in the Results Find pane.

5. Once inserted, the reference is marked in the list of candidates in the Results Find pane.

Insert reference context menu:

Activating the "Insert References" UI dialog enables XMetaL context menu commands related to this task.

Figure 10: Insert reference: context menu

Settings for "Insert reference" action:

Additional tool with a WYSIWYG user interface, activated by button [9], allows for the addition, deletion, and
modification of references.

Figure 11: Insert reference: reference template
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Note: The "Extend selection to word" checkbox is effective when the user partially selects a word and
then applies the "Insert reference" button.

Settings for "Set target" action:

Additional tool with a WYSIWYG user interface, activated by button [16], allows for the target templates and
settings.

Figure 12: Insert reference: target settings

Find Cross-References Candidates

Modern documentation may consist of hundreds of documents, with content frequently referencing or relating
to information in other documents. High-quality documentation includes links that facilitate user navigation
between related pieces of information. Identifying valid connections across numerous documents and creating
accurate markup links is a challenging task for technical writers. Fully automated processes for finding
connections can produce many irrelevant or redundant links, diminishing documentation quality.The XMetaL
"Find Cross-References Candidates" feature is a semi-automated tool that assists in identifying and inserting
valid markup links. Technical writers conduct the final semantic review and determine the appropriate
connections.
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The "Find Cross-References Candidates" feature is a specialized extension of the "Find Content" function,
designed to streamline the creation of cross-references within documents based on keywords defined in the
XMetaL Project.

The user interface is designed to efficiently support the visualization and configuration of search conditions,
options, and criteria.

To access the Find cross-references candidates dialog box, navigate to Links menu and select Find
cross-references candidates, or click the Find cross-references candidates button in the Insert reference
dialog box.

Figure 13: Find cross-references candidates: Find UI

Scope of the Find Cross-Reference Candidates Operation:

Cross-references can be created within the following document scopes:

• The entire XMetaL project or a selected subtree
• Active documents or maps
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• All open documents
• Specific file system folders
• Desktop tree content within XMetaL Resources Manager

Additional options allow for searches by:

• Extending to referenced files or projects
• Limiting the scope of reference elements candidate within a document to specific markup elements and

their descendants, such as paragraphs and descriptions
• Using logical operators such as "IN" and "AND IN", or "IN" and "NOT IN."
• Disabling specific markup elements

Range of Documents for Identifying Keyword Candidates:

The scope of reference candidates is determined by keywords assigned to XMetaL Project documents and
can be limited to the following:

• Entire XMetaL project
• Selected project subtree
• Single document

The list of keywords can be filtered according to user requirements by configuring the following options:

• Ignore keywords
• Ignore referenced project keywords
• Select reference type
• Set filtering conditions

Results Find tab:

The search for cross-reference candidates yields a list of documents containing sub-lists of potential reference
element locations. Each entry in these sub-lists includes the candidate text, the surrounding document
fragment, a link to the target candidate, a link to the reference element candidate, and a button for inserting
the reference. This setup enables users to navigate and validate both link and target locations.

Result UI controls enable users to highlight, select, and adjust link candidates, to set the link element format
and template, to run insert cross-references action as bulk operation.

Note:  Ensure that the link element format is correctly configured by selecting the "Set Replace Options"
button in the Results Find tab.
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Figure 14: Find cross-references candidates: Set reference UI

Set Keywords

An XMetaL Project "keyword" is a text label assigned to a specific markup element or an entire document
within a project.

The primary functions of an XMetaL Project "keyword" are to help technical writers quickly locate documents
or document elements within large documentation projects (which may contain hundreds of files) via the "Find
Document" dialog, serve as a potential reference target for locating cross-document references, and facilitate
explicit document linking. XMetaL uses the document path and, if available, the keyword element's attribute
ID to search content. This enables efficient searching, categorization, and retrieval of information.

XMetaL Project supports two primary types of keywords:

• Element-level keywords: These are assigned to specific elements within a document, such as paragraphs,
titles, or topics. Each element must have a unique ID attribute that corresponds to its position in the source
XML content and the generated documentation. The keyword’s reference target attribute identifies the
element's ID.
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• Document-level keywords: These are applied to the entire document, offering a general overview or
categorization of its content. Unlike element-level keywords, the reference target attribute for document-level
keywords is optional.

The XMetaL Project's "Set Keywords" feature provides a user-friendly WYSIWYG editing environment, allowing
technical writers to easily add, view, and manage both element-level and document-level keywords for files
opened in XMetaL. This functionality greatly improves the organization, accessibility, and searchability of
technical documentation within the platform.

To open the Set Keywords dialog box, go to the Links menu and select Set Keywords. Alternatively,
activating the "Set Keywords" dialog also enables relevant XMetaL context menu commands for this task.

Figure 15: Set keywords full user interface and context menu example

Description of Set keywords user interface:

The keywords for documents are stored within the XMetaL Project rather than directly in the document.When
using the "Set Keywords" UI dialog, the selection within the XMetaL Project should correspond to the active
document.

When assigning a keyword and the keyword entry field is empty, place the cursor on a specific word or select
a portion of text within the document. Then, click the "Add Element Level Keyword" or "Add Document Level
Keyword" button. The keyword can be a partial word, and XMetaL will automatically expand the selection to
include the entire word boundaries. It uses the provided keywords as a search filter to complete the action.

If the desired keyword is not found in the document text or if adjustments are needed, enter the keyword into
the keyword edit box and then click either the "Add Element Level Keyword" or "Add Document Level Keyword"
button. Note that the list of keywords may include words or phrases that are not currently present in the
document or element.
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Another method for setting keywords is to use the "Find Keyword Candidates" button [1] in the "Set Keywords"
dialog. If the document already contains content with designated XML elements for keywords, such as
<indexterm>, <keyword>, etc., the "Find Keyword Candidates" action can extract and assign keywords to
the XMetaL project in bulk.The keywords identified in the Results Find window can be set as either "Element
Keywords" or "Document Keywords" by pressing the respective buttons. The keywords will then be displayed
in the "Set Keywords" dialog within the complete user interface for convenient access and management.

When assigning an "Element-level keyword" to an element that lacks an attribute ID, XMetaL will automatically
generate a new ID for the element. The Full UI dialog will then display a list of newly created keywords along
with their corresponding element IDs.You can modify the keyword text later within this Full UI dialog.

Notes:

• The titles of XMetaL Project documents are designed to be explicit document-level keywords. Therefore,
there is no need to include additional keywords.

• Keywords within a document must be unique to ensure clarity and avoid redundancy.
• When determining whether to assign "Element-level keywords" or "Document-level keywords," consider

the following: if you assign element-level keywords to an element that lacks an attribute ID, XMetaL will
generate a new ID and update the document accordingly. Additionally, certain elements—such as prologs,
meta information, or other components not present or addressable in the "Final Generated
Documentation"—may cause links to element-level keywords to become invalid.

• XMetaL provides both bulk and manual tools for inserting references, utilizing "reference element templates"
within the "Insert Reference" dialog. One of the parameters in these templates is the Keyword ID. XMetaL
allows users the flexibility to either include or omit the element ID when applying the insert reference
template.

Find Keywords Candidates

Find keywords candidates is a specialized feature of "Find Content" designed to assist in adding documents
keywords into the XMetaL Project.

When document rules, such as DTD or Schema, specify elements for document keywords (e.g.,
<index>...</index>, <indexterm>...</indexterm>, <keyword>...</keyword>), "Find Keywords Candidates"
searches for these specified markup tags across the input scope documents.

To open the Find keywords candidates dialog box, navigate to Links menu and select Find keywords
candidates,
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Figure 16: Find keywords candidates: UI

Scope of the Find Operation:

• Entire XMetaL project or a selected subtree.
• Desktop tree content within XMetaL Resources Manager.

Results Find tab:

The results display the found text and markup contents. Each result entry includes buttons to set the found
text as a "Document Level Keyword" (pointing to the root element ID) or as an "Element Level Keyword"
(pointing to the text container element if it has an ID attribute). This action modifies only the XMetaL Project,
leaving the documents themselves unchanged. Selecting the "Element Level Keyword" will automatically
generate an ID attribute for any element that is missing one.The user interface also supports setting keywords
in bulk mode.
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Figure 17: Find keywords candidates: Set keyword from results tab

Find and Validate Links

The "Find and Validate Links" tool is a specialized feature designed to assist technical writers in analyzing
and validating cross-references between documents. It allows users to search for referenced content based
on specific criteria, such as images, web links, or links with specific text, attributes, or locations, ensuring
accuracy and consistency across documentation.

To open the Find linked documents dialog box, navigate to Links menu and select Find and validate.
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Figure 18: Find and validate links: user interface

Results Find tab:

The "Find and Validate Links" tool generates a list of documents, each containing sub-lists of references that
meet the specified search criteria. Each entry in these sub-lists includes the reference's markup content,
reference text, a link to the reference location, and a link to the reference target. This enables users to
efficiently navigate and validate both the links and their corresponding targets.
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Figure 19: Find and validate links: results tab
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Keyboard shortcuts

Shortcut keys for menu commands are indicated in the menus. All menus, menu items, and dialog box controls
are accessible by pressing the Alt key and the underlined letter (also called an access key or mnemonic)
associated with that control. XMetaL Author also supports shortcut keys for window and dialog box navigation
and other functions.

Note:  If a keyboard shortcut listed here does not work in your document, check to see if the keystroke
combination has been assigned to a macro.

Table 46: Working with files

ShortcutAction

Ctrl+NCreate a new document from the default template

Ctrl+TCreate a new document by choosing a template

Ctrl+OOpen a document

Alt+F + number keyOpen a document from the recently-opened list

Ctrl+W OR Ctrl+F4Close a document

Note: You can also click the middle mouse
button to close a document.

Ctrl+SSave a document

Ctrl+QSave all documents

Ctrl+PPrint

Alt+F4Quit XMetaL Author

Ctrl+MPreview document in a browser

F1Display online help

F4Next Results Pane selection

Shift+F4Previous Results Pane selection

Ctrl+'View recently used and favorite documents

Ctrl+DView opened documents

Table 47: Editing documents

ShortcutAction

Ctrl+FFind and Replace

F3Find Next Forwards

Shift+F3Find Next Backwards

Ctrl+F3Find Selection Forwards

Ctrl+Shift+F3Find Selection Backwards

Ctrl+Z OR Alt+BackspaceUndo an action
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ShortcutAction

Ctrl+YRedo an action

EscCancel an action

F7Check spelling

Shift+F7Open thesaurus

F9Validate Document

Ctrl+ASelect all

Ctrl+?Quick access to all available commands

Ctrl+.Quick word correction/replacement

Table 48: Switching views and display modes

ShortcutAction

Ctrl + Space barToggle between Normal and Tags On views

Ctrl+Shift+HSwitch to Plain Text view

Ctrl+Shift+OSwitch to Tags On view

Ctrl+Shift+WSwitch to Normal view

Ctrl+Shift+VSwitch to Page Preview

Ctrl+Shift+QHide/show HTML table grid outlines (if no grid selected).

Table 49: Inserting, deleting, and moving text and markup

ShortcutAction

BackspaceDelete one character to the left

DeleteDelete one character to the right

Ctrl+X OR Shift+DeleteCut selection (copy to clipboard)

DeleteDelete selection (do not copy to clipboard)

Ctrl+C OR Ctrl+InsertCopy selection

Ctrl+V OR Shift+InsertPaste from clipboard

Ctrl+Shift+EInsert special character

EnterInsert newline in PRE-like element

Shift+EnterTerminate a PRE-like element

Shift+F6Open or close the Attribute Inspector

F6Open and place active cursor in the Attribute Inspector

Enter OR Ctrl+Shift+PSplit element (where allowed by the DTD)

Backspace (at beginning of element) OR Ctrl+Shift+JJoin to preceding element (where allowed by the DTD)

Delete (at end of element)Join to following element (where allowed by the DTD)

Ctrl+Shift+DRemove markup

Ctrl+Shift+LOpen or switch Element List to “Change element” mode

Ctrl+Shift+TSelect element

Ctrl+Shift+IOpen or switch Element List to “Insert element” mode
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ShortcutAction

Ctrl+EnterIn-place, look-ahead Element List

F8Insert a comment

Ctrl+,Insert XML template

Table 50: List formatting

ShortcutAction

TabDemote selected list items to sub-list

Shift+TabPromote selected list items out of list

Table 51: Navigating within a document

ShortcutAction

Left arrowOne character to the left

Right arrowOne character to the right

Ctrl + Left arrowOne word to the left

Ctrl + Right arrowOne word to the right

Up arrowUp one line

Down arrowDown one line

EndTo the end of a line

HomeTo the beginning of a line

Page UpUp one screen (scrolling)

Page DownDown one screen (scrolling)

Ctrl+EndTo the end of a document

Ctrl+HomeTo the beginning of a document

Table 52: Navigating within tables

ShortcutAction

Tab OR Right arrowNext cell in a row

Shift+Tab OR Left arrowPrevious cell in a row

Alt+HomeFirst cell in a row

Alt+EndLast cell in a row

Alt+Page UpFirst cell in a column

Alt+Page DownLast cell in a column

Up arrowPrevious row

Down arrowNext row

Click to right of the tableOutside the table
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Table 53: Working with selections in a document

ShortcutAction

Shift + Right arrowOne character to the right

Shift + Left arrowOne character to the left

Ctrl+Shift + Right arrowTo the end of a word

Ctrl+Shift + Left arrowTo the beginning of a word

Shift+EndTo the end of a line

Shift+HomeTo the beginning of a line

Shift + Down arrowOne line down

Shift + Up arrowOne line up

Ctrl+Shift+HomeTo the beginning of a document

Ctrl+Shift+TSelect the current element

Ctrl+ASelect the entire document

TabSelect the contents of the next cell in the table

Shift+TabSelect the contents of the preceding cell in the table

Table 54: Working with selections in a table

ShortcutAction

Shift + Right arrowExtend selected cell block by one cell to the right

Shift + Left arrowExtend selected cell block by one cell to the left

Shift + Down arrowExtend selected cell block by one cell down

Shift + Up arrowExtend selected cell block by one cell up

Table 55: Choosing menu commands

ShortcutAction

Shift+F10Show the shortcut (right mouse) menu

Alt + Space barShow the program icon menu (on the program title bar)

Down arrow, Up arrowSelect the next or previous command on the displayed
menu or sub-menu

Left arrow, Right arrowSelect the menu to the left or right; or, with a sub-menu
visible, switch between the main menu and the sub-menu

AltClose the visible menu and sub-menu at the same time

EscClose the visible menu; or, with a sub-menu visible, close
the sub-menu only

CTRL + Shift + SShow the Insert Symbol menu

CTRL + . (period)Show the Quick Writing Tools menu
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Table 56: Moving between panes, documents, and dialogs

ShortcutAction

Hold Ctrl + Tab to open the dialog and press Tab again until
the pane you want to activate is highlighted

Open a dialog to select where to move the active cursor

Alt+TabSwitch to the next active program

Alt+Shift+TabSwitch to the previous active program

Ctrl+F6Move the active cursor to the next document

Ctrl+Shift+F6 OR Ctrl+Shift+TabMove the active cursor to the previous document

Ctrl+EscShow the Windows Start menu

Ctrl+WClose the active document pane

Alt+F6Toggle between the active document and the most recently
active modeless dialog box

Alt+Shift+F6Cycle through the active document and any open modeless
dialog boxes

Table 57: Navigating in a dialog

ShortcutAction

Ctrl+Tab OR Ctrl+Page DownSwitch to the next tab in a tabbed dialog

Ctrl+Shift+Tab OR Ctrl+Page UpSwitch to the previous tab in a tabbed dialog

TabMove to the next control

Shift+TabMove to the previous control

Alt + underlined letterMove to control

Arrow keysMove between options in the selected drop-down list box

Arrow keysMove between radio buttons in selected group

Space bar OR EnterPerform the action assigned to the selected button

Space barTurn selected check box on or off

Alt + underlined letterTurn any check box on or off

First letter in option nameMove to an option a selected drop-down list box

Alt + Down arrowOpen selected drop-down list box

EscClose selected drop-down list box

EnterPerform the action assigned to the default button in the
dialog (if no other push button is selected)

Arrow keysSelect a folder in a folder list

F5Update the files visible in the Open or Save As dialog box

EscCancel the command and close the dialog
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3rd party viewers

This option configures XMetaL to display media whose format requires third-party control for viewing. Element
types set up with Treat-As-Image designation will be so configured.

For more information, contact XMetaL Support
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Appendix A: XML basics

XML (Extensible Markup Language) is a recommendation of the World Wide Web Consortium (W3C). It is a
language for describing the structure and content of a document. Authors use XML to “mark up” their documents
for a consuming application such as a Web browser or print formatting engine. XML is an application of SGML
(Standard Generalized Markup Language). XML is more flexible than other markup languages such as HTML
because it allows you to create your own markup. This makes it better suited to describing and processing
complex information.

Separation of content and format

XML elements describe the role the information plays in a document, not how it is to be formatted. Consuming
applications such as Web browsers receive instructions from a style sheet on how to render the markup. XML
elements can also be transformed via XSLT (Extensible Stylesheet Language Transformations) into elements
that are recognized by a consuming application. For example, an XML <title> element can be transformed
into the HTML <h1> element for rendering in a specific size and typeface.

XML declaration

All XML documents start with a processing instruction (the XML declaration) that indicates that the file is an
XML file and which version of XML is used. Some XML declarations also specify a character encoding. The
recommended encoding for XML documents is UTF-8. Here is an example:

<?xml version="1.0"
encoding="UTF-8"?>

References

You are encouraged to consult the many available printed and online references.These include the following:

• The Extensible Markup Language (XML) 1.0 (Fourth Edition) (a W3C Recommendation), available at
www.w3.org/TR/REC-xml

• The XML Handbook by Charles Goldfarb and Paul Prescod, at www.xmlhandbook.com

• The Annotated XML Specification by Tim Bray, at www.xml.com/axml/testaxml.htm

• XML-related publications, events, and software, from the World Wide Web Consortium web site at
www.w3.org/XML

• XML.com

• The SGML/XML Web Page (maintained by Robin Cover) at www.oasis-open.org/cover/sgml-xml.html
provides a reference database

• The XML Companion by Neil Bradley is recommended for beginners (see also www.bradley.co.uk)

• XML Specification Guide by Ian Graham and Liam Quin is a comprehensive reference book (see also
www.wiley.com/compbooks/graham-quin)

• XML: The Annotated Specification by Bob DuCharme is recommended for advanced users

• The Project Cool Developer Zone at http://www.devx.com/projectcool/developer/ provides references on
various technologies, including XML

• XML by Example by Benoit Marchal is recommended for intermediate-level Web developers

• XML Black Book by Natanya Pitts-Moultis and Cheryl Kirk is recommended for intermediate to advanced
webmasters and Web developers

• XML Pocket Reference by Robert Eckstein, a reference for XML, XSL, and XLL
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Valid vs. well-formed documents
An XML document is well-formed if it is structurally correct according to the XML standard. It is valid if it
conforms to a DTD or Schema. XML documents can be well-formed without being valid; however, all valid
XML documents are well-formed by definition. SGML documents must be valid and well-formed.

There are several aspects to well-formedness:

• The document must have only one top-level element that contains all other elements.

• All elements (with the exception of the top-level element) must be nested, that is, if an element’s start tag
occurs inside an element, then its end tag must occur inside the same element.

• An attribute name cannot occur twice in the same tag.

• All characters must be in the character set defined by the XML standard (that is, Unicode).

• Entities must not be defined recursively.

DTDs and Schemas
DTDs and Schemas define the information that can be contained in a document and facilitate the exchange
of similarly defined information between systems. Although XML files can exist as well-formed, stand-alone
documents, most are associated with either a document type definition (DTD) or an XML Schema. SGML
files must be associated with a DTD.

Document type definitions

Document type definitions contain declarations that describe document structure using a formal notation.
They define the names of elements and attributes and the document hierarchy.

DTDs specify which elements can or must be contained in a document and their allowable sequence and
combinations. They are often separate files with the extension ‘.dtd’, but declarations can also be included
wholly within the XML or SGML document itself as part of the document type declaration.

A DTD can consist of one or many files. Some DTDs use parameter entities to “call in” blocks of declarations
that exist in other files.

XML Schemas

XML Schemas are similar to DTDs in that they describe a document structure, but they are written in XML.
They also provide flexibility in defining complex data types. Schemas are supported in XML only.

A Schema is always a separate file with the extension ‘.xsd’.

Document type declarations
Document type declarations associate XML documents with a DTD. They consist of an external identifier, an
internal subset, or combination of the two.

Here is an example of a document type declaration:

<!DOCTYPE BOOK
PUBLIC "-//XYZ Corporation//Book v1.0//EN" "book.dtd">

The document type name follows the DOCTYPE keyword (in this case, ‘BOOK’). By default, this is the top-
level element in the DTD.
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A document that refers to a DTD or Schema is referred to as a document instance.

External identifiers
The document type declaration can include an external identifier that specifies an external DTD file.

External identifiers consist of either of the following:

• The SYSTEM keyword followed by a system identifier

• The PUBLIC keyword followed by a public identifier followed by a system identifier

The system identifier can be a filename or URL and is generally the filename of the DTD (for example,
‘book.dtd’). The public identifier is an arbitrary identifier that is agreed upon by the various organizations that
use the DTD (for example, ‘-//XYZ Corporation//Book v1.0//EN’). If the external identifier starts with SYSTEM,
there cannot be a public identifier.

Here are two document type declarations that refer to the same DTD:

<!DOCTYPE BOOK SYSTEM "book.dtd">

<!DOCTYPE BOOK PUBLIC "-//XYZ Corporation//Book v1.0//EN"
"book.dtd">

Another form of external identifier is available for SGML documents only, in which the PUBLIC keyword is
followed by a public identifier, but no system identifier. Here is an example:

<!DOCTYPE BOOK PUBLIC "-//XYZ Corporation//Book
v1.0//EN">

Public identifiers can be mapped to system identifiers using a catalog file.

Internal subset
An internal subset is an optional part of the document type declaration that contains additional declarations.

The internal subset follows the external identifier (if there is one) and is enclosed in square brackets. Here
is an example of an internal subset:

<!DOCTYPE Article SYSTEM
"journalist.dtd" [ <!ENTITY Title "The History of the XYZ Corporation">
... ]>

Declarations in the subset are read before declarations in the external DTD file; therefore, they override any
external declarations of the same name. Attribute list declarations specifying different attributes of the same
element are combined, but if the same attribute is specified in both places, the specification in the internal
subset takes precedence.

A document type declaration can omit the external identifier. In this case, the document’s DTD is internal
(contained completely in the internal subset). Here is an example:

<?xml
version="1.0" standalone="yes"?> <!DOCTYPE Article [ <!Element Article
(Title, Sect1+)> <!Element Title (#pcdata)> <!Element Sect1
(Title,Para+)> <!Element Para (#pcdata)> <!Attlist Article Id ID
#IMPLIED> ]> <Article> ... </Article>
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Elements
An element is a markup construct that consists of tags and content. Tags are written using angle brackets
(‘<’ and ‘>’) and contain element names. Elements are named according to their function in the document.
For example, the <section> element describes a section. Elements can include attributes, text, or other
elements. The elements available in your document and the sequence in which they must appear is defined
in a DTD or Schema.

Since documents are formatted differently by each rendering agent (for example, a browser), you may prefer
to think of elements as standing for parts of the document’s structure (for example, heading, paragraph, list
item) without thinking explicitly about how they are formatted.

In DTDs, an elements are defined using the ELEMENT keyword.The following sample defines topic, title,
and para elements:

<!ENTITY % typemods "b|i|u|pre|tt"> <!ELEMENT
topic (title, para+) > <!ELEMENT title (#PCDATA) > <!ELEMENT para
(#PCDATA|%typemods;)* >

Here is a corresponding document instance:

<!DOCTYPE topic SYSTEM "topic.dtd"> <topic>
<title>My sample topic</title> <para>The first
paragraph.</para> <para>The second paragraph.</para>
</topic>

In XML, element names are case-sensitive. The following samples represent different elements:

<Topic>...</Topic>
<topic>...</topic>

The following markup is illegal:

<Topic>...</topic>

Empty elements

Elements can also be defined as empty. These elements cannot have any text content. Here is a sample
definition of an empty element in a DTD:

<!ELEMENT newpage EMPTY >

Empty elements appear differently in XML and SGML.

<!-- an empty
element in XML --> <newpage/>

<!-- an empty
element in SGML --> <newpage>

Attributes
Attributes consist of name/value pairs that are used to provide more information about an element. Attribute
values are not part of an element’s content. The DTD or Schema specifies attribute names and allowed
values.
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In DTDs, attributes are defined within attribute lists, which are declared using the ATTLIST keyword. In the
following example, an attribute list defines an audience attribute for the topic element:

<!ENTITY % typemods "b|i|u|pre|tt"> <!ELEMENT topic (title,
para+) > <!ATTLIST topic audience CDATA #IMPLIED > <!ELEMENT title
(#PCDATA) > <!ELEMENT para (#PCDATA|%typemods;)* >

Attribute names are separated from the element name by a space, and values are enclosed in quotation
marks. Here is a corresponding document instance:

<!DOCTYPE topic SYSTEM "topic.dtd"> <topic
audience="administrators"> <title>My sample topic</title>
<para>The first paragraph.</para> <para>The second
paragraph.</para> </topic>

In XML, attributes and their values are case-sensitive. The following samples represent different attributes
and values:

version="beginner" Version="beginner"
version="Beginner" Version="Beginner"

Data types and default values

Here are some commonly used attribute data types:

• CDATA describes a sequence of characters from the document character set and may include character
entities.

• ID/IDREF are identifiers. The value of an ID attribute is used to identify an element and must be unique.
The value of an IDREF attribute must be the value of an ID attribute somewhere in the document.

• NUMBER tokens must contain at least one digit (0-9).

Attributes can also be defined as a name token group that restricts the possible values to a list.

Default values for attributes are defined by the default value parameter. Here are some commonly used
parameters:

• REQUIRED means that a value must be specified.

• IMPLIED means that specifying a value is optional.

• FIXED describes a fixed value for an attribute. The value cannot be modified.

Entities
An entity is a named body of data that you can refer to from within your document. An entity declaration
names the body of data and its replacement text or file reference. Entities are declared within the DTD or
your document’s internal subset.You can refer to the declaration from within your document using an entity
reference. When the document is displayed in a rendering agent, the entity reference is replaced by the text
or file that the entity represents. Entities are an important mechanism for supporting content reuse and data
management. In XML, entity names are case-sensitive.

Text entities

Text entities specify replacement text within the entity declaration itself. This type of entity is useful for
“boilerplate” text or for terms that may change, such as product names or version numbers. For example, in
the following user manual, the name of the product is declared as ‘Z2000’ in the prodname entity. For
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subsequent model numbers, you need only change the replacement text to have the change reflected
throughout the document.

<!DOCTYPE manual
SYSTEM "manual.dtd" [ <!ENTITY prodname "Z2000"> ]> <manual>
<chapter> <title>Installing the &prodname;</title>
<p>The &prodname; is easy to install.</p> </chapter>
</manual>

External entities

External entities refer to text and markup that exists within an external file. In SGML, external entities include
a system identifier or a public identifier or both. XML requires a system identifier, and a public identifier is
optional. Here are some examples:

<!ENTITY copyright SYSTEM "copyright.txt" --
a copyright notice containing a block of text -->

<!ENTITY section SYSTEM "section.xml" -- a
section containing text and markup -->

Graphic entities

Graphic entities are used to refer to image, video, sound, or other multimedia files. These entities are not
parsed and they must specify a notation. Notations specify how the file is encoded. Here is an example of
an unparsed entity declaration and corresponding reference:

<!DOCTYPE chapter [ <!NOTATION JPEG
SYSTEM "Joint Photographic Experts Group"> <!ENTITY dogpic SYSTEM
"lassie.jpg" NDATA JPEG> ]> <chapter>
<title>Dogs</title> <img src="colliepic"/>
</chapter>

Character entities

Character entities are used to represent certain typographical characters, such as symbols and accented
letters, that are not normally found on US keyboards. For example, the character reference &#x2026;
represents an ellipsis (…). Numeric character entities do not have to be declared in XML documents because
they are included in the XML specification.

Note:  Named character entities, for example, &hellip;, must be declared in the DTD.

Parameter entities

Parameter entities are used to insert declarations. The internal subset can refer to an external DTD using a
parameter entity reference. In the following example, ‘%journalist;’ causes the declarations in journalist.dtd
to be parsed just as if they were included in the file.

<?xml version="1.0"?>
<!DOCTYPE Article [ <!ENTITY % journalist SYSTEM "journalist.dtd">
%journalist; ]> <Article> ... </Article>

Many DTDs also use this mechanism to “call in” blocks of declarations. In the following DTD, ‘%topic-type;’
causes the declarations in topic.mod to be parsed just as if they were included in the file.

<!ENTITY % topic-type PUBLIC "-//XYZ
Corp//ELEMENTS Topic//EN" "topic.mod"> %topic-type;
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Related Links
Internal subset on page 236

An internal subset is an optional part of the document type declaration that contains additional
declarations.

CDATA sections
A CDATA (character data) section is a type of marked section that is used to prevent content from being
interpreted as markup. A marked section is a markup construct that designates content for special processing.

For example, the following document includes an sample code that contains markup characters (‘<’ and ‘>’).
In this case, you do not want these characters to be interpreted as markup, so you enclose them in a CDATA
section.

<?xml version="1.0" encoding="UTF-8"?> <technote>
<title>Audience attribute</title> <para>The audience
attribute describes the intended audience. It is defined for the TOPIC element.
Here is an example: <![CDATA[<topic audience="administrators" />]]>
</para> </technote>

Note:  SGML files can have several types of marked sections, but XML files can have only CDATA
sections.

Comments
Comments contain additional information about the text or markup. They are ignored during processing.
Comments can contain text only.

The following sample XML document includes a sample comment.

<?xml version="1.0" encoding="UTF-8"?> <!--
here is a comment in an XML document --> <topic> <title>My
sample topic</title> <para>The first paragraph.</para>
<para>The second paragraph.</para> </topic>

Comments in DTDs have a special syntax.

<!ELEMENT para
(#PCDATA|%typemods;)* -- here is a comment in a DTD -->

Processing instructions
Processing instructions contain instructions for applications.

The following processing instruction identifies the document as an XML 1.0 document that uses Unicode
encoding.

<?xml version="1.0"
encoding="UTF-8"?>
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Appendix B: W3C XML Inclusion (XInclude) Support

XInclude allows you to create larger XML documents from smaller documents without needing to manually
duplicate content.

With XInclude, you can assemble multiple XML instances into a larger XML document through inclusion.This
allows for easier editing using smaller files, improved distributed authoring, and reuse of content.

In XMetaL, XInclude support is turned off by default. For information on enabling XInclude, see the XMetaL
Developer Customization Guide.

About W3C XInclude Support 1.0 (Second Edition)

W3C XInclude Support 1.0 (Second Edition) introduces a generic mechanism for merging XML documents
for use by applications that need such a facility. The syntax leverages existing XML constructs - elements,
attributes, and URI references. For more information on W3C XInclude Version 1.0 (Second Edition), go to
http://www.w3.org/TR/xinclude/

XInclude Customization Features

Depending on your customization of XMetaL Author, you may be able to update, show, hide and/or open
XIncluded target content.

• Updating XIncludes will import that target content and process it in accordance to the W3C XML Inclusion
specification. Any processing errors are listed within the XML Inclusion log pane. The target content's
physical location can be either on the local file system or within your CMS (provided you have an XMetaL
Connector).

• Showing XIncludes allows you to view the target content inline with the rest of your document.When includes
are shown inline, they are in read-only but you are permitted to make selections and copy the content.

Note:  Showing includes does not automatically update the includes if you have made changes to the
target content.

• Hiding XIncludes allows you to edit the include element's attributes or fallback element.
• Opening XIncludes opens the files that contain the target of an xinclude's link.

XML inclusion log

The XML inclusion log is a list of XML inclusion link errors. The XML inclusion log is displayed in the Link
Errors pane of the XMetaL Author user interface. Clicking on a link error displays the error in the main pane.

Limitations and Variations

The XML Inclusion support has the following limitations:

• For parse="xml", included target markup must be defined by the top-level source document's schema or
DTD. Furthermore, appearance in Tags On/Normal view is determined by the top-level source document's
customization (i.e., CSS and CTM settings).

• XPointer has the following limitations:

• The xptr-xpointer scheme is built on the XMetaL xpath capability and supports whatever XMetaL supports
for xpath.

• The xptr-xpointer scheme does not support additional functionality described in 4.2 Additions to XPath
Terms and Concepts of http://www.w3.org/TR/xptr-xpointer/.
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• Limited support for range-to:

• Supports node-to-node (inclusive) range only (subsequent steps can remove start/end node).
• If the start point returns a node set, the last node in the node set is used as start point.
• If the end point returns a node set, the first node in the node set is used as end point.
• Start point and end point must be siblings.
• The system handles form: /..../range-to(Expr)/....
• The system does NOT handle form: /...../range-to(Expr)Predicate*/.... However, there is a partial

workaround: /....../range- to(Expr)/self::node()[Predicate]/....,

Note: The above workaround cannot handle cases related to positions, e.g., 2nd node within the
range.

• parse="text" is wrapped with a CDATA section for inline display within your editor. The CDATA tags are
removed when you exporting the content.
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Appendix C: XMetaL Licensing Server

The XMetaL Licensing Server includes an user interface to allow for administration of your license server and
licenses.

Installing XMetaL Licensing Server

1. Launch the installer, and click through the setup wizard, taking into account the following.

2. On the End-User License Agreement screen, select the check box to agree to the end-user license.

3. On the Destination Folder screen, select the destination folder manually or by browsing for it.

XMetaL License Server is now installed on your computer.

Using XMetaL Licensing Server Admin
The user interface consists of two tabbed views, for administration of the licensing server as well as for the
contents of the user licenses+.

License Server

The license server tab includes the following items:

Floating Licenses List - displays all active and inactive, floating licenses. For each licenses the following
information is displayed:

• Product - the XMetaL product to which the license applies

• Maintenance End - the date at which the product maintenance period expires

• Quantity - the total count of licenses of this type

• In Use - the total count of licenses of this type that are currently active

Administrators can perform the following actions on this list:

• Refresh - displays the latest list of floating licenses

• Add Licenses - allows you to add license files to the License Server's database

• Remove Licenses - allows you to remove license files from the License Server's database

Settings - allows administrators to modify the following settings:

• Host Name - displayed as read-only

• Port - displayed as read-only

• Modify - click this button to edit the Host Name or Port number

• Start Service - starts the licensing server

• Stop Service - stops the licensing server

Stopping and re-starting the service is beneficial, for example, if a client has crashed while XMetaL was in
use, and the license may not have been released. In this case, stopping and starting the service frees up
these licenses without needing to wait for the server to do so.
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User License

This view displays the user license file contents. Administrators can perform the following actions:

• Save to File - saves the license file to a location of your choice

• Copy Server Address to Clipboard - copies the URL to the clipboard, to allow for sharing of the server
address
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Glossary

A value that is associated with an element but is not part of the content of the
element.

attribute

An element whose content is preceded and followed by line breaks.block element

A program that communicates with Web servers and is used for retrieving and
displaying documents from the World Wide Web or an intranet. Most browsers use
a graphical interface to provide access to text, images, audio, and video.

browser

A widely used DTD for table markup, described in the U.S. Department of Defense
SGML standard MIL-M-28001B. XMetaL Author supports a definition of the CALS
DTD developed by the OASIS consortium and described at www.oasis-open.org.

CALS table model

A way to specify document formatting that is supported by browsers. XMetaL uses
cascading style sheets to format the document pane in Normal and Tags On views.

cascading style sheet
(CSS)

A cascading style sheet generally consists of one or more rules that define element
appearance. These style sheets are said to be cascading because several style
sheets can be applied to the same document. See www.w3.org for more information.

One or more files that map external identifiers for DTDs, rules files, or entities to a
filename. Also called OASIS catalog files. For more information on catalog files,
see OASIS Technical Resolution 9401:1997.

catalog files

Character data. A type of content in which any markup delimiters (such as ‘<’ and
‘&’) that appear are treated as ordinary characters.

CDATA

A markup construct beginning with the characters ‘<![CDATA[’ and ending with
‘]]>’, inside which all content is treated as character data.

CDATA section

An expression in a DTD that defines the content of a particular element.content model

The element containing the insertion point or selection. If an entire element is
selected, the current element is the parent of that element, not the selected element
itself.

current element

A set of files that determines the formatting and authoring functionality in XMetaL
Author. Customizations can be applied at the document level or at the application
level.

customization

Document type declaration. A declaration that associates an XML or SGML
document with a DTD, and may contain additional markup declarations.

DOCTYPE declaration

The Document Object Model (DOM) is an abstract definition of an API (application
program interface) for manipulating XML document structures. The DOM is a

Document Object
Model (DOM)

Recommendation of the World Wide Web Consortium (W3C), developed and
maintained by the W3C DOM Working group. XMetaL follows the DOM Level 1
Specification. The DOM was designed to represent XML structures, but can
represent SGML structures (such as CALS tables) if they are also found in XML.

Document Type Definition. A set of definitions, written in a formal notation, that
defines the structure and content of a document.

DTD

The building blocks of XML and SGML documents. Elements are named according
to their function in the document, for example, headings, lists, and paragraphs.

element

An element that cannot have any content.empty element

A named body of data that you can refer to from within a document.entity
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A reference, using a specific syntax, to an entity. When the document is displayed
in a browser or editor, the entity reference is replaced by the text or file that the
entity represents.

entity reference

A type of entity that represents another file.external entity

A way of identifying an external file. External identifiers can appear in a document
type declaration and in external entity declarations, where they identify the external

external identifier

file that the entity refers to. In SGML files, external identifiers can consist of a system
identifier, a public identifier, or both. In XML files, external identifiers must contain
a system identifier, which may be preceded by a public identifier.

A file that associates external identifiers with filenames on the system.external identifier
map file

An element that is inserted following the occurrence of a specific element.
Followed-by elements are configured in XMetaL Developer as part of the
customization (.ctm) file.

followed-by element

A data-entry interface usually associated with specific elements in an XMetaL
document. Forms are designed in the XMetaL Forms Toolkit (XFT) either as dialog

form

boxes that are launched from an XMetaL macro, or as content that appears as part
of an element.

These can be text entities, external entities, or graphic entities.general entity

Text that is not part of the document content, but is generated by a display program
and displayed at the beginning or end of an element’s content.

generated text

A type of general entity that represents an external multimedia file, for example, a
graphic, video, or audio file.

graphic entity

Text that can be used to link to another document or another location in the same
document. The viewer can display the linked document or location by clicking the
text.

hypertext

A unique identifier. The value of an ID attribute must not be used for any other ID
attribute in the document.

ID

A reference to an ID. IDREF attribute values do not have to be unique; more than
one IDREF can refer to the same ID.

IDREF

An ActiveX control that is embedded in the Normal and Tags On document panes
in XMetaL Author or XMetaL XMAX, and communicates with XMetaL Author or

in-place control

XMetaL XMAX so that changes in the control can modify the document, and vice
versa.

An element that does not have a line break before or after its contents. They are
often used for typeface modifications.

inline element

An optional part of the document type declaration that may contain markup
declarations.

internal subset

International Organization for Standardization.ISO

The character set for special or accented characters that is widely used in HTML
documents. This character set is also called ISO Latin 1. It includes characters
required for most western European languages.

ISO 8859-1 character
set

A sequence of XMetaL operations that can be run as a unit via a keyboard shortcut,
a toolbar button, or a menu item. Macros can be recorded from within XMetaL

macro

Author, or created by inserting scripting code into a macro file using XMetaL
Developer.
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A markup construct in XML and SGML documents that designates the content for
special processing. The parameters of the marked section specify the type of

marked section

processing. A common use of marked sections is to cause a portion of the document
to be treated as text, not markup.

Keywords that determine how to process a marked section in an SGML document.
The available keywords are INCLUDE (process the section normally); IGNORE (do

marked section
parameter

not process the section); CDATA (treat elements and entity references in the content
as text, not markup); RCDATA (treat elements in the content as text, not markup);
and TEMP (the section is temporary).

Special instructions or indicators in a document that specify how the enclosed
content is to be processed by an application. Element tags are an example of
markup.

markup

A macro file. An MCR file is an XML-based customization file containing XMetaL
macros, or scripts.

MCR file

The mini-template contains elements and prompt text that you can replace with
your own content.

mini-template

A feature of XML that permits documents to contain identically-named elements
defined in more than one DTD or schema.

namespace

A declaration in a DTD that specifies a file format that can be used for files
represented by graphic entities. For example, if GIF files are to be used, a notation
declaring the GIF format must be present in the DTD.

notation

Organization for the Advancement of Structured Information Standards, a consortium
dedicated to promoting structured information standards such as XML and SGML.
For more information, see www.oasis-open.org.

OASIS

An entity that is used to insert declarations in a DTD or internal subset.parameter entity

Parsed character data. The most common form of text content in XML and SGML
documents. In PCDATA text, any markup, such as element start and end tags and
entity references, is interpreted with its normal meanings.

PCDATA

Saving an XML or SGML file so that it is easily readable in Plain Text view by adding
whitespace, for example, by indenting lists to reflect a nested structure.

pretty-printing

Elements that are formatted to look like the HTML <PRE> element; that is, with all
whitespace preserved exactly as it was entered.

PRE-like elements

An instruction that is not interpreted as part of the document’s content, but rather
interpreted by an application that is processing the file.

processing
instruction

A system-independent string that is used to represent a DTD or entity file. Part of
an external identifier.

public identifier

Replaceable character data. SGML files can have RCDATA elements and marked
sections, in which any element start- or end-tags that occur are interpreted as text,
but any entity references are interpreted in the normal way.

RCDATA

A file on an http or Web server.remote file

An attribute that must be present in order for the document to be valid.required attribute

An element that must be present in order for the document to be valid.required element

An XMetaL feature that ensures that you do not break the required structure as you
edit your document; it does this by allowing you to insert only valid elements. Rules

rules checking

checking is less stringent than validation in that it checks that no errors have been
made, but does not check that the markup is complete.
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An XMetaL-specific alternative to a DTD. All of the files comprising a DTD are
compiled into a single binary rules file. Rules files can be issued to XMetaL users
who are not authorized to modify the DTD.

Rules file

An XML standard for defining the structure, content, and semantics of an XML
document.

Schema

A type of text entity whose content is specific to a particular processing application
or platform.These entities are often used to represent platform-specific characters,

SDATA entity

and codes for formatting systems (such as troff or TEX). SDATA entities are
permitted only in SGML files.

In a cascading style sheet, a selector is an expression, representing one or more
elements, that a style property can be associated with. A selector can represent an

selector

element, several elements, an element with a specific ancestor, an element in a
particular class, etc.

A group of elements that is not marked up with one of the supported table models
(CALS and HTML) that can be formatted as a table.

semantic tables

Structured General Markup Language. A standard for describing the structure of a
document using markup. SGML is described by the ISO 8879 standard 1986).
HTML and XML are applications of SGML.

SGML

An SGML declaration is a file associated with a DTD that contains information about
the character set, markup delimiters, quantity settings, and special markup features
that are available in documents that use that DTD.

SGML declaration

The variable that is used to represent the folder in which XMetaL is installed.SQDIR

An XML document that an application can parse without referring to an external
DTD. A standalone document may still require a DTD in some situations, for
example, if it is being edited.

standalone document

Part of an external identifier. A system identifier is generally the filename of the file
(for example, a DTD or entity set) that the external identifier refers to. In XML

system identifier

documents, system identifiers are required in external identifiers, and are interpreted
as URLs.

An element begins with a start-tag (for example, <PRE>) and ends with an end tag
(for example, </PRE>).

tags

Toolbar file. Toolbar and menu customizations are saved in TBR files.TBR

A type of general entity that stands for one or more text characters.text entity

A standard for electronically encoding the characters of many of the scripts used
to write the world’s languages, as well as special symbols such as mathematical

Unicode

symbols. Unicode is the character encoding specified by XML. For more information,
see www.unicode.org.

Uniform Resource Locator. A URL is the address of a file, written in a format that
can be interpreted by a Web server.

URL

An XML or SGML document is valid if it conforms to the rules in the DTD or Schema.valid document

World Wide Web Consortium, an industry association for the development of World
Wide Web technologies. For more information, see www.w3.org.

W3C

World Wide Web Distributed Authoring and Versioning, the Internet Engineering
Task Force standard for collaborative authoring on the Web. WebDAV is a set of

WebDAV

extensions to the Hypertext Transfer Protocol (HTTP) and Secure Hypertext Transfer
Protocol (HTTPS) that facilitates collaborative editing and file management between
users located remotely from each other on the Internet.
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An XML document that is structurally correct according to the XML standard.There
are several aspects to well-formedness, the most important of which are: the

well-formed
document

document must have only one top-level element, and all elements must be properly
nested.

One or more space, tab, carriage return, or line feed characters, in any combination.whitespace

This is a generic term for the collection of Web servers and browsers. Usually
abbreviated as WWW, or simply called ‘the Web’.

World Wide Web

Extensible Markup Language. An application of SGML that describes the structure
and content of a document. Originally designed for displaying content over the

XML

Internet. XML is an initiative of the W3C. For more information, see
www.w3.org/XML.

A processing instruction that appears at the start of an XML document. This
processing instruction indicates the XML version being used, and may specify the
character encoding and whether the document needs an external DTD.

XML declaration

Extensible Stylesheet Language: Transformations. A language for describing how
to transform an XML document into another XML document.

XSLT

An element that redefines simple and complex types, groups, and attribute groups
from an external schema. For more information, see
http://www.w3.org/TR/xmlschema-1#modify-schema

xs:redefine
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.bmp files 112

.css files 58, 106

.ctm files 58, 106

.emf files 112

.eps files 112

.gif files 112

.ico files 112

.ini files 55

.jpg files 112

.mcr files 51, 106

.mdb files 127

.pcx files 112

.png files 112

.rld files 58

.rls files 58

.rlx files 58

.svg files 112

.tbr files 23, 106

.tga files 112

.tif files 112

.wmf files 112

.xls files 127

3rd party viewer 233

A

accelerator keys 228
accepting tracked changes 91
access keys 228
adapter configuration file 72
assets

adding objects to an asset folder 50
asset templates 50
creating 50
creating a new folder 50
My Assets folder 50

Attribute Inspector 13, 110
sort 13

attributes 237
case-sensitivity 237
creating in well-formed documents 68
default values 237
finding 77, 92
removing 77, 92
searching for 77, 92
setting values 110
special characters in 110
types 237

autonumbering 37

B

background spell checking 83
automatically correcting spelling 84

background spell checking (continued)
manually correcting spelling 84
turning on 84

Blank XML Document template 58
blue diamond (to denote empty elements) 107
bookmark manager 155
bookmarks 155
bookmarks and comments 155
browse for DTD 61
browsers

adding, for Page Preview 9
associating with buttons on Preview toolbar 9
removing, for Page Preview 9

C

CALS tables 113, 114
caption, in HTML table 115
cascading style sheet editor 26
cascading style sheets 58, 106

:after pseudo-element 37
:before pseudo-element 37
counters 37
extensions 36
left indent property 36
miscellaneous properties 36
prefix options 36
Structure View 12
Structure View options 36
style properties 36
supported properties 38

case-sensitivity 237, 238
case, names 234
catalog files 236
CDATA sections 124, 240
changes

accepting tracked 91
rejecting tracked 91
tracking 91

character data sections 240
character entities 238
characters

non-ASCII 123
special 123

checking markup 103
checking spelling 78, 79, 80, 83, 84

automatically correcting 84
manually correcting 84

closing
documents 60
multiple documents 60

comments 240
displaying 125
inserting 125

configuration file 55
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content
authoring 103

copy full path 62
copy table cells 117
copying text 74
counters

counter-increment 37
counter-reset 37
initializing 37
multi-level 37
styles 37

create
assets 50
macro 51
menu 24
templates 59
toolbar 24

cross-file 93, 94, 96, 97
operation 92

CSS
supported properties 38

current element 107
custom palette, for tag and text colors 11
customization file 58, 106
customizations 106
customizing the user interface 23
customizing XMetaL Author 51, 55
cutting text 74

D

database import 127
choosing databases 127
choosing fields 128
formatting table and element output 130
table joins 129
updating tables 127

databases 127
declaration subset 236
default view, setting 55
definition lists 110
deleting text 74
diamond (to denote empty elements) 107
display properties

supported CSS selectors and elements 38
docked panes 13
docking indicator 13
DOCTYPE 235

internal subset 236
Document Ex 151
document instance 235
document status bar 9
document type declaration 235
document type name 235
document views 9
documents

closing 60
creating 103
linked 70
moving between 62
opening outside XMetaL 62
saving 65

download referenced components 72
dragging-and-dropping text 74
DTDs 235

internal 236
duplicate IDs 96

E

edit
element properties 110

edit as partial document 61
editing

accepting tracked changes 91
rejecting tracked changes 91
source 9
text 74
tracking changes 91

editing documents without a DTD 67
editing options 61
Element List 13, 107
element properties 110
elements

block 107
case-sensitivity 237
changing 107
creating in well-formed documents 67
current 107
empty 107, 237
finding 77, 92
inserting 107
joining 107
read-only 107
removing tags 107
replacing 77
selecting 74
splitting 107
wrapping and unwrapping 107

empty elements 107, 237
enlarging the document pane 20
entities 122, 238

case-sensitivity 238
external 122, 238
for images and multimedia files 122, 238
for special characters and symbols 238
for text files 122, 238
for XML or SGML files 122, 238
graphic 122, 238
naming conventions 122
opening external 122
opening external entities 60
parameter 238
text 122, 238

entity references 238
finding 78
replacing 78
replacing text 75
replacing with text 78

error checking 80
external entities 122, 238
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F

file naming recommendations 65
files

closing 60
creating a blank XML or SGML document 58
creating a blank, well-formed XML document 58
creating from a template 58
creating new 58
DTDs 235
opening 60
opening outside XMetaL 62
printing 71
saving 65
Schemas 235

fill cell attributes 118
find

across files 94
in files 94

Find and Replace 75
find in files 92
find markup

across files 93
find selected text on WEB 167
find text on WEB 167
finding

attribute values 77, 92
elements 77, 92
entity references 78
text 75, 92
text in an element 75
using pattern matching 76

finding a word on Google 143
finding a word on Wiki 143
floating panes 13
followed-by element 106
Formatting toolbar 16
full-screen mode 20

G

generated text
counters 37

graphic entities 122, 238
graphics 112

H

HTML tables 113, 114

I

identifier
external 236
public 236
system 236

images 112
BMP files 112
EMF files 112
EPS files 112
formats supported 112

images (continued)
GIF files 112
hiding 55
ICO files 112
inline 55
inserting 112
JPG files 112
PCX files 112
PNG files 112
showing 55
SVG files 112
TGA files 112
TIF files 112
WMF files 112

importing
databases 127
Excel spreadsheets 127

inline images, showing 55
insert

definition list 110
elements 107
list 110
XInclude 241

inserting
CDATA sections 124
comments 125
marked sections 124
processing instructions 126

inserting elements 107
interface

document views 9
introduction 9
pane buttons 13
panes 13

internal DTD 236
internal subset 236
ISO 8859-1 character set 65

J

Journalist customization 9, 106

K

keyboard shortcut, creating in menus 24
keyboard shortcuts 228
keyboard shortcuts (for lists) 110

L

language settings for spell checker and thesaurus 88
languages 85, 86, 88

setting a default 88
Latin-1 character set 65
licensing 21
linked documents

archiving 70
list items, inserting 110
lists 110

bulleted 110
converting paragraphs to 110

XMetaL Author Help252

Index



lists (continued)
converting to paragraphs 110
converting types 110
definition 110
inserting 110
nested lists 110
numbered 110
sorting 111

local content 110

M

macro files 106
macros 51

associate with a menu item 53
associate with toolbar button 53
create keyboard shortcut for 53
design guidelines 52
files 51
inserting a tab in a table 120
locations 51
managing 51
recording 52
restrictions 52
running 51

Macros toolbar 16
main word lists 85

adding 85
removing 85

marked sections 240
in SGML 124
inserting 124
order of precedence in SGML 124

marking revisions 91
markup

display options 55
source editing 9

menus, custom 23
merging tables 119
Microsoft Access databases, importing 127
Microsoft Excel spreadsheets

importing 127
pasting as tables 120

Microsoft Internet Information Server (IIS) 62
mnemonic 228
moving between documents 62
multiple documents 20
multiple panes 13
multiple-file operations 97
multiple-user settings 23, 51, 55, 106
My Assets folder 50

N

names, case-sensitivity in XML 234
nested lists 110
new document 58
non-ASCII characters 123
Normal view 9

O

online Help 9
Open 60
opening

documents 60
external entities 60
files in WebDAV-enabled folders 62
templates 58

opening document folders
outside XMetaL 62

opening documents
outside XMetaL 62

options
auto-saving 55
backup 55
default extension 55
default template 55
end-of-line 55
File 55
font 55
General 55
most recently used (MRU) list 55
show/hide inline images 55
syntax coloring 55
tab 55
tooltips 55
View 55
word wrap 55

outline view 12

P

Page Preview 9
panes

Attribute Inspector 13, 110
behavior 13
buttons 13
docked 13
Element List 13, 107
floating 13
options 13
Resource Manager 13, 50
Results 13
rules for docking and floating 13

parameter entities 238
pasting text 74
pattern matching 76
personal settings 23, 51, 55, 106
pin 13
Plain Text view 9
Preview toolbar 9, 16
printing 71

headers and footers 71
processing instructions 234, 240

inserting 126
prompt text 107, 126
properties

editing 110
public identifier 236
PUBLIC keyword 236
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Q

quick attribute inspector 69
quick navigation 143
quick navigation tool 143

R

raw code editing 9
read-only elements 107
rejecting tracked changes 91
replacing

elements 77
entity references 78
entity references with text 78
text 75
text with entity reference 75
using pattern matching 76

repository 72
repository adapter 72
repository configuration file 72
repository file

creating 72
opening 72

repository integration layer 72
Resource Manager 13, 50
Results 13
results pane 97

actions 99
buttons 99

Reviewing toolbar 16
revision marking 91
revisions

accepting marked 91
rejecting marked 91
tracking 91

rules checking 103
Rules file 58
rules for pinning and un-pinning 13
running

macros 51

S

sample files 9
saving

documents 65
multiple documents 65
options 55
validating before 65

Schemas 235
Schematron

options 104
validating 104

screen tips 55
SDATA entities 234
Search options 75
search patterns 76
searching 75

for attribute values 77, 92
for elements 77, 92
for entity references 78

searching (continued)
for text 75
using pattern matching 76
within an element 75

separator line
in menus 24
in toolbars 24

services
multiple-file operations 97

settings
multiple users 23, 51, 55, 106
personal 23, 51, 55, 106

SGML 234
comments 240
empty elements 107, 237
entities 122
processing instructions 240
references 234
source editing 9
valid markup 235

shortcut keys 228
showing inline images 55
Smart Insert 103
source editing 9
special characters 123
Special Characters and Symbols toolbar 16
spell check 94
spell checker 79

languages 85
options 80, 85, 86, 87
word lists 79, 85, 86, 87

splitting cells into columns 115
splitting cells into rows 115
splitting table groups 119
splitting tables 119
SQL 127
Standard toolbar 16
Structure View 12, 58
style properties 36
style sheets 58, 106
styles

supported properties 38
symbol characters 123
symbols 55, 123
system identifier 236
SYSTEM keyword 236

T

tab group
horizontal 62
vertical 62

tabbed interface 20
Table Advanced toolbar 16
table caption (HTML table) 115
table cells

contracting spanning 116
copying a selection of 116
entering tab character 120
height (HTML) 121
merging 116
pasting a selection of 116
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table cells (continued)
splitting 116
width 121

table grid lines 113
Table Properties 121
Table toolbar 16
tables 113

auto-suggest 115
CALS 114

change body row to header row 114
proportional column widths 121

captions 115
cell properties 121
column properties 121
column/cell width 121
contracting cells 116
copy cells 117
deleting cells 117
deleting columns 117
deleting rows 117
editing 115
fill series 118
from database 127
header rows 114
HTML 114
inserting 115
inserting caption (HTML table 115
inserting cells 115
inserting columns 115
inserting rows 115
merging 119
merging cells 116
moving rows and columns 115
navigating in 113, 228
pasting from other applications 120
properties 121
properties for a selection of cells 121
row properties 121
row/cell height (HTML) 121
sorting 120
sorting rows 120
splitting 119
splitting cells 115, 116
splitting table groups 119
XML model 130

tag and text color, specifying 11
tag-valid markup 103
Tags On view 9
templates 58, 59
text

finding 75
finding in an element 75
replacing 75
replacing entity references 78
replacing with entity 75

text case
changing 101

Text Case Assistant 101
text entities 122, 238
thesaurus 89, 90

data file 90
languages 90

thesaurus (continued)
options 90

third-party viewer 233
toolbar files 106
toolbars 16
toolbars and menus 23

files 23
locations 23

toolbars, custom 23
tooltips 55
tracking changes 91
treat-as-image 233

U

un-pin 13
Unicode 65
unpin 13
unwrapping elements 107
US-ASCII encoding 65
user word lists 84, 86

adding 86
default 86
entries 86, 87

UTF-8, UTF-16 encodings 65

V

valid markup 235
Validate Document 103
validate references 96
validating markup 103
Validation Log 103
view results 97
views 9
views, setting a default 55

W

WebDAV 62
file caching 62
opening files 62

well-formed documents 67
adding new attributes 68
adding new elements 67

well-formed markup 235
whiteboard 143, 167
windows 13
word count 96
word lists 79

main 85
user 84, 86, 87

worksheet tab
moving 62
scrolling 62

wrapping elements 107

X

XInclude attribute 241
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XIncludes
inserting 241

XMetaL configuration file 55
XMetaL Connector 72
XMetaL Customization Guide 8
XMetaL customizations 58, 106
XMetaL Developer 8
XMetaL Programmer's Guide 8
xmetal.ini 55
XML 234

comments 240
declaration 65, 234
empty elements 107, 237

XML (continued)
entities 122, 238
processing instructions 240
references 234
separation of content and format 234
source editing 9
specification 234
version 234
well-formed markup 235

XML table model 130
XPath

expression 94
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